Chris NottSky Insurance
Results 1 to 11 of 11
  1. #1
    Olliecox's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Marlow, Bucks
    Posts
    26

    A4 1.9tdi AVF weird problems

    Morning

    i am having some rather odd problems with my b6 sport avant and wondered if anyone had the same issues or knew what was wrong, first of all the car has full service history, has been scanned on vagcom with no errors so assume its mechanical failure. In the last 6mths the engine has been making an extremely weird rattle noise from the engine bay, Audi said this was the aircon pump and wanted ridiculous amount to change, the noise is only really apparent if you run the car with the econ light illuminated, with the aircon running the noise is still there but very muted! But in the last week its been acting very odd, the car fails to start first pretty much every morning, starts for a split second then cuts out, and car has started to feel like its got a 1.0l engine and is towing a trailer, I do around 100 miles a day in the car and its been getting worse, no smoke from exhaust or anything like that, however the other day (and this is the weird bit) I noticed by pushing the econ button so was illuminated made the car run like it had been kicked in the backside, it would start in the morning etc, the other weird thing is with the econ light on now the engine won't get to temperature, it runs cold, switch econ light off again and it runs to temperature and stays there no matter what!! Also with econ light on I get the terrible rattle noise! I have been told I can change the belt for a smaller belt to bypass aircon pump for the moment but don't have a clue what belt I should buy??
    The car has a revo remap on it and like I say runs fine with econ light on (apart from cold running issue and rattle) and runs like a bag with the light off and feels really bogged down
    i don't have much money (just moved house) so would like to attempt to fix by myself instead of a garage

    Any help appreciated before I decide to set the car alight!!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    pauldazzle's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Cardiff
    Posts
    639
    Ok I had the same issue with the AC on my AVF. The rattle is being caused by the AC pulley bearings wearing out. You can get a replacement pulley for about £120 from TPS or on German Ebay. Klimakompressor Riemenscheibe Kupplung für Audi A4 A6 A8 TDI | eBay.
    I ran mine with a short belt for a while, but my mechanic fitted it & I've no idea what belt he fitted.
    As for the other issue I would advise you change the Coolant temp sensor with a revised VAG CTS (genuine only) £30ish from dealer or TPS. It's a very common failure, hence the VAG revised part which can cause all sorts of starting & running issues.
    A4 Avant B6 1.9 TDI 130 Sport (6) Moro Pearl Blue, GMBH S Line Kit, Decat, 165bhp remap, EGR delete, K&N panel, Dunlop SP Sport Max, Full Leather, Cruise Control, Full DIS, Bose, Audi phone prep, Cooled Glove Box, Rear privacy glass, Rear parking assist.
    2003 Seat Ibiza 1.2 TSI FR in Lima green.

  4. #3
    pauldazzle's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Cardiff
    Posts
    639
    BTW I think I may still have the short belt which you are welcome to have for the price of P&P.
    A4 Avant B6 1.9 TDI 130 Sport (6) Moro Pearl Blue, GMBH S Line Kit, Decat, 165bhp remap, EGR delete, K&N panel, Dunlop SP Sport Max, Full Leather, Cruise Control, Full DIS, Bose, Audi phone prep, Cooled Glove Box, Rear privacy glass, Rear parking assist.
    2003 Seat Ibiza 1.2 TSI FR in Lima green.

  5. #4
    pauldazzle's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Cardiff
    Posts
    639
    For your info.
    When I first became aware of the rattle I noticed that it was much worse on the econ setting & much quieter with the AC on. However eventually it started to rattle regardless of the which setting the AC was on. I bought a new pulley as above, but the old pulley rubber bearings had all worn to the size of peas, which had caused damage to the pulley mounting shaft so my mechanic had to fit a short belt to get me out of trouble.
    The car was noticeably quicker with the short belt fitted which leads me to conclude that when the bearing completely fails it causes a lot of load which sucks power from the engine.
    With summer looming I bought a used compressor from a scrapper for £55 which is still running fine.
    Last edited by pauldazzle; 23rd August 2013 at 20:36.
    A4 Avant B6 1.9 TDI 130 Sport (6) Moro Pearl Blue, GMBH S Line Kit, Decat, 165bhp remap, EGR delete, K&N panel, Dunlop SP Sport Max, Full Leather, Cruise Control, Full DIS, Bose, Audi phone prep, Cooled Glove Box, Rear privacy glass, Rear parking assist.
    2003 Seat Ibiza 1.2 TSI FR in Lima green.

  6. #5
    deano1978's Avatar
    different gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    near brighton
    Posts
    631
    Same issues i had. Pauldazzle is correct.
    A4 avant b6.1.9 avf 6 speed. Bv43 turbo.uprated fmic. More bhp custom map. Powerflow straight through twin pipes. Allard delete kit. Boost,egt, + voltage gauges. Ball,spring boost controller. Fk silversport coilovers. 312mm brake upgrade. B7 multifunc steering wheel. Full dis. Cruise control. Auto locks. Rs4 rear bumper. Full rs4 grills. Drls + hids. 10inch custom sub + amp. Rear parking sensors. Leds everywhere. Parrotkit full speaker streaming. silver 4d carbon interior.never ending...

  7. #6
    Olliecox's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Marlow, Bucks
    Posts
    26
    Thanks for the reply guys, sounds like I am not the only one to have these issues, Paul sounds very much the same as the problems I have, I will pop into Audi after the bank holiday and order a new coolant temp sender, as its not that expensive its worth trying first for that problem, as for the pump I have heard they can sheer the pulley off from vibration, not sure if that is true, so need to get that sorted ASAP, if you do have the shorter belt lying around I would be more than happy to pay the postage etc to cover me for the short time as with the aircon on now it feels as though the car is turning a dead weight which I suppose is the bearings failing, also uses a lot more diesel with aircon on (more than usual with aircon on) and is a pig to drive!!

    Thanks again

    Really appreciate the help

    Ollie

  8. #7
    pauldazzle's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Cardiff
    Posts
    639
    I found the belt & it's Continental 6PK 1125 you can get an equivalent from DAYCO POLY RIB BELTS PK BELTS - Poly Rib Belt - 6PK1125 &pound11.30 Cambelts, Auxilliary Belts, Drive Belts & Fan Belts Dayco & Gates Poly Rib Belts - 6PK Belts

    If I were you I would avoid the main dealer like the plague. TPS (Trade Part Specialist) supplies VAG parts to the trade & is a bit cheaper, if you say you're a taxi driver they will usually serve you.
    Changing the CTS is easy but a bit fiddly on the diesels, I can talk you through it if you need help.
    A4 Avant B6 1.9 TDI 130 Sport (6) Moro Pearl Blue, GMBH S Line Kit, Decat, 165bhp remap, EGR delete, K&N panel, Dunlop SP Sport Max, Full Leather, Cruise Control, Full DIS, Bose, Audi phone prep, Cooled Glove Box, Rear privacy glass, Rear parking assist.
    2003 Seat Ibiza 1.2 TSI FR in Lima green.

  9. #8
    Olliecox's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Marlow, Bucks
    Posts
    26
    Paul

    Your a star, I really appreciate it, will get a belt ordered and get that on will also have a pop in tps and order a coolant temp sensor, once I have that I may need to call on your to give me a bit of guidance, I am capable with the spanners, may just pointing in right direction

    Cheers again

    Ollie

  10. #9
    Olliecox's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Marlow, Bucks
    Posts
    26
    Paul


    Do you know how the shorter belt should be fitted to exclude the air con pump?
    Should the belt still go around the idler pulley (3) the same way, so coming around the crankshaft pulley (5) straight up onto the idler pulley (3) like in the picture?


    Many thanksimage.jpg

  11. #10
    pauldazzle's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Cardiff
    Posts
    639
    Yes you need to install it exactly as the diagram but omitting the AC pulley.
    A4 Avant B6 1.9 TDI 130 Sport (6) Moro Pearl Blue, GMBH S Line Kit, Decat, 165bhp remap, EGR delete, K&N panel, Dunlop SP Sport Max, Full Leather, Cruise Control, Full DIS, Bose, Audi phone prep, Cooled Glove Box, Rear privacy glass, Rear parking assist.
    2003 Seat Ibiza 1.2 TSI FR in Lima green.

  12. #11
    Olliecox's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Marlow, Bucks
    Posts
    26
    Hi Paul

    Cheers for the help with the belt, all on and sorted the noise straight away, car feels like a different car to drive, with the aircon pump not being on the belt I tried to turn it by hand, very stiff and noise!! So probably making the car rather sluggish
    Gonna pop in tps and get CTS when I get a chance this week so will be calling on you for some fitting advise

    Anybody else who has the noisy aircon pump and car feeling sluggish I recommend as a temp measure fitting the smaller belt omitting the aircon pump, easy job but access is tight unless you fancy putting front in service mode, but does the job until you can get hold of a new or recon pump

    Ollie

 

 

Similar Threads

  1. Weird Problem, Please Help Me!!
    By johal87 in forum A3/S3/Sportback (8P Chassis)
    Replies: 16
    Last Post: 18th July 2009, 11:37
  2. 1.9TDI water pump problem, now non starter
    By kitefright in forum Diesel forum
    Replies: 2
    Last Post: 20th June 2009, 18:52
  3. '02 1.9TDI estate Steering Problems
    By Shawsy in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 3
    Last Post: 31st December 2008, 19:39
  4. weird problem NOT FIRE-ING
    By vw754 in forum Diesel forum
    Replies: 32
    Last Post: 6th April 2007, 20:28
  5. WEIRD PROBLEM NOT FIRE-ING
    By vw754 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 15th March 2007, 11:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO