AH FabricationsVolks Autos
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By bez101

Thread: Hazard lights stuck on.

  1. #1
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152

    Hazard lights stuck on.

    Just wondering if anyone has experienced the same issue as me...

    Basically, my hazard warning lights are "stuck" on...

    I unlocked the car yesterday morning, straight away the hazard warning lights started flashing continuously.
    I thought possibly the alarm was going off and I had a dead alarm siren battery, but it wasn't.

    I started the car, pressed the hazard light button and they went off.

    Throughout the journey the hazard lights would start and go off randomly.
    I thought about possible water ingress due to all the rain we have had lately (plenum drains were cleaned a few months back) - all front carpets.etc were dry.

    When I got home from work, I double checked the plenums and ECU box / seal - all were clear and not showing signs of any water entering the car.

    On the way into work this-morning the hazards were stuck on all the way!
    I pulled over, removed the fuses for the CCM, removed and disconnected the hazard light switch - but they are still on.

    Are there any additional relays / fuses for the hazards, just to make them stop? - the indicators, along with everything else work fine.

    I have thought about the CCM to blame, but it was dry when I checked.

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Just had a quick faff about on my lunch break...
    Removed the drivers lower trim panel (below the steering wheel) - pulled a few fuses / relays.etc which didn't stop the indicators.

    Sounded like the relay may be behind the speedo / instruments somewhere as opposed to being on the hazard switch like the B5.

    Removed a few more relays / fuses.etc but the hazards kept on going!

    I resorted to unplugging a few power and wiring connections until the hazards stopped - found out which one it was, gave it a wipe (looked clean and dry) and left unplugged for 30 minutes or so.

    I have plugged them back in and so far it seems to be behaving (touch wood)

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  4. #3
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    remove the switch

  5. #4
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Quote Originally Posted by bez101 View Post
    remove the switch
    I did remove the switch - didn't make a blind bit of difference!

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  6. #5
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    check for any water round the relays
    there known for leaking through the ecu box

  7. #6
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    My electrical gremlins are back!

    The hazards have been fine for a few days - along with the rest of the car.

    Went out to the car on my lunch break and I have a single (nearside) reverse light on, hit the unlock button and it goes off!
    The car wasn't even left in reverse.

    Going to have to have a proper trawl through things one evening this week - anyone have any suggestions on places to start?

    Cheers!

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  8. #7
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    did you check the ecm for any sings of water

    very comon on the A4

  9. #8
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Yeah, I took off the lower cowling - below the steering wheel - all bone dry, passenger carpet is dry.

    Need to have a proper look around by the sound of things.

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  10. #9
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    remove the ecm it may have got water in it and you cant always tell
    its the unit with the 3/4 big plugs in it

    to the right below light switch

  11. #10
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Quote Originally Posted by bez101 View Post
    remove the ecm it may have got water in it and you cant always tell
    its the unit with the 3/4 big plugs in it

    to the right below light switch
    Thanks bez is it where all the fuses and relays are?

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  12. #11
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    sort of

    its at the side of the fuse box above the bonnet release

    3/4 big plugs in it no relays or fuses in it tho

    post a pic and ill point it out for you

  13. #12
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Quote Originally Posted by bez101 View Post
    sort of

    its at the side of the fuse box above the bonnet release

    3/4 big plugs in it no relays or fuses in it tho

    post a pic and ill point it out for you
    Hi bez, found it!

    Took the thing out, as I tilted it on its side, water started pouring out the corner!

    Took the cover off, its been pretty wet. If dried it all out, but I reckon I will need to replace it.

    The part number I have is 8E0 907 279 E.
    My next question is, if I get a newer unit, can I get one with return home lights? (lights that come on when unlocked)?

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

  14. #13
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    you need 1 from a b6 model only

    iv tried the b7 on b6 and they did not work

    NHN could give you more info on the comeing home lights but thats more sensors etc etc

    next thing is where the water came in ?
    fisrt off is remove the ECU cover as they do let water in the seal goes

    and under the battery pull the bung out if its still in there
    AlexGSi2000 likes this.

  15. #14
    AlexGSi2000's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Liverpool
    Posts
    1,152
    Quote Originally Posted by bez101 View Post
    you need 1 from a b6 model only

    iv tried the b7 on b6 and they did not work

    NHN could give you more info on the comeing home lights but thats more sensors etc etc

    next thing is where the water came in ?
    fisrt off is remove the ECU cover as they do let water in the seal goes

    and under the battery pull the bung out if its still in there
    Thanks a lot for your help bez - the ECM seems to be working ok now, but there were signs of slight corrosion on the PCB and around a few components, so will keep a lookout for a replacement on ebay.

    The water seems to have definitely come from the ECU box area, the seal and box looked fine, but I used a little roof sealant for the time being before I order a new seal.

    2002 A4 Avant Quattro Sport 2.5 V6 TDi - 219Bhp - Votex
    BCS Automotive Turbo-Back - Remap -
    19" RS6 Reps - B6 S4 Brakes - Symphony II+
    - Weitec GT
    - 2001 Honda CBR600-FS1 -

 

 

Similar Threads

  1. hazard lights stuck on
    By mel_man in forum A3/S3 Forum (8L Chassis)
    Replies: 10
    Last Post: 27th July 2010, 19:26
  2. hazard light switch
    By downie in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 1st February 2007, 19:00
  3. Hazard light problem
    By cocain in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 27th August 2006, 21:18
  4. S3 headunit lights stuck on!
    By imported_MattT in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 30th August 2005, 14:17
  5. Hazard light button
    By Siy in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 18th July 2005, 16:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO