Chris NottJMB Retrofits
Results 1 to 11 of 11
  1. #1
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90

    2.5TDI BDG Engine Speed signal

    I just had my brake fluid changed by my local Indy..

    On the way home I tried some spirited braking, just to be sure.. Then my engine light came on and the glow plug light is flashing.

    VCDS scan reveals:

    01126 Engine Speed Signal
    03-10 No signal - Intermittent

    I've checked all the engine measuring blocks, all are within spec, the fuel pump checks out and is getting power.

    I checked my workshop manual and can't find the G28 sender where it's supposed to be, under the coolant expansion tank.

    Where should I be looking?
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    60
    i believe the g28 sender is attached to one of the injectors (underneath the drivers side cam cover)

  4. #3
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    I think that's the needle lift sensor..

    I've ordered a speed sensor and will be getting under the car later tonight. I think it's at the rear of the block on the passenger side, in line with the crank.
    I'll see what I can find.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    60
    Yes, you are correct, the needle lift sensor, but I believe it is the drivers side on a 2.5tdi

    mine has never worked since I had had my car, does not seem to cause an issue

  6. #5
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    I've fixed it (for now)..

    I went out to go looking for the speed sensor, and figured out that its attached to the grey plug mounted on the bulkhead..
    ImageUploadedByTapatalk1371672049.722296.jpg
    I loosened the cable a bit and cleaned the contacts with some DeoxIT from my tiny tube.

    After that I cleared the codes and left it for a few minutes, usually the fault would come back in a few seconds, but not this time..
    So hopefully it was just a wiring fault.

    I've been out and replicated my braking, just to be sure, and it's still clear.

    I'm going to pick up a speed sensor anyhow, just in case it doesn't last.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    60
    Nice onE

    i might try the wiggle technique tomorrow

  8. #7
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    It's gone again.. I drove 50 miles to work with no trouble, then 15 miles into the return, the lights came on again.

    I'll pickup and hopefully fit the replacement at the weekend.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    60
    Let me know how you get on jason

    also does a failure of this sensor cause an engine light to illuminate, if so I think the person I bought my car off has disabled the light, which is a bit naughty

  10. #9
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    Yes, when you turn on the ignition, you should see two amber warning lights on the dash
    An 'engine' light on the top left, a 'glow plug' light on the lower right.

    These should both go out once the engine is running. - if no fault codes are present.

    At the moment, my engine light stays illuminated and the glow plug light flashes to warn me.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  11. #10
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    ARRGH!

    I replaced the engine speed sender, which was a rotten job, very fiddly and very difficult to get my hand and tools into the right place..

    Only to find that the fault is still present.

    So I turned my attention to the socket and wiring from the sender plug to the ECU, I found that if I twisted the wiring slightly, the fault goes away, so it looks like the wire has got hot and gone brittle over the years, so I'll probably have to get hold of some repair wires and splice into the loom to prevent further problems.

    Bah. 40 quid and two hours for nothing.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

  12. #11
    JasonS's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    North Herts
    Posts
    90
    All sorted..

    Water in the ECU sockets..
    How it got there I have no idea, no signs of ingress..

    ImageUploadedByTapatalk1372608935.169277.jpg
    ImageUploadedByTapatalk1372608963.285849.jpg

    Cleaned with WD-40, dried, then cleared codes.. Seems to be running OK now.
    2005 A4 Sport Cabriolet 2.5 TDI
    Previous Audis:
    1997 A6 Avant 2.5 TDI Quattro
    1994 80 Cabriolet 2.0
    1995 S6 2.2t 20v Quattro
    1998 A6 Saloon 1.8t
    1995 A6 Saloon 2.0

 

 

Similar Threads

  1. A3 Engine Speed Sensor
    By K12_RNS in forum General Technical / How To
    Replies: 1
    Last Post: 2nd October 2007, 01:02
  2. Engine Speed Sensor Intermittent ...... HELP
    By 242spot in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 9th April 2007, 23:31
  3. Engine speed drop when using electrics
    By Rich in forum A4/S4 forum(B5 Chassis)
    Replies: 22
    Last Post: 4th March 2007, 16:09
  4. speed signal.
    By ajmackie in forum General Technical / How To
    Replies: 19
    Last Post: 28th October 2004, 17:29
  5. Speed Signal - VW POLO
    By leor in forum In-Car Entertainment
    Replies: 1
    Last Post: 23rd October 2004, 18:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO