Chris NottAH Fabrications
Results 1 to 18 of 18
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9

    Audi S4 B6 - Won't start.. ECU issue maybe?

    Hi folks, I've got a 2004 B6 S4 Avant with what I think might be a mad ECU, and now it won't start - not even turn over.


    It started with the key fob not working the central locking so I had to use the key to start the car. Also occasionally I'd come out to find the hazards flashing but no alarm noise. I took the car to an Audi dealer and bought myself a new key and got the old one recoded and everything seemed fine, although occasionally it would still do the flashing hazards thing.


    Last week, both keys stopped working the central locking which tells me it can't be the keys - one of them is brand new. It would still start on the key though. Now I try to start the car, I get some lights on the dash, the fuel gauge flickers a bit and I can hear a whiring clicking noise (fuel pump maybe?) and then nothing when I turn the ignition.


    I've tried disconnecting the battery and reconnecting. I've tried charging the battery (although it is a new one so I don't think it's that).


    Any ideas folks. ECU fault maybe?? I'm just uploading a video to YouTube so on the off chance it helps I'll post a link once it's up.

    Cheers, Spencer

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,985
    get it scanned for fault codes 1st
    it could be anything

  4. #3
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,985
    the key problem could be your ccm under the passanger seat
    may have got water in there

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Quote Originally Posted by bez101 View Post
    get it scanned for fault codes 1st
    it could be anything
    I'm on it Bez.. I've ordered a cheap one from eBay and see if I can make any sense of it. Failing that I'll have to get my local friendly garage to come up with his cable.. Can't get the car anywhere cos the damn thing won't go :-(

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Quote Originally Posted by bez101 View Post
    the key problem could be your ccm under the passanger seat
    may have got water in there
    Crikey, shows how much I know about my new motor. Didn't even know that existed! I'll have a poke around tomorrow in the light and see there's any sign of water damage. Cheers.

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    If it turns out to be the ECU, any ideas how I identify the correct model? There are a few on eBay which all seem to start 8E0 910 560. Audi S4 4.2 V8 B6/B7 Engine ECU Bosch 8E0 910 560 | eBay One has an R on the end: AUDI S4 B6 4.2 V8 ENGINE ECU 0261208666 | eBay. I've googled and found a C suffix means it's for the cabrio so I don't want that one for sure. I've watched a youtube clip showing how to get to the ECU and it looks damn fiddly!

    Speaking of which, here's my wobbly cam video showing the dash lights when I try to start her 2004 Audi S4 Avant (b6) won't start. ECU maybe? - YouTube

    Thanks, Spencer

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,716
    If the dealer sold you a key because it wasnt working and now its not working again and wasnt needing a key, id be kicking up a fuss, i know how much the dealer charges, hence buying the equipment to make them myself!
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  9. #8
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,716
    When you scan with VCDS you will get the correct part numbers on the modules in your car.

    That vid looks like a flat battery or other bad earth issue...
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Quote Originally Posted by @udi A3 View Post
    If the dealer sold you a key because it wasnt working and now its not working again and wasnt needing a key, id be kicking up a fuss, i know how much the dealer charges, hence buying the equipment to make them myself!
    It wasn't just that, the car only came with one key and having just one that was potentially flakey I didn't want to risk it. I also bought a used one on eBay and got them to swap the key over and code it to get my money's worth. I should have two good keys now.

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Quote Originally Posted by @udi A3 View Post
    When you scan with VCDS you will get the correct part numbers on the modules in your car.

    That vid looks like a flat battery or other bad earth issue...
    Ok great, I guess a lot more progress can be made once I've done that. Fingers crossed the cheap unit I've bought gives me similar results. Pretty sure it's not the batter, I bought a new one a couple of months back and charged it just in case. Bad earth sounds like a bit of a mare to trace if it's that!

  12. #11
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,716
    I just saw your lights go out when you attempted to crank the car... i think... does it crank? if you turn the headlights on and try to crank do they go dim? do you have any immobiliser warning? was hard to see in the vid you posted.
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  13. #12
    5th Gear

    Status
    Offline
    Join Date
    Dec 2006
    Location
    barnsley
    Posts
    932
    i cannot even hear it try and crank
    have you actually looked at the starter motor itself ??? id check the fuses as well for a start ???
    2003 pearlescent black s4 avant tiptronic - milltek exhaust - pre cats removed - remapped ...
    koni adjustable suspension front and rear
    alpine f1 dvi9990 -pxah990 headunit and processor - alpine d511r
    4 x focal 5ws midbass drivers - focal audiom 6w midrange - focal tce tweeters - velodyne df 12 sc servo controlled subwoofer
    3 x phoenix gold zpa 0.5 amplifiers

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Quote Originally Posted by @udi A3 View Post
    I just saw your lights go out when you attempted to crank the car... i think... does it crank? if you turn the headlights on and try to crank do they go dim? do you have any immobiliser warning? was hard to see in the vid you posted.
    Quote Originally Posted by dualmono21 View Post
    i cannot even hear it try and crank
    have you actually looked at the starter motor itself ??? id check the fuses as well for a start ???
    It definitely doesn't crank. I'll take another vid in the light and put that up later but basically the instrument lights light up, you turn the key and everything goes out. When you're done, the instrument lights come back on and you hear a whiring and clicking noise - maybe fuel pump or a/c fan and maybe a relay.. not sure.

    I guess there's so much it could be I really need to get those engine codes but in the meantime here's everything else I can think of that might be relevant:

    - Door key lock still works and seems to set the immobiliser (red light on door flashes)
    - Hazard warning lights work with ignition off (although don't sound right) - don't work with ignition on
    - Radio not working (ign on or off)
    - Lights not working I think (will check again to be sure..)
    - AC controls not working but backlight is on dimly

    In the run up to the problems here are some of the issues
    - Keys stop working, get reprogrammed, work then stop again
    - Randomly come back to car to find alarm sort of going off - hazards, no noise
    - Water ingress at back of car caused by wash wipe. Now fixed and Bose Amp replaced
    - After last service came back with Drivers side airbag light on - garage said they'd probably knocked a cable off and will fix
    - Last week, engine warning light came on - quite a biggie this I guess but I assumed same issue as my golf - i.e. exhaust leak as I can smell exhaust gasses and I do tend to give it too much right foot in 1st!

    That's as much as I can think of on only one coffee! I'll go out and have a poke around the car in a bit and see if I can find any other clues. Once my ODB2 gadget turns up that should shed a bit more light.. VAG Scanner Engine Airbag ABS Diagnostic Scan Tool com VW Seat Skoda Audi Reset | eBay

    Thanks for your effort so far guys - I've definitely found the right forum!

    Cheers, Spencer

  15. #14
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,716
    I still think an earth related issue, last time i had a problem like this was a main broken earth around the battery or from engine to chassis. Or a live cable around battery / starter/alternator.

    All the power is shutting down under any small load. do you have AA home start? could you push it up the road and get them to come out on a breakdown?
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  16. #15
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,985
    i agree with the above
    i didnt look at the video.
    and it still could be the battery
    have you got a mate and some jump leads to try ?

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    Earth issue certainly sounds promising.. The battery I'm not sure about.. I got the RAC to fit a new one a couple of months back although I guess maybe a dodgy alternator might mean it's not charging? Having said that, I charged it up with a mains charger to rule that out and it made no difference.

    To explore the earth possibility, where exactly do I need to look folks? My auto electrical skills are a bit limited (but not non-existent so I'll give it a go!) Also where's the fuse box so I can have a look at those?

    Cheers, Spencer

    PS - Girlfriend has RAC membership (I think with homestart?) so might give that a go.. It won't start mister! I guess they may have an ODB2 diagnostics tool too??

  18. #17
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    South West UK
    Posts
    9
    OK folks, I've found my jump leads and got her going so looks like battery was the issue but a bit confused by a couple of things:
    1) Battery was replaced 2 months ago after the original went flat and RAC man reckoned it was knackered.
    2) I charged it on the mains for half a day (rapid charge) and it still didn't turn over.
    3) Once I got it running I took her for a trip around the block and now the battery seems to have a good charge.. So presumably that points to the alternator doing it's job right?
    4) After starting the car the Engine warning light was gone (had been on the week before) but ESP warning light was on for a bit then cleared itself.

    So what's causing the battery to discharge? Also why does it keep forgetting it's keys? And what's going on with the alarm/immobiliser intermittently going off (or at least hazards going?). Something's still up but at least she's up and running again :-)

    Cheers, Spencer

  19. #18
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,985
    glad its running
    id have the alt and batt checked first off
    the keys will will be down to the batt going dead or loseing power
    get it to a good garage and get it on the batt machine.

 

 

Similar Threads

  1. Audi A3 2.0 TDI won't start
    By johal87 in forum A3/S3/Sportback (8P Chassis)
    Replies: 28
    Last Post: 2 Weeks Ago, 13:11
  2. 99 2.5 TDI - engine cut out and now won't start - timing issue? fuel pump?
    By mattupnorth in forum A4/S4 forum(B5 Chassis)
    Replies: 35
    Last Post: 4th August 2012, 10:43
  3. Audi S3 won't start - No communication with VCDS
    By Scullies in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 23rd June 2012, 11:39
  4. Audi a4 B5 2.5tdi Starting Issue
    By mat_vw in forum A4/S4 forum(B5 Chassis)
    Replies: 8
    Last Post: 16th May 2012, 21:54
  5. Audi A3 - cluster swap, now won't start, help!
    By Endacy in forum VCDS (formerly VAG-COM) forum
    Replies: 10
    Last Post: 20th February 2011, 08:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO