AH FabricationsSky Insurance
Results 1 to 11 of 11
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83

    B6 saloon strange central locking issues.

    Hi all,
    my 2001 b6 sport is having some strange issues lately, since I got the car I have replaced the looms to the front doors and removed the rusted multi plug, however since doing this and curing the front door locks not working the back ones have decided to start having problems.

    i have checked e plugs in the doors and the back ones are in very good shape with no damage and no corrosion at all, so I don't quite understand why I am getting these problems.

    vcds is showing the following errors on the comfort module.
    01562- right rear door won't unlock
    01562- right rear door won't de-sasafe

    ok, so we think there's a locking problem... Think again! Using the fob, drivers door lock and the interior buttons the door locks and unlocks perfectly fine, so I stripped down the door card and checked the wiring inside the door, looks fine too, as a matter of course I sprayed all connections to the locking mech with wd40 to isolate any dampness and also sprayed ALOT into the door lock itself.

    It's morning when I come out to use the car it was locked and the battery was completely flat, its although its possessed it suddenly out of the blue keeps trying to lock itself.

    i have full vcds if there is anything you can give me to disable the auto-lock at least so that I can get on with using the car and not have to worry about it being dead every morning,

    or is this a common problem?

    Also, am I right in thinking that rear right door is the one behind the driver (rhd, uk car)? Sanding at the back of the car looking at it?

    any help much appreciated.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,928
    have you checked for wet damp on pass side carpet footwell

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83
    Just been out and removed the comfort module, opened it up there's absolutely no damp contamination in there, looks perfect carpet and floor are dry as a bone, no water marks etc.

    anything else? Could it be the lock mech not passing back the 'unlocked' signal?

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83
    Another twist of weirdness....
    Opened up vcds and told it to measure group 003, which shows the lock and safe status of each door,
    i unplugged the central locking motor in that door and it still says locked/safe where as the other doors say unlocked/not safe.

    so it's asif the car doesn't even know the door lock has been removed/unplugged. It also doesn't know that the door is open either.

    somebody help me sort this thing out before it ends up on a scrap pile had nothing but problems since buying it, the electrics in the thing are shocking!!!

  6. #5
    Audi Doodah's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Swindon
    Posts
    371
    Magic electron thingies are amazing when it all works but frustrating and baffling when it doesn't! As an electrical technician, I know!

    I was looking at wiring diagrams for the door locks relating to your fault codes, thinking about possible causes. Having re-read your posts though, you say all doors lock/unlock correctly from fob, key and door switch. This makes me think the fault could lie with the comfort module itself, especially if it's locking itself and draining your battery. Something internal could have gone fizz pop and be permanently drawing current from the battery. Fuse 38 and fuse 24 supply power to the comfort module so pulling these will stop the car locking itself and draining your battery. Only a temporary solution, I know!

    Also, do you have rear electric windows and door lights as cars with these features fitted appear to have an extra control module in the rear doors (more things to go wrong)?

    Sorry for not having a solution for you but your problem has got my techie mind ticking!

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83
    When the car is off i am reading no major current drainage, The doors just every so often will attempt to lock (although, already locked). The indicators dont flash which is strange its like the car is trying to deadlock (safe lock) itself without command.

    I've removed the comfort module today, even stripped it out of its casing and the board looks clean, no sign of any damp contamination or any evidence of anything burning out.

    I don't think theres much hope for me, a pretty well established unqualified auto-electrician (i can do pretty much anything i set my mind too), if an actual auto techie cant figure it :D.

    I'm going to try swapping the door lock from my other B6 over the weekend and see if that makes any difference, although i cant see it.

    I am pretty sure now the problem is a short somewhere between the controller and the lock, because even with the lock & door unplugged from the car it still reports "Locked" and "Safe" on that door.

    The car only has the curtesy light, Speakers & Central Locking, no Electric windows or door modules for the rear doors.

  8. #7
    Audi Doodah's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Swindon
    Posts
    371
    Actually an aircraft tech but it's all the same :-D

    I think you are onto the fault when you say a short between controller and lock. To test for this you need a multimeter.

    Disconnect the red plug at the comfort module, 20 pin aka plug 4 and disconnect at the door (20 pin black). Working at the door end, you need to find a good earth (any bit of unpainted metal should do or Pin 7 (brown) on the black plug). Then with the other multimeter lead check for 0 ohms on the following three lines;

    Pin 8 Green/Yellow
    Pin 6 Purple/Green
    Pin 4 Black/Yellow

    These three lines are for door contact switch, locking actuator and actuator 'safe', respectively. If you do get a reading of 0 ohms or similar then that is your fault. It basically means you have a short to earth which simulates a switch closed scenario. You can also use this method to prove that your door lock is good by checking that the same three lines are open circuit with the door open

    Hope this helps!

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83
    Ahh i shal give that a try shortly! Thank you!

    I am making some good ground today, did a test between battery earth & Earth terminal (off the battery) and found that when the car is locked up its still using 1.9 Amps, disconnected the headunit and its using 0.75amps.

    So think i am onto a short in the headunit somewhere or the wiring to it, but will check into that further later.

    I'll report back on my findings re: control module/short

  10. #9
    666markyboy's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Oldham, Manchester
    Posts
    1,089
    Did you get this sorted?? I'm currently working on my sons car which has been stood for 6 months.... the battery was dead and wouldn't take a charge so I've fitted a new battery .... but next day it was flat so I've charged it up again and then today whilst working on it I noticed it automatically locks the doors after a minute or so with no input from the FOB....not good if the keys are in the car.... the car was fine before it was left standing but it has acquired a lot of mold inside though it doesn't seem particularly damp anywhere... another odd thing id the DIS seems to have left and right confused,,, when the drivers door is open the DIS shows passenger door and vice versa... I've pulled fuses 38 & 24 to disable the central locking and will see tomorrow if that's stopped the battery drain ...Where is this Comfort module located ?? I'll inspect that tomorrow
    1999 A3 Quattro 1.8T Pics >>HERE
    2002 A4 Avant quattro 1.9 TDi

  11. #10
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,928
    your problem could be the CCM under the pass front seat
    you say its goin mouldy so water must have got in somewhere
    check the front carpet pass side theres a drain plug under the battery they well known for blocking up and sending wather into the footwell

  12. #11
    666markyboy's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Oldham, Manchester
    Posts
    1,089
    I'll check the module tomorrow... thanks for letting me know where it is... it doesn't seem damp inside but that mold has come from somewhere.. I removed the grommet's in the plenum about 18 months ago when he first got the car so I know that's all clear
    1999 A3 Quattro 1.8T Pics >>HERE
    2002 A4 Avant quattro 1.9 TDi

 

 

Similar Threads

  1. Central locking issue. HELP!!!!
    By Intrepid in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 16th April 2011, 15:15
  2. strange central locking problem
    By swarcup in forum General Automotive Chat
    Replies: 0
    Last Post: 23rd December 2010, 16:18
  3. central locking issues, a6 4.2 quattro 1999 saloon
    By shufti in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 3
    Last Post: 18th June 2010, 17:06
  4. Central Locking Issue!
    By eddie659 in forum RS6 Forum
    Replies: 0
    Last Post: 27th January 2010, 09:40
  5. Central locking issue
    By IainW in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 11th February 2009, 18:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO