Volks AutosChris Nott
Results 1 to 15 of 15
Like Tree2Likes
  • 1 Post By stu_m
  • 1 Post By stu_m

Thread: Audi A4 1.9 tdi 130 S ECON light and temp gauge problem

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14

    Audi A4 1.9 tdi 130 S ECON light and temp gauge problem

    Hi

    Please bare with me as I don't know much about cars


    I have an Audi A4 1.9 tdi Estate 130 sport .. 52 plate, mileage 159,000

    The cambelt, water pump and fresh water/antifreeze was changed.

    The day after I noticed the ECON light was on.

    The mechanic said the light was on due to him draining off the Aircon. This needed to be drained to get to the cambelt etc.

    Is this true??????

    The other problem ...... I drove to London Thursday gone and the temp gauge didn't move from zero ...A 2hr drive.

    The mechanic said this was normal since it was so cold out side. I let it idle and the temp gauge eventually went up, But soon as I put the heaters on and drove down the road the temp needle started to drop back to zero.

    If someone could shed some light on any of these problems, I would be really grateful. I don't really know much about cars and have to take a lot at face value.

    Thanks in advance

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,453
    Hi Dean, welcome to audi-sport.net. I have moved this post into the correct section for you. Im sure the boys will help you out.. Enjoy the forum. x
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP


  4. #3
    5th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Hull
    Posts
    1,440
    the mechanic is fobbing you off!!

    it sounds like your stat is sticking open so not warming up properly

    he didnt need to drain any of the aircon to change the cam belt! if I was you I would find another garage and tell him your thoughts

    you will need to get the aircon regassed he should have done this if he thought he had to drain it as he should have treated it as part of the job

    also he cant have the right gear if he didnt fill the aircon back up which means he has let gas in to the atmosphere which is against the law

    before the cam belt and water pump did it used to get up to temperature ok?

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    Everything was great before the cambelt and water pump was done.

    The Mechanic turned off all the heaters and let it idle, the temp went up between 80/90 but soon as I drove off and put on the heaters, the temp gauge dropped right down to zero.

    So if the Aircon is regas'd the ECON light will go out ?

    Dean

  6. #5
    5th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Hull
    Posts
    1,440
    I would expect the temp to drop a little but not down to zero once the needle starts to move and your driving it should never go back to zero it sounds like he has done something wrong somewhere...do your heaters go stone cold too?

    yeah the climate control will disable the aircon due to there been not enough gas in the system once you get it re gassed it should all work fine again

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    Quote Originally Posted by stu_m View Post
    I would expect the temp to drop a little but not down to zero once the needle starts to move and your driving it should never go back to zero it sounds like he has done something wrong somewhere...do your heaters go stone cold too?

    yeah the climate control will disable the aircon due to there been not enough gas in the system once you get it re gassed it should all work fine again
    No the heaters are blowing warm/hot even when the temp drops down to zero.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    18
    The day after I noticed the ECON light was on.
    I couldnt see it in the post, but have you actually tried pushing the 'ECON' button to see if the light goes out?

    As it may just be turned off, as the light just shows its in 'ECONOMY' mode.

    No the heaters are blowing warm/hot even when the temp drops down to zero.
    Are you sure this is not just totally unrelated, and just a dodgy coolant temp sender, which is very common.

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    Yeah, ECON won't turn off mate. No code for that cts either... The thing is, it was working great until cambelt change. I read earlier that if the water/antifreeze has been drained it can cause the thermostat to stick?????

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    Thanks Stu_m

    Had the Aircon regass'd ECON light went out instanlty .... Also had the thermostat changed for original Audi one and temp gauge is working as it should.

    Top man and once again thanks

    Dean

  11. #10
    5th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Hull
    Posts
    1,440
    No probs

  12. #11
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Who or where was this garage? WHY THE HELL would you degas the aircon to do a timing belt?
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    Who knows mate but it's done now and all fixed .... matter closed and won't be going back there!!

  14. #13
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Eyes peeled for the next victim then !
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    14
    lol yeah

  16. #15
    5th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Hull
    Posts
    1,440
    Name and shame if you can

 

 

Similar Threads

  1. Couple pics of my Audi A4 B6 Sport TDI 130
    By Mr Singh in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 57
    Last Post: 28th September 2011, 17:05
  2. Audi a4 2.0 tdi VERY poor fuel economy and engine starting problems.
    By audi 88 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 2
    Last Post: 26th July 2011, 10:54
  3. Audi A4 1.9 tdi 130 on ebay
    By reggieroo in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 30th September 2010, 16:38
  4. Audi A4 1.9SE TDi 130 2001 (Y)
    By imported_Coullio in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 12th March 2005, 08:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO