Monster MotorsportJMB Retrofits
Results 1 to 20 of 20
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151

    Fitting XCarLink Ipod dock

    Hi All,

    Ordered an XCarlink ipod dock for my A4 cabriolet the other day, and the instructions are not fantastic. Wondered if anyone had fitted this to their car? I have a Chorus, single CD with no CD changer at the minute.
    First question is: which way round do I insert the radio removal keys
    This way, keys.jpgor with the teeth pointing outwards?

    Also, there is a funny red connector which isn't mentioned in the instructions. I presume this is supposed to be connected together?
    red connector.jpg

    And finally, it says to earth it to the radio. How would I do this? A screw anywhere into the metal casing? Or is there some
    specific earthing point with a nut and bolt to attach it to?

    I haven't yet removed the radio (for obvious reasons, I don't want to break the keys/get them stuck!).

    Thanks in advance for any assistance!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    S E Kent
    Posts
    238
    Ok I fitted mine
    keys go flat side towards the doors- so as you have them there.
    mine did not come with that red conector
    I earthed mine to one of the holes in the side of the head unit with a PCM case screw.
    2006 A4 cab

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Thanks for the reply lewie, makes me wonder what that funny connector is, there's no mention of it at all in the instructions.

    Sorry if this is a stupid question, but what is a PCM case screw? Is it something that is already part of the radio or something you had separately and used?

    how long did it take you to fit it? Have you done similar installs before? Is the functionality and sound quality what you expected?

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    S E Kent
    Posts
    238
    Sorry that was supposed to say pc screw- although I think there is a spare screw on the side of the head.
    took me around 30 mins- I have a little bit of experience(on previous cars)
    i think the quality is good, I have an old 8gb nano (dead screen) in the glove box and a MFSW and just have it on shuffle
    i think the hardest bit was feeding the lead into the glove box- I managed it without removing the glovebox though.
    Good luck any questions just ask
    Once you have the head unit outits pretty self explanatory
    2006 A4 cab

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Thanks, it's reassuring to know you've done it! I'm planning on sticking my old 32gb iPod touch in and just leaving it there.
    May have a bash at it on Sunday. How have you fixed the unit in the glovebox, have you screwed it in or sticky pads?
    Is it the 20pin connector that's used?

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    S E Kent
    Posts
    238
    I just wrapped mine in a bit if padding and slipped it behind the air cond unit - with just the 20 pin cable coming out of the top right of the glove box(there is a cut out)
    2006 A4 cab

  8. #7
    ajax1976's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Oct 2012
    Location
    Fife, Scotland
    Posts
    479
    I fitted one in my golf and the instructions said connect the red cable together if you were suffering from interference to the sound. I tried it connected and not connected and it made no difference to the sound quality at all.

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Thanks lewie and Ajax, that's really helpful! The chance of me screwing it up is high, but all the help I'm getting at least reduces that a little :D

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    S E Kent
    Posts
    238
    I'm sure it will be fine- just get on with it :-)
    2006 A4 cab

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    The wife says I faff, you're right I should just crack on!

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Okay, had a bash at it this afternoon and I'm well and truly stuck! Managed to get the radio out, but couldn't work out what was supposed to go where? I have a 20pin socket which is full, and I presume needs to come out and go into the red connector that came with the XCarLink?
    i then have 3 connectors coming out of this which are all attached to each other: blue, green and yellow. I am guessing I detach the blue connector from the 3 and plug this into the black XCarLink socket, and then attach the "dangling" blue connector which was attached to the XCarLink to the yellow and green connectors, and these go into the back of the stereo?

    i think the earthing should be easy, but it looks like I need to remove the glove box to feed through! Is this just a matter of undoing the bolts I can see plus 2 on the passenger side door side behind the pop off panel?

    finally, how the hell do you get the stereo removal keys out once you put the stereo back? One side fell out easily, the other side is jammed!

    Please help!

  13. #12
    ajax1976's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Oct 2012
    Location
    Fife, Scotland
    Posts
    479
    Glove box is easy mate, had mine out today. The two bolts you mentioned under the panel, three along the top edge you'll see when you open it and two underneath(one at either end). Open it up and give it a gentle tug downwards and backwards, once its loose you can slide it down from behind the Alu dash trim.

    Stereo keys, I find it easier to remove them before I slot it back into the dash. You can push the tabs that hold them inwards to release the keys then just push the stereo home.

    Wiring, Do you have instructions for it? I found it dead easy to wire up.

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Hi Ajax,
    Have given up for tonight as I can't see well enough to do it, but glove box sounds okay to do then! Instructions are present but I can't fathom them! I think I've got it sussed now though (does my summary above sound about right?).
    No idea what I've done wrong with the key, tried wiggling it every way possible, just no releasing it!

  15. #14
    ajax1976's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Oct 2012
    Location
    Fife, Scotland
    Posts
    479
    I honestly can't say about the wiring was 4 yrs ago I fitted one and it was into a golf. The fact you're not using a multichanger should make it a bit easier, just means you'll have wiring from the xcar that won't be needed. In the Golf if I didn't have a multichanger it would just be one plug on the xcar to simply plug into the back of the stereo but unsure if the Audi is different.
    Are you trying to remove the keys once its back in the dash? I was trying to say before you slot it back into the dash look at the sides of the stereo and you'll see the mechanism that holds it in and how it works. Simply apply pressure on the spring bit and the keys should come out then slot the stereo back in the dash, no need for the keys for refitting.

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Thanks Ajax, I'll have another look today!
    Does anyone know if I should be putting 3 connectors into the back of the head unit, in the top left socket (as it would be if slotted in the dash)? It only seems to make sense if the 3 conectors(green, yellow, blue) all slot together an then go in this top left socket. Just don't want to blow anything up! :-)

  17. #16
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    S E Kent
    Posts
    238
    I think that right from memory, you unplug that multiplug, plug the red multi into the head then replug the car loom into the red multi??
    Does that make sense?
    The blue plug beaks off into the xcar, is that corrcet its been so long since I installed mine
    2006 A4 cab

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Lewie, thanks for your post, I think that is what I tried to say above, you just managed to say it more succinctly! The instructions are confusing, I think I woul have been better without them! I can't see any other way to do it than how I described, I.e "break" the blue connector away from the yellow and green, plug this into the black connector on the XCarLink, then attach the blue connector on the xcarlink to the yellow and green connectors. These 3 plugs then go into the head unit at the top left, with the 20pin black connector which was originally in the head unit slotting into the red connector provided with the XCarLink.

    lewie, does that sound right? I've managed to remove my stuck key so that's an improvement, and I've almost removed the glove box, I just never get chance to finish a job (2 year old and 4 year old see to that!).

  19. #18
    JAS11N's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2006
    Location
    England
    Posts
    77
    Done this to my B5 RS4 and my mates B6 A4.
    My RS4 has an RSN-E sat-nav and my mate Chris's A4 has a single din chorus.
    (I've not fitted one to my B6 as I bunged an RNS-E in)

    Both connected identical.

    I took pics of the fit on my RS4, so should be the same on your B6 Chorus.

    (I'm quoting below from my build thread elsewhere)

    Remove the iso connector;



    Next up, grab the supplied iso connector block and slide off the blue connector;





    Plug the original iso block into the other end;



    Once I'd routed the units cable to behind the headunit, I needed to attach the two new earth cables. Just removed one of the headunit case t8 torx screws and attached there;



    Next up, the blue plug you slid off earlier needs plugging into the new looms black female connector , the new blue connector on the loom gets slid onto the new iso connector block and plugged into the rear of the headunit,



    As you can see, I had the red connector you asked about. I connected the two and forgot about them.

    Hope that helps.

    Jase...
    2001 Avus silver Audi RS4.
    2004 Silver A4 Avant 1.8T quattro Sport LE.

    1995 Byzanz S2 Coupe quattro - sold.
    1995 A6 Avant 2.5 TDi - sold.
    1993 80 TDI - sold.
    1990 90 2.3E auto - scrapped
    1989 Coupe 2.3E - sold.
    1993 80 2.8E quattro - sold.
    1990 Coupe quattro 20v - sold.

  20. #19
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Jase = legend! You've just validated exactly what I was planning to do, it's nice to get some reassurance though! Not sure why but I only have one Ground wire even though it refers to 2?

    jase, you seem to know a fair bit about the stereo set up? I seem to have patchy radio reception, which I'm guessing is the common problem with the aerial in the boot lid. I was wondering if getting a universal aerial and sticking it next yo the A pillar would work? Anyone on here done this as a quick fix? Anyone know what the aerial socket in the back of the head unit looks like?

  21. #20
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stanley, County Durham
    Posts
    151
    Job done! Once I finally hadd a proper look in the daylight, only took me an hour from start to finish, removing glove box and refitting etc!

    I am officially chuffed to bits :-)

    Thanks for the help everyone

 

 

Similar Threads

  1. Help! Fitting iPod dock. 8E0 857 925 D
    By Alex Suter in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 2nd July 2012, 23:48
  2. Ipod dock (fit in glove box)
    By TM in forum For Sale/Wanted - Audi Parts
    Replies: 5
    Last Post: 4th June 2012, 00:01
  3. iPod Dock Fitting Problem
    By MattyW19 in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 8th April 2011, 00:09
  4. Ipod dock to 3.5mm lead
    By Amchlolor in forum In-Car Entertainment
    Replies: 0
    Last Post: 21st March 2008, 10:17
  5. Fitting the Ipod connector
    By audi_france in forum In-Car Entertainment
    Replies: 1
    Last Post: 6th October 2007, 13:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO