Chris NottEM Tuning
Results 1 to 12 of 12
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    yorkshire
    Posts
    112

    Traction light and glow plug light flashing??

    Hi all, got a problem with my b6 - basically on full lock to the right and when driven forward I noticed sometimes that there is rumble,

    Only does it sometimes, today it did it on full lock and the traction control light has come on - switched the car off and now traction light is on and the glow plug light has started flashing?

    Any ideas what this can be?

    Car drives fine, brakes are fine, brake lights are ok also...

    Please advice.
    2004 A4 1.9 TDi Sport Avant Quattro - HiD's - FULL RECARO LEATHER - S4 Mirrors - Cupra R Splitter - Heko Wind Deflectors

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    yorkshire
    Posts
    112
    Forgot to mention this is not on my Quattro, it's on a normal b6!
    2004 A4 1.9 TDi Sport Avant Quattro - HiD's - FULL RECARO LEATHER - S4 Mirrors - Cupra R Splitter - Heko Wind Deflectors

  4. #3
    Neutral

    Status
    Online
    Join Date
    Oct 2012
    Posts
    71

    Traction light and glow plug light flashing??

    Hey I'm new to the forum. Glow plug symbol's flashing on my 2003 A3 and it's giving the fault code 16955, I think my brake light switch is at fault so I'm going to replace it. They're cheap to buy and pretty easy to change though haven't got round to doing it yet. My brake lights still work so assuming the switch is on the way out and not knackered yet.

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    yorkshire
    Posts
    112
    I had this once on my bora but the brake lights weren't working - changed the switch all was fine!

    But now my lights are working and everything seems to work also
    2004 A4 1.9 TDi Sport Avant Quattro - HiD's - FULL RECARO LEATHER - S4 Mirrors - Cupra R Splitter - Heko Wind Deflectors

  6. #5
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    It all points towards the brake light switch, ideally you want to get it scanned, but if you can't I'd change that first off.
    Ingolstance Read about my A6 HERE.

  7. #6
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    Mine done this before I sold it and noticed my brake lights had failed
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Wigan
    Posts
    178
    yep i changed replaced the duf bulb and was fine after this

  9. #8
    scottshere's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    South Yorkshire
    Posts
    337
    Shaz did you fix this problem?
    I see from other posts that this could be from the grommets being blocked and water running down into the car

    Mine started with this problem tonight and no rain so im hoping its the brake light switch or a bulb out, not an ECU problem
    A4 1.9TDI Sport - 130 (B6) / Mods: None yet, just getting the basic right first

  10. #9
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    Quote Originally Posted by scottshere View Post
    Shaz did you fix this problem?
    I see from other posts that this could be from the grommets being blocked and water running down into the car

    Mine started with this problem tonight and no rain so im hoping its the brake light switch or a bulb out, not an ECU problem
    Most definatatly brake switch bud cheap fix when it happens try and catch your brake lights in the mirror
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  11. #10
    scottshere's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    South Yorkshire
    Posts
    337
    Quote Originally Posted by marktdisport View Post
    Most definatatly brake switch bud cheap fix when it happens try and catch your brake lights in the mirror
    Thanks, i just checked today and my brake lights arnt working, the one in the rear window is though... This makes me wonder
    Mate at work says he noticed i had a bulb out last week, so will check them all tomorrow and see if changing the faulty one works
    If not then off to the stealers for a switch...
    A4 1.9TDI Sport - 130 (B6) / Mods: None yet, just getting the basic right first

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    yorkshire
    Posts
    112
    Hi mate, sorry for late reply, yes it was the brake switch, bought it from GSF and fitted myself,

    Thanks to all the guys on here for the advice

    Thanks
    2004 A4 1.9 TDi Sport Avant Quattro - HiD's - FULL RECARO LEATHER - S4 Mirrors - Cupra R Splitter - Heko Wind Deflectors

  13. #12
    scottshere's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    South Yorkshire
    Posts
    337
    Same here.... Fixed mine too yesterday
    Turns out it was a blown bulb !!! Easy fix
    A4 1.9TDI Sport - 130 (B6) / Mods: None yet, just getting the basic right first

 

 

Similar Threads

  1. Uh..oh... Flashing glow plug light and limp mode :(
    By dubdemand in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 38
    Last Post: 2 Weeks Ago, 17:03
  2. Flashing glow plug light and no accellerator!!
    By blucoop in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 20
    Last Post: 16th April 2013, 11:51
  3. ESP Light on and Glow Plug Light Flashing - Car Cuts Out! Help!
    By jay786 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 20
    Last Post: 20th June 2012, 18:39
  4. Replies: 2
    Last Post: 25th November 2010, 16:00
  5. flashing glow plug light and wouldnt run
    By flyingfisherman in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 9th March 2009, 16:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO