Monster MotorsportChris Nott
Results 1 to 9 of 9
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    53

    Engine Warning Light - Have fault codes - don't know if its a concern.

    Hi Guys,

    Posting this I have realised that its been well over a year since I last logged in - which means its been well over a year since my Audi gave me any grief! So that is something to celebrate!

    Any-hoo. About a week ago, whilst pottering along, my engine warning light came on. I've just now had chance to hook-up Vag-Com and pull the codes - they were:

    17544 - Fuel Trim: Bank 1 (Add): System too Lean


    P1136 - 001 - Upper Limit Exceeded


    16891 - Idle Control System RPM: Higher than Expected.


    P0507 - 001 - Upper Limit Exceeded - Intermittent

    I cleared the codes and took the car for a 15 min drive and the engine warning light has not come back on. However I have been noticing a slightly 'lumpy' idle recently (which matches the codes) - if I'm stopped at lights for over 20 seconds or so, the idle speed will drop slightly, rocking the car, before (presumably) the engine management picks up the RPM to stop it stalling, it will over-rev for a couple of seconds before settling back down. This repeats every 20 seconds roughly.

    Anything to worry about? It's due a service in a couple of months, so I'm tempted just to leave it until then, as there is nothing in the codes that hints at a cause.

    Agree? :-)

    Thanks all!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    4th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    765
    What engine?

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Sep 2010
    Posts
    167
    Ive seen these codes on a 1.8t and it was the breather valve in the breather pipe system had failed. There was a lot of vacuum in the oil system esp when the dipstick tube was pulled out a bit. Please confirm the engine to us though
    Last edited by quattro tony; 4th June 2012 at 20:29.

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    53
    Quote Originally Posted by quattro tony View Post
    Ive seen these codes on a 1.8t and it was the breather valve in the breather pipe system had failed. There was a lot of vacuum in the oil system esp when the dipstick tube was pulled out a bit. Please confirm the engine to us though

    Sorry folks, missed out a crucial bit of info there! It is indeed a 1.8T on a 03 plate -engine code BFB I think.

  6. #5
    bowen's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    456
    Try taking the oil cap off with the engine running, if there is suction then there is your problem. Check the crankcase breather valve.
    Audi A4 B7 SE S line TFSI Quattro.

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    53
    Hey,

    I tried to take the oil filler cap off with the engine running - so much suction that I actually physically couldn't - had to lever it up with a screwdriver blade. Tried clamping the tube which comes off the breather valve, and sure enough the suction went away - so I'm pretty sure that's the problem.

    I read on another forum a post recommending replacing the turbo vacuum valve at the same time as the additional pressure in the engine caused by the faulty breather valve can damage it. Has anyone else heard of or recommend this?? Its not a cheap part (compared to the breather valve with is a mere tenner).

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    just the pcv will fix it.
    tho the actual valve is cheap. getting to remove it and disturbing the other breather pipes..... rubber ones be all gunked up and soft and plastic breather pipes go brittle and break too. youll end up spending more than a tenner!

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    53
    So, good news and bad news.

    First the good news, I bought the parts today and fitted the new valve. The job was a complete pain in the arse, even after taking the coolant header tank off you are still constantly working with your wrists bent at angles they were never intended to. No surprise the plastic parts of the L-shape breather pipe fell away like wet cake when I removed the large end from the engine. The small end also snapped off in the rubber T-piece. It took an enormous amount of effort to get the other side of the T-piece off the fixed pipe, not only to remove the fscking annoying one-use clips but also to physically pull it off - took a good 10 minutes of wiggling and swearing. Thankfully once those two were off you are able to pull the T-piece into a better working position to get the last pipe off and pull the valve out.

    Replaced all the parts, used decent quality jubilee clips to put it back together as a favour to myself for the next time I have to do this repair!

    Started the engine, all good, steady smooth idle and no suction on the filler cap. Took it for a spin and everything is feeling normal again, hooray!

    You can see the remnants of the old parts below.


    And the all too familiar broken valve.


    Now the bad news - well, I hope its not too bad, but it's certainly not good. When I pulled the L-shape part of the pipe out of the engine block the plastic part of the join literately disintegrated into bits and while I managed to catch and control most of it, a pinky fingernail sized piece of the soft plastic plunged into the depths of the engine. I spent about 15 minutes with a torch and my fingers inside the engine trying to locate it, but to no avail. I even tried getting the hoover in there to suck it out but all I ended up achieving was ruining my hoover with oil and gunk. Wherever it had got to, it was lodged.

    So how bad is this... its a soft bit of plastic so if it encounters anything mechanical it shouldn't be a problem, my concern is it floating around and eventually blocking something :-/

    What is the in the void directly below where this pipe joins? Should I be worried?

  10. #9
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    hopefully it wont find its way to the oil pick up in the sump.

 

 

Similar Threads

  1. Replies: 2
    Last Post: 20th March 2012, 22:35
  2. ESP light on, then engine warning light... What have I done?
    By j033y in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 24th July 2010, 12:53
  3. Uh-oh.. Engine Warning light came on
    By Mike_P in forum A3/S3/Sportback (8P Chassis)
    Replies: 5
    Last Post: 8th July 2005, 12:11
  4. Help! Engine Warning light on :(
    By edmanning in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 14th May 2005, 19:05
  5. Engine Warning Light
    By Dean_T in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 15th July 2004, 21:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO