EM TuningAH Fabrications
Results 1 to 22 of 22
Like Tree1Likes
  • 1 Post By CHEZ

Thread: Hazard warning switch help!!

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24

    Question Hazard warning switch help!!

    I have a A4 2.5 tdi quattro sport 2001 on the newer shape. I have a problem with my hazard warning lights that i can't fix and ran out of idears.

    You press the switch and nothing happens. I have changed the switch and did not solve.

    Both indcators work normally. If you press the button on the key fob they go on and off as they should. I can't find a fuse gone in the fuse box or one marked up for them. I have no wiring diagram that i can use to check or find the relay.I need hep as i need to fix this so my car will pass its mot.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Lancaster
    Posts
    1,629
    I beleive the switch has the relay in it bud.
    Atlas Grey A4 2.5 TDI Quattro Sport.
    Mods so far: Cruise control, DIS, Heated Mirrors, Tuning box, Xenonx, Centre Arm Rest, MFSW, RNS-E, SDS and Aero Wipers.
    To do: None yet.
    Next: Auto dip rearview mirror and Folding Mirrors.

  4. #3
    CHEZ's Avatar
    moderately amusing

    Status
    Offline
    Join Date
    Jul 2011
    Location
    the living room
    Posts
    3,594
    i would have suggested a relay at fault!
    but if the relay for your hazards are indeed located in the switch itself as blackquat suggests i personally would get the car scanned with vagcom to pinpoint an area!
    .................................................. ..........


  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Its the small hazard switch. 8E0 941 509 and i have already changed it

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    can't find a relay in back of the switch opened up the back only a small board that has the switch on it and the leds the it uses are soldered onto
    Last edited by SPORT180; 11th February 2012 at 18:29.

  7. #6
    CHEZ's Avatar
    moderately amusing

    Status
    Offline
    Join Date
    Jul 2011
    Location
    the living room
    Posts
    3,594
    someone will be here soon to assist brother!
    where is quattrojames when you need him?
    sounds like a relay dude! sit tight and the boys will be here to advise!
    SPORT180 likes this.
    .................................................. ..........


  8. #7
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    does the indicators work fine m8 and with key out the parking lights work ok ??? similar thing happened to my cupra and it was dust got into the indicator stalk causing it £3 tin of switch cleaner cured that fault......... my prob was my relay in the switch was clicking like crazy and hazard n/w intermittantly.............
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Parking lights work ok with key out indicators work fine when used no excess clicking or sticking

  10. #9
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,713
    my moneys on the wiper stalk mate, they are used so often that the contacts get warn and can cause the hazzrds to stuff up, i had this on a passat B5.5 2001.

  11. #10
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    yeah turkster my thoughts excactly, this problem seems so similar to the issue i had with the cupra... and was told to clean the contacts with spray and couldnt believe how cheap the fix was
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  12. #11
    6th Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Lancaster
    Posts
    1,629
    but the indicators are working? Its just the hazard light switch not working?
    Atlas Grey A4 2.5 TDI Quattro Sport.
    Mods so far: Cruise control, DIS, Heated Mirrors, Tuning box, Xenonx, Centre Arm Rest, MFSW, RNS-E, SDS and Aero Wipers.
    To do: None yet.
    Next: Auto dip rearview mirror and Folding Mirrors.

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Indicators work ok just the hazard light switch is not working

  14. #13
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    its a common issue across the vag range they somehow connect or use the same relay somehow
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    i have tried looking for a relay not in back of switch like earlier models dont have a wiring diagram or know were the relay could be located

  16. #15
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    but why would the relay be at fault when like stated the indicators work correctly and so does alarm on/off..... im just stating i had nearly the same issue as you and like you i tryed a hazard switch to no difference made and read of google the issue ppl have with vag's and its down to the dust and crap getting into the connections inside the stalk..... the fix was cheap a can of contact cleaner from maplins £3...... you may not have this fault but its very similar to the one i had thats what forums are for to share like minded info just thought its worth a shot.
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Quote Originally Posted by marktdisport View Post
    but why would the relay be at fault when like stated the indicators work correctly and so does alarm on/off..... im just stating i had nearly the same issue as you and like you i tryed a hazard switch to no difference made and read of google the issue ppl have with vag's and its down to the dust and crap getting into the connections inside the stalk..... the fix was cheap a can of contact cleaner from maplins £3...... you may not have this fault but its very similar to the one i had thats what forums are for to share like minded info just thought its worth a shot.
    I have cleaned out the indicator switch this has not fixed the problem. Does anyone know where the relay is or have a wiring diagram?

  18. #17
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Can anyone help?

  19. #18
    CHEZ's Avatar
    moderately amusing

    Status
    Offline
    Join Date
    Jul 2011
    Location
    the living room
    Posts
    3,594
    i dont know if yours is the same as mine, but i tried my hazards today and the relay sound seems to be behind the clocks or lower down from the clocks mate!
    .................................................. ..........


  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    i have most of the dash out but cant find the relay had my hand up there and had a look were i could see at the back of the clocks only looks like connectors into the back

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Does anyone have a wiring digram for this car that i can look at ? It might help me find the problem

  22. #21
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    The only power i have on the switch pin is 12v across pins 3 and 6 the reast are dead

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Tamworth
    Posts
    24
    Up date cannot find the cause .I have changed the switch with a brand new one. Switch pin 6 is 12v+ pin3 and pin 4 are earth pin 2 does not have power this seams to go the power control had this out checked the connections. Any one have a circuit diagram for this car?
    Last edited by SPORT180; 19th February 2012 at 12:15.

 

 

Similar Threads

  1. Hazard Warning Switch stays illuminated
    By Corrado Storm in forum General Technical / How To
    Replies: 4
    Last Post: 24th February 2011, 14:01
  2. A3 Hazard Warning Switch?
    By reptor245 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 12th January 2011, 19:43
  3. Hazard/warning triangle switch removal?
    By qawsed in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 10th May 2010, 15:25
  4. Help with replacing hazard warning switch
    By Stepho in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 26th April 2008, 20:42
  5. hazard warning switch....HELP
    By Ballcrusher in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 29th October 2007, 21:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO