Sky InsuranceMonster Motorsport
Results 1 to 13 of 13
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186

    Hazard light staying on

    Hi guys,

    Think this is part of the battery drain issue I have, noticed my hazard light isnt turning off.

    I have pulled the switch out and changed over for my wifes 8E switch and I have the same result, even though on her car it turns off. So I can only assume my switch is also fine. Indicators also work fine as I think unlike the B5 the indicator relay is separate to the hazard switch.

    Id appreciate any ideas or pointers to what I can try or where the hazard relay is?

    Thanks in advance

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    346
    disconnect your convenience module over night and see if that sorts the flat battery problem,if it does that is most likely your prob with the switch staying on as well,hopefully not tho cause the aint cheap.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186
    Sigh, thats the last thing I wanted to check, everything else works fine with no issues or vag codes, I did a drain check and the current didnt drop when I pulled the fuses for the convenience system though so Im still hoping it aint that. Also pulled carpet and all was nice and dry around the black box so assume no water ingress inside.

    Pulled the hazard switch for now as I dont want it killing the battery cells.

    Do you know if the hazard works off the indicator relay or if its on its own relay and which it is and where I can find it?
    Last edited by twist123; 4th November 2011 at 19:16.

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    346
    don't know about the relay but i had the same problem with mine,after a while the windows started playing up as well.put the switch back in and disconnect the module and if the battery holds the charge over night it has to be down to the module

  6. #5
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    This thread might be of interest:

    warning triangle on dash
    Ingolstance Read about my A6 HERE.

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186
    Out of interest how much is a ccu? Wil, it need programming? Thanks

  8. #7
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,723
    Quote Originally Posted by twist123 View Post
    Out of interest how much is a ccu? Wil, it need programming? Thanks
    about £150

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186
    Would that be new or used, from audi?

    Think this may have something to do with it Vagcom 01562 - 01562 - Rear Right Door: Can't Unlock

    Audi offered me a diagnostic scan for 145 plus vat!!!!!!

  10. #9
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,723
    £150 for a new one from Audi mate,

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186
    Weird, when I unplug fuse 24 (CCM fuse) the hazard goes off, result. When I take amp reading with car locked it drops from 0.80 amps to 0.10 amps after around a minute.


    Now heres the catch, when I unplug fuse 24 and take the reading the hazard goes off BUT the voltage when locked goes from 0.80 to 0.23 amps!


    Now very confused as it seems the CCM is causing the hazard light to stay on but at the same time the drain is higher with the CCM fuse in than with it pulled out and hazard off.

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    186
    Before I go ahead and replace the CCM, I was hoping someone can help me out with a few questions....


    I ran vagcom and Im getting-


    5 Faults Found:

    01330 - Central Control Module for Central Convenience (J393)
    53-10 - Supply Voltage Too Low - Intermittent

    01370 - Alarm triggered by Interior Monitoring
    35-00


    01369 - Alarm triggered by Hood Switch
    35-00

    01562 - Right Rear Door
    59-10 - Can't Unlock - Intermittent

    01562 - Right Rear Door
    61-10 - Won't De-Safe - Intermittent


    I fixed the rear door puddle lights by cleaning the lock switch in the rear right door and all seems to be working fine but I clear the codes and they come back? So Im wondering if its still not the lock thats knackered and giving me the other fault codes or perhaps its the wiring in the door itself behind the panel.


    All of these issues seem to be intermittent, so Im not quite sure if its the CCM thats faulty, as all doors lock/unlock via remote and from inside, alarm seems to work fine and all interior lighting/door signals in dash/door lights/indicators work as they should.


    But I still have a battery drain and the hazard doesnt go off.

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    83
    I've got this same issue, did you ever find the cause of the problem?

  14. #13
    Audi Doodah's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Swindon
    Posts
    371
    Legacy

    I was going to point you in the direction of this thread but you beat me to it!

 

 

Similar Threads

  1. ESP Light staying on
    By dirtydamdog in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 3rd April 2011, 20:01
  2. Engine Management Light Staying On
    By scoobyra in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 15th September 2010, 14:46
  3. HAZZARD LIGHT STAYING ON
    By brownie 25 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 9th July 2010, 22:32
  4. HAZZARD LIGHT STAYING ON
    By brownie 25 in forum General Chat
    Replies: 2
    Last Post: 5th May 2010, 08:36
  5. EMISSION CONTROL LIGHT STAYING ON
    By NEVZN in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 6th October 2009, 09:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO