Monster MotorsportBadger5
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By Turkster

Thread: Problems, any advice welcome

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    150

    Problems, any advice welcome

    Two problems, can anyone shed any light please?

    I have a 1.9tdi 130 sport, the brake pad warning light came on (fronts only as rears dont have the sensors) so replaced the pads. As youd expect the warning light on the DIS went off, after a jurney of 15 or so miles the light came back on. After whipping the wheels off again the pads are fine anf the sensors are conected.

    So I disconected both and reconected, still the same warning light. Now I have the sensor disconected (open circuit) this should turn the light off as the system is open circuit, the lamp should only come on when the circuit is closed, ie, the pad wears and the contacts touch the disc. I have the lamp on no matter what I do????

    Secondly, I have a rattle, it has got progressivley worse over the last few months, I have had the front wheels off, checked all bushes everything I can think of. Today I took the car to Kwik fit (would never normally) they put the car on the shaker pad and found nothing.

    The rattle occurs when impacting potholes ect. It's not suspention related and going over bumps such as speed bumps and the susspention in either in compression or extention, no noise. It's a metalic noise and sounds as if something is realy loose. Please someone shed some light on this it's doing my head in.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Is your brake fluid level ok?

    The rattle isn't something trapped on top of the undertray is it?
    Ingolstance Read about my A6 HERE.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    150
    Brake fluid is at its max and have had the undertrays off many times to look for something loose.

    Im out of ideas mate, seriously conssidering selling as the noise is mega anoying, my mate calls my family the clangers now after we drove past him clanging and rattling...

  5. #4
    4th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    770
    Are the new pads rattling in the carriers?Have had this on rears and it sounds really loud as you hit a bump.

  6. #5
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I have a similar problem with my low pad light being on intermittently at the moment. The pads are fluid are fine, I've not tried to bypass it yet, it started about the same time as my light switch started playing silly buggers, so I have a sneaking suspicion they might be linked...

    If a new switch doesn't resolve it then I'll by pass it and see what happens.
    Ingolstance Read about my A6 HERE.

  7. #6
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,723
    the plug backwards from the pad may have a nick in it coursing the short circuit, have a inspection there, the noise i cant help you with unless you pass by me in Northampton as its hard to tell from behind a screen,
    quattro tony likes this.

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Sep 2010
    Posts
    167
    Disconnecting the plug off the sensor wire wont turn off the light, have you carefully inspected the warning wires , especially the muliplug for and corrosion, common this, when you replaced the pads first when the light came on were the pads worn to metal?
    Regards your rattle, If you get a garage who knows what they are doing ( except kwik fit )(imho) to carefully check all the balljoints , and underside for any problems,you might find the cause . Rattling pads are a posibility, Ive come across this too, Did the rattle start ever since you changed the pads?

  9. #8
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Does it rattle when you brake? If so, then it won't be the pads.
    Ingolstance Read about my A6 HERE.

  10. #9
    deanski's Avatar
    wax on, wax off

    Status
    Offline
    Join Date
    May 2010
    Location
    Lancashire
    Posts
    374
    I have rattling pads and its a proper pain. I also had the brake light prob and it was the brake light switch.
    A4 B6 1.9 tdi 130. Slowly modding but don't tell the missus.
    Front ambient lighting
    Eibach sportlines.
    Audi TT Alloys.

  11. #10
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,258
    this may sound weird but the metalic knocking noise. Does it sound like a bad creaking noise when you set off and stop, the faster you start the worse it is. and as its got worse has it started knocking randomly but at low speeds. this was what i have just had and after changing all 4 arms ,drop links and track rod ends it turned out to be the engine mount, it was only when i supported the engine and removed the bottom bracket that holds the mount it was obvious, the bottom steel plate which the bottom bolt is fixed to had sheared fully accross and half had fallen out thus resulting in a severe creaky knocking noise. Try lifting the bonnet and then setting off, you can whatch the engine through the gap under the bonnet to see if its lifting excessivly, mine was moving up about 3 to 4 inches so it was a giveaway. hope this helps
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  12. #11
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    doesnt the pad light work opposite to you stated on a audi ?? take your plug off and loop a wire over the 2 terminals then switch on the ignition ??? sure this is how i tested mine dont qoute me for sure it was 6 mth ago when i replaced mine my plug was also cracked and full off water, so repaired my plug and its fixed.... try this when you get 5
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  13. #12
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    150
    Holy thread resurection.

    Bringing this back up, I have been out of the country fro 6 months and now back to the nightmare audi.

    I have done what marktdisport said, I bridged both conectors for the wear sensors on the front pads, this turned the light off. So new pads it is.

    The rattle.... I cant see it being the pads? Its a massive rattle, will see what the pad replacement brings. Will also check that engine mount.

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    206
    Well? Lol
    B6 A4 Avant 1.8T (190) S-Line

  15. #14
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    150
    Well..... I have fixed it.

    It was the pads all along, bought a set for front pads from Euro car parts, plugged in and put the light out, so I changed the discs aswell. Took it for a drive and no clanging.

    Im surprised it was the pads clanging in the carriers, it sounded like the anti roll bar was hanging off. The wiring,,, who knows, the old pads were conected up the same way.

    Top tip.... dont buy Halfords pads.

 

 

Similar Threads

  1. 2 problems i need advice on......
    By Dani_B19 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 26th September 2011, 01:25
  2. Picked up my new car, problems, advice needed please..
    By A3Bash in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 4th June 2010, 22:19
  3. Steering problems, I need some advice
    By jwhat in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 5
    Last Post: 21st December 2009, 23:53
  4. engine problems advice needed
    By 20s on a tt in forum TT/TT-S/TT-RS Forum
    Replies: 2
    Last Post: 31st March 2008, 10:26
  5. Cutting out problems, any advice?
    By imported_smoke in forum A4/S4 forum(B5 Chassis)
    Replies: 5
    Last Post: 8th December 2005, 18:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO