Monster MotorsportChris Nott
Results 1 to 8 of 8
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    6

    Red face A4 B6 2.5TDI Quattro idle issues???

    Hi,
    so iv'e had my A4 for about 3 months now and i love it!!!! i took it for a health check courtesy of Audi and the usual crap returned, replacement screw £140, wiper linkage squeaking £245vyada yada, anyways one of the things found was the G80 injector had an intermittent fault....

    there was a slight stutter in the idling which id noticed but only when at stop and when you really tried to feel it as it doesn't show on the rev counter but it is noticeable....

    so without further hesitation i plugged her in myself and sure enough G80 intermittent short to plus or open circuit.
    bought the injector, £350 worse off replaced it and the code went away... YAY success...

    however this did not remove the funky idle!!!! there are no more fault codes after a clean sweep with vag-com but still this random lumpy but hardly noticeable idle lumpyness!!!! and its driving me mad.

    anyone had an issue like this before? the car runs fine otherwise.... good mpg around 37 average, smooth motorway running and a dream to drive!

    2001 A4 2.5 TDI Quattro AKE with 99K genuine!
    cam belt at 80K

    Regards to anyone who has any ideas!!!

    Niki

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    quattrojames's Avatar
    Moderator

    Status
    Online
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,689

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Hi Niki and welcome to the forum.

    It could be anything, but assuming a VCDS scan shows nothing then there's always the possibility it's a fuel pump VP44 error...
    Ingolstance Read about my A6 HERE.

  4. #3
    white.akita's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    county durham
    Posts
    280
    Maf doesnt always show fault code.
    2003 A4 2.5 TDI QUATTRO AVANT

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Ireland
    Posts
    21
    One of the injectors has a needle lift sensor, drivers side, closest one to the windscreen (if I remember correctly). You will see a wire coming from it, worth checking that the wiring is ok as I believe the wire is sandwiched between the rocker cover and head (no special path for it).

    Afaik this injector cannot be refurbished so you will need a new one (if no wiring fault found), they are not cheap from audi but find the bosch part number and you may find it cheaper.

    See thread:
    00542 Needle lift sensor (G80)


  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    6
    Hi,
    yeah i replaced the G80 as stated at £350 squids to no avail! i will get a new MAF anyways and see if it makes a difference.
    Regards

  7. #6
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,196
    dual mass flywheel could be a culprit, these 2.5tdi's do use them up, do you suffer a judder on take off or changing gear when its warm and had a run out?
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    6
    Hi,
    i had considered the dual but there are no other signs! it pulls great on all gears and doesn't judder or lurch at all....

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Ireland
    Posts
    21
    Sorry I did not read your original post carefully enough, with regards to the sensor injector.

    I believe you can just disconnect the MAF and see it if improves the idle before putting your hand in your pocket again.

 

 

Similar Threads

  1. Audi 2.5TDi - Several issues and in need of advice (temp/starting/mpg)
    By DavieMac in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 34
    Last Post: 16th December 2010, 04:47
  2. 2.8 Idle issues
    By cjrob in forum A4/S4 forum(B5 Chassis)
    Replies: 23
    Last Post: 7th May 2010, 18:49
  3. Brake Issues on B6 2.5Tdi Avant Sport
    By tonypill in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 1st December 2009, 13:19
  4. 2.5tdi auto slight issues
    By 52-2.5-tdi-auto-karl in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 8th March 2008, 18:04
  5. Still Having Perfomance issues with my 2.5tdi Allroad
    By Biggles in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 18
    Last Post: 23rd January 2007, 21:32

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO