Monster MotorsportEM Tuning
Results 1 to 25 of 25
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17

    Audi A4 2.0 Fsi needs some help.

    First off Hi everyone im new to the forum I have looked on some bits before and decided to finally join

    I was hoping someone could help me out.

    I have an Audi A4 2.0 FSI Sport 2004 B6.

    Now when I brought it had a fair few problems one being a new engine needed so I decided to get a replacement used engine with what they told me had 60k on. So that was fitted back in January I think it was. Various other things were changed such as coil packs etc.

    Now I have been experiencing this first problem pretty much since the new engine was fitted took it back to the garage but they are useless to say it nicely and they wont ever see my car again let alone touch it. Thats another story.
    Basically sometimes my car will start to judder horribly and other times it is not so bad being very minor but either way it does it. Sometimes I can actually get out of the car and the car will be shaking. It is most noticeable when idling and there is a tiny bit of movement on the needle but it very minor and not like you would see on a missfire. Whilst idling if you put the clutch in it makes no difference. On the odd occasion the car will start and the rev needle will be in limbo land as if the car wants to die or just start to pick up you can hear the car sound as if its just about to die but it will stay like that for as long as the car will tick over unless the accelerator is tapped. I would really like to get to the bottom of this as its driving me mad.
    I have taken it too a few garages that cannot find the problem and I have now been told to take it to Audi but to be honest I was really hoping not to do that when the problem is unknown as I just dont have the cash for what they charge.

    The second problem is a not as old. The car when locked would randomly start beeping and all lights flashing sometimes I could unlock the car and relock without any problems other times it would stop and start to beep a few minutes after locking it again. Then that suddenly stopped. Then after a few months it started again but was not so bad only on random occasions it would do it. Im pretty sure that I disabled the interior motion detectors a few times and the problem still happened.

    Any help would be appreciated.
    Last edited by Gaz1987; 10th September 2011 at 09:54.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    S3 GAZ's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2006
    Location
    East Ayrshire Scotland
    Posts
    347
    Sounds like the vibration could be the engine mounts. Perhaps they were damaged during the engine swap.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Hi thanks for the reply.

    Im no expert but I dont think it is the mounts as when I had a new coil pack and all codes wiped off the car ran really smooth and nice for a week or 2 then it started again. Also a few weeks ago I had my aircon re-gassed and that added a fault code so once a fuse was replaced and the code wiped the car ran nice again for a few days then back juddering. When the car is juddering very bad you can actually see the car shaking thats the whole of the A4 and if sitting in it you can feel it a lot.

    Something I just remebered is if I was to let air in to the engine by lifting the dipstick while the car is running it will sound rough and jiggle about also.
    Last edited by Gaz1987; 10th September 2011 at 12:34.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Can anyone help?

  6. #5
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Engine breather?
    Ingolstance Read about my A6 HERE.

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    I was thinking that but surely the garages should have picked that up, anyone know of anywhere to get a breather set for a decent price?

    Any ideas on the alarm issue?

    Many thanks

  8. #7
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    The alarm might be a damaged wire in the door hinge possibly.

    Have you had the car scanned at all?
    Ingolstance Read about my A6 HERE.

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    I have but nothing was found on the alarm side of things, there was a code for an air leak but I didnt get the code it was thought that was an old code from when the mass airflow meter was replaced I think the last time my car went in all codes were wiped so anything that comes up now will be new and relevant.

    If there is someone in the area that is interested in helping me out with the problem I will be very interested to talk with you and it would be nice if you are able to do the work on it for me as I dont have a VAG system and im not a mechanic.

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Update on the alarm issue.

    The last two nights have been pretty much the same the first night the car was left from around 5pm all night locked. Then at around 10pm just decided to set the alarm off. I unlocked and locked again after about 10minutes the alarm started going again soni tried a further few times even opening all the doors and closing then re-locking for the alarm to go off once it was armed.
    I also disabled the 2 switches at the side of the drivers side door but the alarm still went off.

    The second night it was left from around 8pm all night locked until the alarm started sounding at around 5am so I had to leave the car unlocked all night.

    If anyone can help it would be great.

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Can anyone recommend a good garage that knows about Audi's in the Midlands or Birmingham area?

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Anyone at all?

  13. #12
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    Mine was doing this alarm thing and was traced to a duff glass break sensor. I dont know where it is though.
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Thanks for your reply the car is in a garage at the moment hopefully it will get sorted.

    Does anyone know if there was ever a recall on the alarms or anything else with the 2004 B6 model?

  15. #14
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    Coilpacks and plenum chamber grommets are 2 recalls that im aware of
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    Ok will be ringing Audi up when I get time to see if they owe me any recalls.

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    I had my car looked at and its not the breather pipes I had the throttle body cleaned while it was in the garage too but no change with regards to the juddering any other ideas would be helpful.
    Last edited by Gaz1987; 30th October 2011 at 19:35.

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    May 2011
    Posts
    136
    Quote Originally Posted by Gaz1987 View Post
    Can anyone recommend a good garage that knows about Audi's in the Midlands or Birmingham area?
    Midland vw in cannock or vw rescue in wombourne ! used them both in the past with no problems !

  19. #18
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    cheers may give them a try.

  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    If anyone else can think of an explaination in the mean time im all ears.

  21. #20
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    You say it's not the breather pipes,,hhmm, I have the same car with the same engine and have had this fault,, it turned out to be a plastic breather hose that runs from the right side of the rocker cover into the grey plastic inlet-box to the right of it,, if you lift the fsi engine cover of it's immediately in front of you there's two, the plastic hose has a textured pattern of rings witch become brittle and leak air from fine cracks in it...

  22. #21
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    was the coilpacks ebay cheapys m8 !!! they could be failing again or a dodgy plug

    i use midland vw only speak to jody he's the gaffa.....
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  23. #22
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Quote Originally Posted by marktdisport View Post
    was the coilpacks ebay cheapys m8 !!! they could be failing again or a dodgy plug

    i use midland vw only speak to jody he's the gaffa.....
    possibly but would have thought it would be missing right through the revs not just on tick-over,,,

    GAZ, the two breathers i mentioned can only be checked by removing the inlet box , which involves removing the expansion container etc, so not cheap to get checked,and I'm not saying that's defo going to cure your problem,just that it cured the same symptons on my 2.0 FSI

  24. #23
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    not always m8 if one is slower breaking down......
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  25. #24
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    There is no missfire there is a little movement on revs on tickover occasionly but not like it is when there is a miss.

  26. #25
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    West Midlands
    Posts
    17
    So since having a new water pump and cambelt change the judder has gone I had all breathers checked just incase too and now the car is driving very well. I am still yet to find out about the alarm problem but it has been locked for a few days without any problems now but could it be a possibility that a leaking water pump could have got some electrics wet that made the alarm go off randomly?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO