Volks AutosAH Fabrications
Results 1 to 15 of 15
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141

    OEM Bluetooth retrofit into A4 B6 help required

    Hi All

    Well, i thought it was just going to be a straight plug and play, or maybe a slight variation on that but it seems it may not be.

    The kit i have so far is:-

    BT control unit 8P0 862 335 Q
    BT aerial ( came fitted to control unit)
    BT microphone 8L1 862 373 A
    Kufatec loom item 33866 (bluetooth handsfree harness)
    Kufatec instructions

    The loom itself looks ok , 2 plugs, one for the control unit and one for the mic, a red/wht cable for fuse s32-34
    (+12v) an earch cable (brown ring terminal) and then there are 6 grey wires with printed idents along their length.

    can hi, can low and diagnostic (in german) all have bare ends, ie no crimped connection
    NF+, NF- and mute (in german) all have crimped ends.

    The instructions from Kufatec are as follows:-

    Installation guide Bluetooth hands free wiring harness Audi A4 8E

    First of all: unconnect the car’s battery at the beginning of your work!

    - 3-pole connector including the FAKRA connector will be connected to the
    compensor.
    - 2-pole connector will be connected to the microphone
    - 10-pole red connector (only for radio) will be connceted to the radio (empty slot)
    - Black/white – can high – connect to 20-pole mini iso connector pin 7
    - Black/green – can low – connect to 20-pole mini iso connector pin 12
    - Brown – ground
    - Red / white fuse S 32-34 (+12V)
    - Yellow – diagnosis – connect to 8 pole radio-connector pin 3

    - If you ordered the cable for Navigation RNS-E you need to use the following
    connecting scheme:

    o green -> pin 12 Connector C (greeen NF+)
    o black -> pin 6 Connector C (green NF -)
    o grey -> Pin 11 Connector D (Mute)
    o black/white -> CAN-Hi Pin 9 (connect to existing wires)
    o black/green -> CAN-Lo Pin 10 (connect to existing wires)

    - If you got the BNS-Navigation installed, you need to use the following
    connecting scheme – these wires will be connected to the 20-pole connector at
    your navigation-system.
    o Pin 16 -> Green
    o Pin 17 -> Grey
    o Pin 19 -> Black

    The interface is located under the passengers seat in a black box. You need to
    remove all foam in order to be able to place the box down there.

    Removing the cover of the steering wheel:
    - Remove 2 lower screws
    - Pull the cover
    - Unconnect all connectors (diagnosis, light switch, light etc.)

    Removing of the cluster unit:
    - pull the cover
    - remove the 2 screws
    - pull the cluster unit out and unconnect the blue connector

    After installation you need to recode your components:

    - Radio (Chorous, Concert, Symphonie). Add 2 to the second digit of the right
    side

    - RNS-E Navigation: Add 2 for Temic (8 for Comfort controlling) to the 3rd digit
    from the right side.


    So, basically i'm looking for a bit of clarification on what connections i need to be making, as far as i knew it was power, earth and then connections to the RNSE, whereas these instructions also make reference to colour code of cables and also removing the instrument cluster??

    I have no other connector plugs other than those on the loom supplied, do i need another connector?

    Any help from someone who's been there would be beneficial.

    cheers for any help

    Graeme

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    LOL, it seems that by putting it all down in text in front of me has drawn my attention to some bits of the instructions i had missed before.

    I take it i just crimp into the existing can lines, a'la scotchlock ( but not scotchlock)

    o black/white -> CAN-Hi Pin 9 (connect to existing wires)
    o black/green -> CAN-Lo Pin 10 (connect to existing wires)



    I will let you all no how i get on

  4. #3
    Woorlord's Avatar
    shifting to Hyperspace... .

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Tiptree, Essex
    Posts
    946
    This may help for reference....



    As I replaced my original Single-DIN radio with an RNS-E I had an adaptor harness between the original ISO connectors and the RNS-E Quadlock connector. I soldered the BT module cables into this adaptor cable and used heatshrink for a tidy and compact connection method.

    This link is also good as lists all the RNS-E connections and compares them to Symphony/Concert Radio ISO connections.

    K-Line (Yellow wire) is also important as this is used for configuring the BT module with VAG-COM.
    Connector B / Pin 5 of RNS-E unit.

    In summary:

    red/white -> +12v -> D/Pin15 (connect to existing wires)
    brown (with ring) -> GROUND -> D/Pin12 (connect to existing wires)
    green -> C/Pin12 NF+
    black -> C/Pin6 NF-
    grey -> D/Pin11 Mute
    black/white -> D/Pin9 CAN-Hi (connect to existing wires)
    black/green -> B/Pin10 CAN-Lo (connect to existing wires)
    yellow -> B/Pin3 K-Line (connect to existing wires)
    Last edited by Woorlord; 9th July 2011 at 10:43.
    2001 A4 Saloon 3.0 Quattro Sport Tiptronic - Platinum Leather/Heated Front Seats/BOSE/DIS/Cruise Control
    Retrofits:GmBH Bumpers, F&R Ambient LEDS, OEM Valeo Xenons (D2S) & Headlight Washers, Auto-dipping RVM, Footwell Lights, Vent Control illumination, ISO-Fix, RNS-E & OEM Bluetooth + VIMhack + Video i-pod & Aux inputs, Rear PDC, Powerflow 100mm Tips, Reversing Camera
    2012 A4 Saloon 2.0 TDIe Technik (163ps)
    Diagnostics:VCDS HEX+USB+CAN Cable

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    You Beauty!!, i was just thinking i could do with the wiring diagram for the plugs on the RNSE and as if by magic you put one up!!
    It all makes perfect sense now.

    Will hopefully throw it all in on Monday when the wife and kids aren't about!, i can't really get away with playing with the car on a weekend anymore LOL

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    Well, i got the bluetooth module and wiring fitted today and tried to code it in on telephone 77 but it wouldn't see the controller!
    "Your telephone may not be connected or attatched correctly" was the message on the screen when selecting the tel button on rnse.

    I've basically done the same as craig above and soldered into the quadlock loom, mine had all sorts of different colours and only a couple equated to what Kufatec or craig had mentioned, typical of an ebay lead, so i just went by the positions on the RNSE guide.

    I'm not sure if it's a wrong connection i've made or whether or not i have coded it in correctly so:-

    I have RNSE, and bluetooth and thats the lot, no changer, no mfsw, nothing else so what headings should i be adjusting codings under?

    Any help would be much appreciated, while i wait for feedback i'll be digging back into it to make sure i havn't wired incorrectly and also searching to see where i may have gone wrong.

    Graeme

  7. #6
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    In your summary

    Your K-line connects to pin 3 and it should be in pin 5

    Quote Originally Posted by Woorlord View Post
    This may help for reference....



    As I replaced my original Single-DIN radio with an RNS-E I had an adaptor harness between the original ISO connectors and the RNS-E Quadlock connector. I soldered the BT module cables into this adaptor cable and used heatshrink for a tidy and compact connection method.

    This link is also good as lists all the RNS-E connections and compares them to Symphony/Concert Radio ISO connections.

    K-Line (Yellow wire) is also important as this is used for configuring the BT module with VAG-COM.
    Connector B / Pin 5 of RNS-E unit.

    In summary:

    red/white -> +12v -> D/Pin15 (connect to existing wires)
    brown (with ring) -> GROUND -> D/Pin12 (connect to existing wires)
    green -> C/Pin12 NF+
    black -> C/Pin6 NF-
    grey -> D/Pin11 Mute
    black/white -> D/Pin9 CAN-Hi (connect to existing wires)
    black/green -> B/Pin10 CAN-Lo (connect to existing wires)
    yellow -> B/Pin3 K-Line (connect to existing wires)

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    so basically the instructions from kufatec are wrong??, with regards to the k-line.

    Well, i know what i'm doing first thing in the morning then LOL

    Thanks again craig, a wealth of knowledge and experience showing there

    Graeme

  9. #8
    Woorlord's Avatar
    shifting to Hyperspace... .

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Tiptree, Essex
    Posts
    946
    My typo - Sorry!
    It is Pin 3 of ISO Connector III (Symphony/Concert), but Pin 5 of B-connector Quadlock (RNS-E).

    In "revised" summary:

    red/white -> +12v -> D/Pin15 (connect to existing wires)
    brown (with ring) -> GROUND -> D/Pin12 (connect to existing wires)
    green -> C/Pin12 NF+
    black -> C/Pin6 NF-
    grey -> D/Pin11 Mute
    black/white -> D/Pin9 CAN-Hi (connect to existing wires)
    black/green -> B/Pin10 CAN-Lo (connect to existing wires)
    yellow -> B/Pin5 K-Line (connect to existing wires)
    Last edited by Woorlord; 11th July 2011 at 22:00.
    2001 A4 Saloon 3.0 Quattro Sport Tiptronic - Platinum Leather/Heated Front Seats/BOSE/DIS/Cruise Control
    Retrofits:GmBH Bumpers, F&R Ambient LEDS, OEM Valeo Xenons (D2S) & Headlight Washers, Auto-dipping RVM, Footwell Lights, Vent Control illumination, ISO-Fix, RNS-E & OEM Bluetooth + VIMhack + Video i-pod & Aux inputs, Rear PDC, Powerflow 100mm Tips, Reversing Camera
    2012 A4 Saloon 2.0 TDIe Technik (163ps)
    Diagnostics:VCDS HEX+USB+CAN Cable

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    will post up tomorrow and let you guys know how i get on

    Cheers

  11. #10
    dsmclark40v's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Hampshire
    Posts
    715
    Quote Originally Posted by bugwhizz View Post
    Well, i got the bluetooth module and wiring fitted today and tried to code it in on telephone 77 but it wouldn't see the controller!
    "Your telephone may not be connected or attatched correctly" was the message on the screen when selecting the tel button on rnse.

    I've basically done the same as craig above and soldered into the quadlock loom, mine had all sorts of different colours and only a couple equated to what Kufatec or craig had mentioned, typical of an ebay lead, so i just went by the positions on the RNSE guide.

    I'm not sure if it's a wrong connection i've made or whether or not i have coded it in correctly so:-

    I have RNSE, and bluetooth and thats the lot, no changer, no mfsw, nothing else so what headings should i be adjusting codings under?

    Any help would be much appreciated, while i wait for feedback i'll be digging back into it to make sure i havn't wired incorrectly and also searching to see where i may have gone wrong.

    Graeme
    If I recall from when I did mine you need to tell the RNS-e that the Bluetooth module is connected. There is a link somewhere for all the coding but it's on my work pc. I'll have a look for it when I get in

    This is the website with the coding.

    The number marked by the question mark below is the one you have to change

    0xxx?xx: Telephone/telematics
    1 - no telephone (supply voltage for microphone actively)
    2 - Mobile phone preparation (Temic - Speisesp. Microphone inactively)
    3 - Mobile phone preparation (Cullmann - Speisesp. Microphone inactively)
    4 - Mobile phone preparation (Nokia - Speisesp. Microphone inactively)
    5 - Telematics Europe (supply voltage microphone inactively)
    6 - Telematics US (supply voltage microphone inactively)
    7 - Base plate diagnostic capable with comfort control
    Last edited by dsmclark40v; 12th July 2011 at 10:03. Reason: added the link and code
    Sam,




    Gone

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    Hi all

    Turns out that my K-line was in the wrong position, in 3 and should've been in 5, now thats all sorted.

    Bluetooth is in and works both making and receiving calls, it shows 'Orange' telephone on the telephone display and shows the actual number and name being called but when making calls, i have to use my phone for the phone book as in there's no phone book on the RNSE so thats another area i need to look into.

    I have full DIS, RNSE and BT, thats all that affects the coding i'm thinking and my phone is a SE k800i, any help?

    coding so far is:-

    56 Navigation - 0301211 and the pt number for RNSE is 8E0 035 192 TX
    77 Telephone - 0000702 and the pt number for the BT control unit is 8P0 862 335 Q

    Cheers again
    Graeme
    Last edited by bugwhizz; 12th July 2011 at 15:41. Reason: addition of information

  13. #12
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    can anybody tell me if this coding is correct?, it all seems to be working but i have no contacts list in the RNSE?

    Is it a phone compatability problem or just my coding

    Any help would be great.

    Graeme

  14. #13
    Woorlord's Avatar
    shifting to Hyperspace... .

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Tiptree, Essex
    Posts
    946
    Your RNS-E Coding: 0301211:
    0=not used
    3=Audi A4(8E)
    0=Not Cabriolet
    1=Audi A4(8E) non-BOSE
    2=Telephone Base Plate(Temic) >>>>>>> set this to 7 (says set this to this value for Bluetooth connections)
    1=Tuner not installed
    1=TV/Tuner/CD-Changer/MFSW not installed

    So suggest you change the RNS-E coding to 0301711
    and
    Coding is wrong on BT unit - should be 0010702 with RNS-E (xx1xxxx Classed as "Hi" HU)

    Coding information for BT found here and RNS-E found here for reference.

    Have used a SE K800i with no problems and full support - only item greyed out on RNS-E telephone page is "Directory" and "Store Current number". Phone book and all other call logs integrate fine. Not using the K800i as replaced last year with iPhone 4G, so had to quickly re-check.
    Last edited by Woorlord; 15th July 2011 at 18:09.
    2001 A4 Saloon 3.0 Quattro Sport Tiptronic - Platinum Leather/Heated Front Seats/BOSE/DIS/Cruise Control
    Retrofits:GmBH Bumpers, F&R Ambient LEDS, OEM Valeo Xenons (D2S) & Headlight Washers, Auto-dipping RVM, Footwell Lights, Vent Control illumination, ISO-Fix, RNS-E & OEM Bluetooth + VIMhack + Video i-pod & Aux inputs, Rear PDC, Powerflow 100mm Tips, Reversing Camera
    2012 A4 Saloon 2.0 TDIe Technik (163ps)
    Diagnostics:VCDS HEX+USB+CAN Cable

  15. #14
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    Cheers for that woorlord, i'll just get the kids to bed first then i'll go swap the codings over and post up

    Thanks for the help fella, much appreciated

    Graeme

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Mar 2004
    Posts
    141
    Well, i got to work sorting the coding today and hey, everything works a treat!

    full phone book function, and no messing with the phone whilst driving!!

    All controlled through the RNS-e

    Many thanks fella's

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO