EM TuningAH Fabrications
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By kressy

Thread: A4cab roof problems

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2011
    Posts
    1

    A4cab roof problems

    Just bought a a4 cab on a 05 plate yesterday and got it home and tried ta take roof down and it stopped completely after a few seconds, done the open and close manually but saying roof not secure even tho it is. My boot won't open with button I have ta use the key, and I tried the roof this morning and it not workin at all!! Garage has said they fix it but can this turn into regular problem? Is it an easy fix?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Iyole's Avatar
    N/A Rools

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Cape Town; South Africa
    Posts
    69
    I haven't had any issues with my roof since buying the Cab 2 yrs ago.......so don't think it is a common/regular prob.

    Sounds like something related to the boot not opening with remote as the roof won't operate properly
    if the boot thinks it is open. Probably a Sensor somewhere giving problems

    Hope it is an easy fix.

    Keep us posted

  4. #3
    a4 cabrio's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    north yorkshire
    Posts
    135
    i have had no problems with my cabriolet either, only had mine since january, but so far so good.

    did you guy private or through dealer??? if a dealer, take it back too them. hope you get it sorted
    2005 Audi A4 Cabriolet 2.5 V6 TDI S Line 163BHP
    Now Remapped to 195BHP

  5. #4
    itsmeagain's Avatar
    1.8T Sport Cabriolet

    Status
    Offline
    Join Date
    Mar 2010
    Location
    West Midlands
    Posts
    435
    Quote Originally Posted by Markymark79 View Post
    Just bought a a4 cab on a 05 plate yesterday and got it home and tried ta take roof down and it stopped completely after a few seconds, done the open and close manually but saying roof not secure even tho it is. My boot won't open with button I have ta use the key, and I tried the roof this morning and it not workin at all!! Garage has said they fix it but can this turn into regular problem? Is it an easy fix?
    The boot sounds like the solenoid has packed up, real easy to change and only about £20 from memory. Just take the car to Audi and ask a technician to have a look. I got mine stuck months ago and they did it for me, they did the manual reset.
    Audi A4 1.8t sport convertible, Full Grey Leather Interior, Ambient Light Pack, Polished Forge FMCL007P Diverter valve, Green Cotton Filter, 100mm Tail pipes, Rear RS4 ARB, Interior Xenon White LED's bulbs, Xenon White LED number plate bulbs and side lights, JBS Auto Designs stage 1 remap, RNS-E and OEM Bluetooth, Remote roof module, OEM Wind Deflector, B7 rear lights, HID lights.

  6. #5
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    661
    If it says not secure it could be a micro switch in the boot, need to check fault codes to be sure or a manual open close (see handbook) might reset.
    2003 A4 Cab 2.4 V6 Manual / 43k miles genuine woohoo (on a 10 year old car lol) / Ebony Black Metallic / Full Grey Leather / Fully Electric Seats / Heated Seats / Interior Light Pack / Cruise / Wood / Bose Symphony II / Black roof

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2010
    Posts
    5
    Hi,
    I have had a similiar issue with the roof on my 03 A4 cab ! it was working fine and i stupidly shut the car of half way into closing the roof! when i re-started the ignition the roof wouldnt work. I ended up doing a full manual open and close. Now when i try i can get the roof down in stages, I have to unlcok using th =e tool the latches from the front (windscreen) then the button works all the way back to the part before the boot opens, i then use the tool on the front latches again and close them in and then the button works all the way till close. this is the same when opening.... not sure if theres a motor section under the plastic in the roof (windscreen side) that may be broke...any ideas welcome..

    thanks
    Arthur eros likes this.

  8. #7
    2nd Gear

    Status
    Online
    Join Date
    Feb 2011
    Location
    Leicester, United Kingdom, United Kingdom
    Posts
    311
    Quote Originally Posted by kressy View Post
    Hi,
    I have had a similiar issue with the roof on my 03 A4 cab ! it was working fine and i stupidly shut the car of half way into closing the roof! when i re-started the ignition the roof wouldnt work. I ended up doing a full manual open and close. Now when i try i can get the roof down in stages, I have to unlcok using th =e tool the latches from the front (windscreen) then the button works all the way back to the part before the boot opens, i then use the tool on the front latches again and close them in and then the button works all the way till close. this is the same when opening.... not sure if theres a motor section under the plastic in the roof (windscreen side) that may be broke...any ideas welcome..

    thanks
    Hi kressy, I doubt that you will have broken anything by switching it off midway, may have broken something during manual operation. I'd recommend to put it on vagcom and have a look. If you do need to replace the motors then drop me a message and I'll pull off the relevant sections off the workshop manual

  9. #8
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    661
    I have stopped mine during the cycle loads of times to clean or maintain and never had a problem. When they stop working its usually a micro switch in my experience.
    2003 A4 Cab 2.4 V6 Manual / 43k miles genuine woohoo (on a 10 year old car lol) / Ebony Black Metallic / Full Grey Leather / Fully Electric Seats / Heated Seats / Interior Light Pack / Cruise / Wood / Bose Symphony II / Black roof

  10. #9
    2nd Gear

    Status
    Online
    Join Date
    Feb 2011
    Location
    Leicester, United Kingdom, United Kingdom
    Posts
    311
    Quote Originally Posted by Cabbyfan View Post
    I have stopped mine during the cycle loads of times to clean or maintain and never had a problem. When they stop working its usually a micro switch in my experience.
    Hi cabbyffan, not had any problems with microswitches myself so can't comment on that, however it is useful to note that the motors for the hydraulic units are temperamental as they get older and poor conduction can also stop the system operating .

    Audi A4 Cabriolet Soft Top/ Roof / Hood Motor Repair Guide

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO