AH FabricationsJMB Retrofits
Results 1 to 13 of 13
  1. #1
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    346

    another esp question

    well everyone the esp light has been coming on and off for a while now but today started the car from cold and drove out of my drive,and with the wheels turned left there was a bit of a grind from front left wheel and it was like the brake stuck for a split second and released again (one problem).later on in the day was taking off from a junction and it seemed there was no power for about 3 sec and the esp light was flashing,then it just drove on again fine and the light stopped flashing any one ever have anything like this.
    ps its a 01 a4 2.5 qs
    Last edited by brownie 25; 5th January 2011 at 23:18.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    seriously considering removing the instrument bulb on mine !!!

  4. #3
    quattrojames's Avatar
    Moderator

    Status
    Online
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I know I say it time and again.... but you need to get it scanned. It might cost you a bit but it's the best chance of getting the problem diagnosed. The ESP light comes on for so many errors it's impossible for anyone here to be be able to accurately tell you whats wrong.
    Ingolstance Read about my A6 HERE.

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    346
    i had it scanned and all it shows is a needle lift sensor

  6. #5
    quattrojames's Avatar
    Moderator

    Status
    Online
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Ouch

    Thats not an uncommon fault on the 2.5. Its worth checking the wiring loom where it passes the cam covers to make sure it's not damaged.
    Ingolstance Read about my A6 HERE.

  7. #6
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Mine comes on when the wind changes direction, or there's a week in the month !
    then won't come on for between 50 and a hundred miles, stays on till I turn the ign; off start back up and all's fine for another hundred miles or so !!! WTF

    Had mine scanned,,, 1 code steering angle sensor,
    Checked the front tyre pressure today 35 psi n/side,,, 15 psi o/side, maybe this was my problem !
    Last edited by Digger1; 7th January 2011 at 08:34.

  8. #7
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    the steering angle sensor is behind the steering wheel and may throw up the esp light, have you had cruise and dis retrofitted? maybe in need of a new steering angle bit.or there maybe a loose connection somewhere
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Quote Originally Posted by swarcup View Post
    the steering angle sensor is behind the steering wheel and may throw up the esp light, have you had cruise and dis retrofitted? maybe in need of a new steering angle bit.or there maybe a loose connection somewhere
    cruise and dis,,, factory fitted
    I changed the steering wheel + after having it lowered I had 4 wheel alignment done and the s/wheel was slightly of center so I removed and replaced it in line...

  10. #9
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    Taking the wheel off to straighten it wont affect it. Ive done it on mine as when i fitted cruise and dis as i didnt refit it quite straight. there is a steering angle calibration sequence you can try but it requires vag-com. Other than that it may well be an intermitant fault with the sensor itself.
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  11. #10
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    You have PM !

  12. #11
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Quote Originally Posted by mike foster View Post
    You have PM !

    DO I !

  13. #12
    TheBigUn's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Posts
    7
    Quote Originally Posted by brownie 25 View Post
    well everyone the esp light has been coming on and off for a while now but today started the car from cold and drove out of my drive,and with the wheels turned left there was a bit of a grind from front left wheel and it was like the brake stuck for a split second and released again (one problem).later on in the day was taking off from a junction and it seemed there was no power for about 3 sec and the esp light was flashing,then it just drove on again fine and the light stopped flashing any one ever have anything like this.
    ps its a 01 a4 2.5 qs
    Mine has been similar for the past 6 months, I do a lot of motorway miles and some days it's fine. Other days it judders slightly and the ESP light comes on then goes out for a while and then comes back on? If I switch the engine off it re-sets and may or may not come back on? At low speeds it very rarely comes on at all?

    It is mystifying but it's due a service soon so hopefully I'll be able to sort it. (Cheaply )
    A6 Avant ~ 2.5 TDI ~ SE CVT ~ 2002

  14. #13
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Quote Originally Posted by Digger1 View Post



    DO I !
    Sorry Digger - just read the post - the PM was for Swarcup !!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO