Sky InsuranceBadger5
Results 1 to 4 of 4

Thread: Climate control

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2004
    Posts
    34

    Climate control

    The climate control on my car seems to have stopped working, on LO it is cold but from 18 degrees c upwards it is red hot. I recently had a new thermostat and housing after the engine was overheating any ideas???

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    London UK
    Posts
    2,614

    Re: Climate control

    No but i think mine is starting to go the same way. At 19.5 or even 18.5 it pumps like its on full for about 5 minutes before starting to cool down. Think a trip to the stealers is in order!

  4. #3
    imported_ronny
    Guest

    Re: Climate control

    Mine is the same its weird, put it on Auto though and its fine.

    I recken its just the climate system, my old B5 climate was better.

    Try sticking it on Auto and setting 18c on both displays, you will find it doesnt get half as hot

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Oct 2004
    Posts
    34

    Re: Climate control

    ill give that a try, thanks, id agree abut the b5 control but that only had one screen instead of the three!!!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO