Chris NottAH Fabrications
Page 1 of 2 12 LastLast
Results 1 to 40 of 48
  1. #1
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314

    car wobbles on idle TDI(possible injector problem!?)

    my audi a4 wobbles the car on idle i have determined it to be a engine/injector fault and it only does it when stationary....

    has anyone got any experience with this? ie would it be injector seals or the injectors blocking or sticking?

    Should i buy new injectors or 1 new one and try and find the fautly one!?

    cheers Ad

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    paul20v's Avatar
    Audi fanatic

    Status
    Offline
    Join Date
    May 2009
    Location
    S.Wales
    Posts
    1,108
    I would get the injector loom changed first
    its very rare for an injector to go down like this

  4. #3
    SerialAudiOffender

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Scotland
    Posts
    100
    If it's the 1.9 lump, then I'm sure the engine mounts have a history of knackering and causing severe idle shaking and vibrating of the whole unit??? Normally ok when driving the car under load though. Worth checking out I'd say.

  5. #4
    S3 MRU's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Luton, Bedfordshire
    Posts
    756
    my a3 8p 2004 model does this... not all the time only sometimes like now and then

  6. #5
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    yes its a 1.9 lump pd130...

    The injector loom is a twat to change tho is it not!? we had the rocker cover off and checked the loom, cleaned it and refitted and was still the same.... but the way it looked was the loom had to be removed backwards ie would need the head off for removal!?

    i know people suggest the loom but i REALLY don't think it is that... and i also think the engine mounts are a bit crap too and need replacing but it is not this causing the wobbles my mechanic suggest there is a miss on it...

    JUST to add this is my GF's car so i' kinda doing this for her so i dont drive it daily too see how it acts BUT i do drive it once a week and have tried things like injector cleaner in the fuel to sort it but has made it slightly better but not fixed by no means...

    Are the pd injectors all the same? or can the nozzles be changed? perhaps that could be a option? I have a 2001 A3 tdi and i have changed the nozzles on that one no problem but just unsure if the PD injectors can be done in the same way!? if so we could change them upto a higher flow to improve the power before we remap it...
    Last edited by MAD_Adamski; 22nd November 2010 at 02:06.

  7. #6
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    I'm pretty sure you don't need to take the head off to do the loom mate I had this and although I did not need a new one looked into it and it says nothing about the head from memory rocker cover and then it pulls out from the back .
    Also a guy on here just adjusted his tick over a wee bit and it stopped it to just a thought though

  8. #7
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,723
    im surprised nobody has said duel mass fly wheel yet, they make the engine rock at tick over, when you drive the car, does it settle down?

  9. #8
    CHRIS555's Avatar
    DOPE with added OCD

    Status
    Offline
    Join Date
    Jul 2010
    Location
    Midlands
    Posts
    1,941
    Does this model have a crankcase breather valve?????

    If so - thats your baby!

    On the petrol models these go all time and only show themselves at idle, by creating a vibration which feels like a misfire or as if the car is being battered by the wind, yet as soon as you increase the revs and drive away everything is fine.

    If it is this the part is normally under 10 and is a DIY job.

  10. #9
    chrisash32's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Manchester
    Posts
    575
    my TDi has suffered from this for at least 12 months.. As described above the car feels like its shaking side to side.
    Would also be interested to hear a fix on this.

  11. #10
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    as said it seems to have a slight miss which leads me to think its a injector!? does anyone know about the injectors in my previous post?

  12. #11
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    Quote Originally Posted by Turkster View Post
    im surprised nobody has said duel mass fly wheel yet, they make the engine rock at tick over, when you drive the car, does it settle down?
    yes but if its stationary in gear, out of gear, on bite, on revs, it still does it so not clutch/fly problem....

  13. #12
    paul20v's Avatar
    Audi fanatic

    Status
    Offline
    Join Date
    May 2009
    Location
    S.Wales
    Posts
    1,108
    Quote Originally Posted by MAD_Adamski View Post
    yes its a 1.9 lump pd130...

    The injector loom is a twat to change tho is it not!?
    No
    the injector loom bends into sections its a fiddle but does come out and go back in ive done a few
    personally i wouldnt start fiddling with pd injectors there very fussy and also any dirt of any type in them could render them useless.
    have you had the car on a diagnostic and check what fault codes the missfire is bringing up?

  14. #13
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    Quote Originally Posted by paul20v View Post
    No
    the injector loom bends into sections its a fiddle but does come out and go back in ive done a few
    personally i wouldnt start fiddling with pd injectors there very fussy and also any dirt of any type in them could render them useless.
    have you had the car on a diagnostic and check what fault codes the missfire is bringing up?
    i have handled injectors before so that is not a worry to me a have done alot of hands on stuff before just not with his car yet,, i will try and get a chap i know with a fault reader to come have a look.. but just wondered if others have had/solved this before!?

  15. #14
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    when you had the loom out did you try just closing up the little spade terminals on the plugs to the injectors?

  16. #15
    hybenz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    10
    Quote Originally Posted by MAD_Adamski View Post
    my audi a4 wobbles the car on idle i have determined it to be a engine/injector fault and it only does it when stationary....

    has anyone got any experience with this? ie would it be injector seals or the injectors blocking or sticking?

    Should i buy new injectors or 1 new one and try and find the fautly one!?

    cheers Ad
    Hi MAD_Adamski, i remember reading one post from audi repair questions that has the same case as yours. He replaced his injectors-that solved his problem. If i remember it correctly,it has something to do with DMF failure.

  17. #16
    paul20v's Avatar
    Audi fanatic

    Status
    Offline
    Join Date
    May 2009
    Location
    S.Wales
    Posts
    1,108
    Quote Originally Posted by hybenz View Post
    Hi MAD_Adamski, i remember reading one post from audi repair questions that has the same case as yours. He replaced his injectors-that solved his problem. If i remember it correctly,it has something to do with DMF failure.
    DMF= Dual Mass Flywheel
    did he change injectors or the fly wheel or both ?

  18. #17
    hybenz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    10
    Quote Originally Posted by hybenz View Post
    Hi MAD_Adamski, i remember reading one post from audi repair questions that has the same case as yours. He replaced his injectors-that solved his problem. If i remember it correctly,it has something to do with DMF failure.
    He replaced his injectors first,but it only work for a while. He's planning to change his fly wheel this week.

  19. #18
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    well go a mate coming to plug it in when h's next round he's a customer of mine but a mechanic, so he will have a look for me then if not we may change the injectors it seems definatly to be fuel related i could be wrong but just seems unlikely to be DMF by the way its acting

  20. #19
    deanski's Avatar
    wax on, wax off

    Status
    Offline
    Join Date
    May 2010
    Location
    Lancashire
    Posts
    374
    mine wobbles on idle sometimes. it has a brand new DMF in it and the wobble persists with the clutch in. Nothing shows on vagcom even when its doing it. I have a cold start problem and roughness at around 2k rpm to coincide with the wobble so its pointing to the injectors for me.

  21. #20
    Neutral

    Status
    Offline
    Join Date
    Dec 2009
    Posts
    76
    Its something to do with injectors being dirty i think. injector cleaner fixed mine for a while but it is back again and a small missfire as you describe also you said injector cleaner helped. i think a really heavy dose of injector cleaner and right foot is the way to go. its not dmf as it wouldnt fix itself sometimes. mine shows no fault codes.

  22. #21
    MAD_Adamski's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    314
    we have tried a few types of cleaner with no joy so think we need the injectors cleaned properly or changed....

  23. #22
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Durham
    Posts
    110
    i've got this problem to,its deffinitly not the flywheel on mine as i've just had it changed ,only seems to do it though when the engine is warm,when started from cold its steady as a rock.

  24. #23
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Location
    South Wales
    Posts
    18
    Mine does it on start up but not tickover, is this a sign of future problems?
    2004 Sport Avant 1.9 TDi

  25. #24
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Posts
    274
    My A3 2.0TDI only does this when idling (handbrake applied, clutch disenganged/out of gear) on a slight inclined hill.. rarely when level but it has happened.
    8P Audi A3 2.0TDI Quattro Sport - what a change from my 1.0L CorsaC!!!

    follow me on Twitter - Jonay1990 for #Photography #Aviation #Mil #Automotive #Subsea

  26. #25
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    33
    My a4 2.5 quattro 180 did this and it was the dual mass flywheel, only on idle and smoothed out once reved. could not notice it when driving or in gear.

  27. #26
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    so it whent when you put your cluch in ?

  28. #27
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2010
    Posts
    1
    Hi Chaps,
    Going back to the start of this thread, I started to notice exactly the same thing with my 57 A3 TDI 170 Sportback (88K) a couple of months ago, that I could feel the motor shaking the car slightly at idle when waiting at traffic lights. Which it didn't use to do.
    And then, last Friday leaving work, the thing conked out dead halfway round the carpark and couldn't be started at all.
    So I had it recovered to Watford Audi because I had no means of diagnosing the falut or attempting a repair in the work carpark.
    And today I got a call..a fault on the number 2 injection unit, cost to replace: 1092...ouch. There was no detail as to whether the fault was mechanical or electrical.
    That quote was based on a 4-hour job, which seemed long to me...but not much option at this point.
    Anyhow, it will be interesting to see afterwards whether the lumpy idle still exists or not.
    If it still is, then I would start to suspect DMF.

  29. #28
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Durham
    Posts
    110
    did you ever get to the bottm of what was causing the shake cause mines exactly the same but steady when cold on first startup but get pretty back if the car has been running awhile.

  30. #29
    deanski's Avatar
    wax on, wax off

    Status
    Offline
    Join Date
    May 2010
    Location
    Lancashire
    Posts
    374
    sorry to dig an oldish thread but mine also wobbles sometimes at idle but i just noticed that it starts when i turn the heater controls off. if i turn it back on it will stop for a minute then start again?
    A4 B6 1.9 tdi 130. Slowly modding but don't tell the missus.
    Front ambient lighting
    Eibach sportlines.
    Audi TT Alloys.

  31. #30
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    346
    ime in the same boat lads,changed the loom today and its still the same going to try injectors tomorrow,just wondering has any one come to a conclusion on this

  32. #31
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Bournemouth
    Posts
    312
    You could try upping the tickover if you have VCDS. I had an annoying exhaust vibration / resonance at idle put the tickover up a few clicks and resonance gone
    FOR SALE... 2007 Rns-e (sds), 2009 OEM bluetooth module, Flat bottom TTRS MFSW, steering wheel control module and slipring. All in Classifieds, Pm me if interested.

    RS6 Avant, Milltek non res, Forge, ITG, Bilstein, Hotchkis.

  33. #32
    deanski's Avatar
    wax on, wax off

    Status
    Offline
    Join Date
    May 2010
    Location
    Lancashire
    Posts
    374
    i think mine is the alternator clutch pulley so gonna try and change that.
    A4 B6 1.9 tdi 130. Slowly modding but don't tell the missus.
    Front ambient lighting
    Eibach sportlines.
    Audi TT Alloys.

  34. #33
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Kidderminster, Worcestershire
    Posts
    1
    My 1.9TDI 130 A4 does this. I'm convinced it's also a fuel/injector problem. Car has done 170k.
    It misses when ticking over, seems to be better when cold than when it's warm. Raising the tickover with my right foot very slightly (10-20rpm etc) seems to smooth it out. I was just wondering if by doing this and adding a tiny amount of fuel, that if I do have a slightly lazy injector then it's giving it enough to allow it to run ok.
    I have VCDS, anyone any tips as to how to raise the tickover slightly? I'm lucky in that most of my driving doesn't see a lot of traffic and hence ticking over
    I'm also convinced it's not a clutch/DMF issues, or the alternator clutch which I did last year.
    Phil

  35. #34
    1st Gear

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    184
    Mine was caused as the timing was out. Check one of my threads on how to check for it.

  36. #35
    marktdisport's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    mids
    Posts
    1,193
    my brother owns a jetta 140 tdi 56plate with 60k which has the biggest shaky idle ever and it's been diagnosed as dual mass flywheel also being faulty !! it's now been like this since 30k... diagnosed by vw main stealers... my a4 pdi130 is also going in next monday for new engine mount, DMFlywheel, new clutch, rear mains and the rear gearbox mount my a4 has a perfect tick over though so cant say i got a tick over problem to compare it to when i get it back, But my car running std 130hp didnt have a clutch fault at all apart from biting a bit high up but since mapped it know shakes and judders under load, few times in the cold spell ive noticed a few shakes on tick over when start up but id guess that as normal for a diesel
    A4 TDI 130 SPORT..
    now sold but still in the family, gone back in time to the cupra R again..

  37. #36
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Hertford, UK
    Posts
    116
    My A3 2.0 TDI is doing it.
    A good friend of mine is a Landy specialist and recommends this cleaner as the best money an buy:

    http://www.uniteddiesel.co.uk/diesel-fuel-treatment.php

    I'll order some today and let you know how it goes.

  38. #37
    white.akita's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    county durham
    Posts
    280
    In my opinion 90% of the time when these vag diesels have an intermittant shaky idle it is because the timing is out.
    it doesnt matter if your timing belt was just changed it can still be wrong unless the timing was set with vcds.
    There are 3 bolts on the cam pulley that need to be loosened slightly then the cam pulley can be moved a few mm in either direction using the big nut in the middle until it is within the correct tollerence.
    Its very very easy to fix you just need vcds and the tollerence figures.
    Audi call this procedure idle stabilization and the timing is fine tuned this way.
    check this out also How to adjust rough idle and camshaft timing on VW and Audi TDI pumpe duse engine
    Last edited by white.akita; 26th January 2012 at 16:44.
    2003 A4 2.5 TDI QUATTRO AVANT

  39. #38
    Charlie Ford's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2011
    Location
    RAF Benson
    Posts
    96
    i have spoken to Audi about mine and the tech at the garage thinks my timing could be out slightly not enough to cause damage but a slower start and a slight wobble.
    (53) Graphite A3 2.0 TDI (Sport) Avionics aircraft engineer, currently based in oxforshire working on Merlin EH101 Support helpicopter


  40. #39
    white.akita's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    county durham
    Posts
    280
    i had exactly the same problem before the new cambelt kit was fitted, after it was fitted the idle was fine but after about 6 weeks the rough intermittant idle came back.

    after ALOT of searching this VERY common vag diesel problem i deceided to alter the timing on the cam sprocket as detailed above but without the use of vcds as i dont have it or could get the use of it.

    anyway, i turned the cam sprocket clockwise about 1mm then tightened the 3 nuts back up and tried it, the idle was better but still not as smooth as i wanted so i turned it clockwise about another 2mm and now the car idles/starts/drives perfectly.

    it seems that hundreds of people have had this problem and people have been searching for years to fix it without any luck and most have just put up with it or adjusted the idle with vcds to mask the problem ,but just by adjusting the idle with vcds it means that the timing is still not correct and it is probably down on power and mpg as im sure it would be better if the timing was set correctly.
    Last edited by white.akita; 27th January 2012 at 14:06.
    2003 A4 2.5 TDI QUATTRO AVANT

  41. #40
    deanski's Avatar
    wax on, wax off

    Status
    Offline
    Join Date
    May 2010
    Location
    Lancashire
    Posts
    374
    sorry to bump and old thread but my car had the exact same problem and it as fixed today by Ian Collins Automotive in Preston.

    My car had had a timing belt fitted under warranty when I bought it and they hadn't set it properly so it wobbled at idle when warm. He picked it up on VCDS as the KW power units were down slightly. All fixed and rock steady now.
    A4 B6 1.9 tdi 130. Slowly modding but don't tell the missus.
    Front ambient lighting
    Eibach sportlines.
    Audi TT Alloys.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO