Volks AutosJMB Retrofits
Results 1 to 9 of 9
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2009
    Posts
    20

    Intermittent remote central locking

    2003 A4 Avant TDi

    I have an intermittent issue with the remote central locking. Every now and then it just fails to work. Sometimes putting the key in the ignition fixes it straight away. Sometimes it can take a few goes (I usually just ignore it, use the car as normal locking the doors manually until it mysteriously starts working again).

    I have 2 keys and both seem to be the same, although I've only ever tried the second key when the main one is failing anyway.

    The key always works in the ignition so the car is recognising the immobiliser code on the key (?) it just seems to forget the remote central lock code ?

    initially this would happen once every few months and be fine again as soon as they key as in ignition, but it's far more frequent now. Sometimes the car will lock fine, then fail to unlock a few minutes later. Other times it will have unlocked fine, been driven then refuse to lock straight away when getting out. Then it may work fine for days.

    Any ideas as this is starting to annoy me now. I've got to manually unlock the drivers door, put the ignition key in and turn it to release the tailgate lock to let my dog in.

    Thanks
    Martin.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    i have this and when i wiggel the wier blockthat goes into the drivers door it works fine

  4. #3
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Quote Originally Posted by funkyspider View Post
    2003 A4 Avant TDi

    I have an intermittent issue with the remote central locking. Every now and then it just fails to work. Sometimes putting the key in the ignition fixes it straight away. Sometimes it can take a few goes (I usually just ignore it, use the car as normal locking the doors manually until it mysteriously starts working again).

    I have 2 keys and both seem to be the same, although I've only ever tried the second key when the main one is failing anyway.

    The key always works in the ignition so the car is recognising the immobiliser code on the key (?) it just seems to forget the remote central lock code ?

    initially this would happen once every few months and be fine again as soon as they key as in ignition, but it's far more frequent now. Sometimes the car will lock fine, then fail to unlock a few minutes later. Other times it will have unlocked fine, been driven then refuse to lock straight away when getting out. Then it may work fine for days.

    Any ideas as this is starting to annoy me now. I've got to manually unlock the drivers door, put the ignition key in and turn it to release the tailgate lock to let my dog in.

    Thanks
    Martin.
    Had exactly the same problem,,, put the car on VAG-COM, which showed intermittent fault with both keys plus broken wire in drivers door jam, repaired the wire,, No difference so I replaced the battery in one of the keys despite being told it was fine,, and also the rubber button section that you press to lock-unlock...
    It now works fine,,, all of the time !!! ... I got the rubber button section for the key off the bay for a couple of quid, just need to do the other one now !!!

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2010
    Posts
    2
    I have the same problem. Have replaced the remote with a new battery and still no effect. The rubber is still good. I have vag-com and can see that the remote is actually picked up the Central Convenience (46) controller. The remote I'm using is adapted as 2 (Key from adapted position) under Group 7 (Measuring Blocks). And pressing each button on the remote will register under Remote control command either 1,2 or 3.

    I'm wondering if there is a communication problem or lost signal due to a broken wire between the controller and the lock cylinders. Any guess where this central convenience controller is located and where would the harness would follow to any further to look for bad connections on any connector blocks?

    Many thanks.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2010
    Posts
    2
    And suddenly the remote decided to work again. And I wonder for how long againg

  7. #6
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    a new battery cured the same issue for me, when i had my problem the range wasnt very good aswell.New battery and it worked from 30 yards away
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2010
    Posts
    2
    Ive had the same problem with my audi a4 cab 2.4 6speed.. Works intermittantly. Was told by a garage that the module needs replacing.total cost 400.

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    sutton coldfield
    Posts
    440
    Quote Originally Posted by jassoni View Post
    Ive had the same problem with my audi a4 cab 2.4 6speed.. Works intermittantly. Was told by a garage that the module needs replacing.total cost 400.
    I was told the same,,, try the battery and button pad first !!!

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2010
    Posts
    2
    Tried a new battery which was bought from E-bay, will try a new button pad. cheers

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO