Volks AutosEM Tuning
Results 1 to 8 of 8
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2007
    Posts
    17

    audi avant tdi sport diesel, 2003,engine races when cold

    Hi all, can anyone help, when i first start up in the mornings, the engines races briefly, and i don't have my foot on the accelerator. any ideas on this problem, someone mentioned a airflow sensor could be needed, euro carparts want Ł102 for one,
    as i'm on a pension,, thats out of the question.
    thankyou,

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Sep 2010
    Posts
    167
    Hi ive come across this problem before on the pd engine and it was the coolant temp switch at fault, carnt see how the air mass meter would cause it but i may be wrong. If you can do a scan of the ecu should pick up the fault, but the ones ive had , new temp switch had fixed it.

  4. #3
    sniffy_smiffy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    115
    If you suspect MAF (Airflow) then unplug it from the connector the car will ignore its readings and run a default set of data through the ECU, then start her up & see if it makes a difference?

    If not then look elsewhere I.E CTS (Coolant Temp Sender/Sensor) or further...

    If you cant find the problem then you really need someone to scan your E.C.U with VAGcom / VCDS software for errors as this should report a dodgy component.

    There is a VCDS / VAGcom section on this forum to find local members who will help you out.
    People are very helpful on ASN with that sort of thing.

    Good Luck.

    If it doesnt't work out @ least the bus tickets are free.......
    Sorry only playing could not resist that one..
    Audi A4 Avant 1.8T Limted Edition 2004 Manual (30k Miles) - Akoya Silver - S-Line Bodykit - RS4 17" Alloys
    Heated Leather/Alcantra Seats



    My Ex's (Some not so desirable !! ahemm...)
    VW Golf 2.3 V5 170BHP
    VW Polo 1.2 C Formel E - The Beast .....
    Ford Fiesta 1.6 Si

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Bournemouth
    Posts
    312
    Mine done the same when i bought it and it was the coolant temp sensor. It will show up in Vcds and other diagnostic equipment. If doing it yourself (quite easy) buy the plastic clip and rubber o ring too, about Ł25 all in.
    FOR SALE... 2007 Rns-e (sds), 2009 OEM bluetooth module, Flat bottom TTRS MFSW, steering wheel control module and slipring. All in Classifieds, Pm me if interested.

    RS6 Avant, Milltek non res, Forge, ITG, Bilstein, Hotchkis.

  6. #5
    sniffy_smiffy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    115

    audi avant tdi sport diesel, 2003,engine races when cold

    The CTS was a pain in the ass on my old v5 Golf! I had to replace most of my engine coolant that ended up on my driveway...

    You had to have ladies hands to get at it.

    Was like trying to paint your hallway through your letterbox !!!

    I guess it is easier on the Audi's ?? Have not had to do it yet so don't know?
    Audi A4 Avant 1.8T Limted Edition 2004 Manual (30k Miles) - Akoya Silver - S-Line Bodykit - RS4 17" Alloys
    Heated Leather/Alcantra Seats



    My Ex's (Some not so desirable !! ahemm...)
    VW Golf 2.3 V5 170BHP
    VW Polo 1.2 C Formel E - The Beast .....
    Ford Fiesta 1.6 Si

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Nov 2005
    Location
    Midlands
    Posts
    215
    Always best to buy some G12 fluid.

    On my 1.9tdi, it drained most of the fluid.
    2004 A4 2.5tdi Avant quattro Sport Tip, BOSE, Elec Heated Leather Seats with Memory, Sunroof, Black Optic Pack (Black Grill, Window Frame and Roof Rails), Front & Rear Electric Windows, Front & Rear Parking Sensors, Lighting Pack, Xenon Lights with Washers, Come Home Lights, Electric Retracting Mirrors, Auto Dimming Rear View & Side Mirrors, Under Seat Storage & 6 CD Changer

    Gone But Not Missed -

    2003 A4 Saloon 1.9tdi Sport Multi, Leather/Alcantara Heated Seats, Lighting Pack & RS4 Alloys

  8. #7
    Garfie's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2009
    Location
    Ipswich, Suffolk
    Posts
    179
    Sounds like the coolant temperature sensor to me too. My Golf used to occasionally rev up briefly when I started it as the wiring in the plug to the CTS was dodgy. If it reved up I would just pop the bonnet and wiggle the wires and connector and it would be fine again for a few weeks before it went again.

    I'd therefore try checking the connection to yours first before replacing the sensor.

    On a 130 PD its located on the back of the engine about 8-10 inches down, accessed from the passenger side, you can't really see it, you'll have to feel for it. Access is easier with the rigid boost pipe removed and the flexible section unclipped but as mentioned above its not a job for someone with big hands!!

    Current Car:

    A3 S-Line TDI 140bhp Sportback in Misano Red Pearl with Audi Open Sky System, Chrome Roof Rails, Full Leather, Front Armrest with Audi Phone Prep, MFSW, Cruise Control, Auto Wipers, Auto Lights, Auto Dim Mirror, Rear Parking Sensors, Bose Stereo, Privacy Glass, Ambient & Footwell Lighting and Puddle Lights.

    Pic soon

    Gone but not forgotten:

    Audi A4 TDI Sport Avant in Denim Blue
    VW Golf Mk4 GTTDI
    Vauxhall Calibra 2.0 16V 150bhp Red Top
    Vauxhall NovaVAN 1.5TD

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    May 2007
    Posts
    17
    Thankyou all for your reply's, i will check the coolant sensor, cheers

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO