JMB RetrofitsEM Tuning
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    12

    A4 1.9 TDI pd 130 misfire - cough/mis/splutter under load - judder on idle

    Hello everyone.

    Hopefully someone can help on here. Recently bought a 2001 1.9 tdi pd 130sport and love it apart from the fault is has suddenly developed. When it is cold it is usually fine however once warm it runs perfectly find on idle but judders through the cabin. It has had the flywheel done 4k milles ago and no fault codes for the engine dampner so i am thinking it could be this that need adjusting - TDIClub Forums - View Single Post - injection pump repair, fuel quantity

    However more annoyingly when its warm driving normally it runs well through the rev range. But when accelerating hard it cuts out / chugs / coughs above the 2k rev range to the red line. There are no fault codes in the ecu.It does drive through it to the red line and doesnt go into limp home mode, nor does it smoke. It normally happens at around the 3k rpm mark and only does so on wide open throttle. Its getting quite annoying now and what to get this sorted out asap as i want to send it to be remapped but not untill i know its running as it should.

    Any help or suggestions would be greatly appreciated.

    Ian

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2011
    Location
    Harrogate, North Yorkshire, United Kingdom
    Posts
    11
    Hi did you manage to cure this fault i know its an old post but i seem to be having similar problem

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Swansea - South Wales
    Posts
    8
    Sounds like it could be a similar problem to me, when I had a mk4 Golf 1.9 TDi. I'd get a missfire once the car was warm and it just kept getting worse over a few weeks. Turns out it was the wiring loom that powers the fuel injectors that runs through the head. It's fairly straight forward to change and they are only about £30 new from the main dealer.

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Nov 2011
    Location
    South Lanarkshire
    Posts
    81
    I've just had a similar problem with my A4 avant, I scanned for faults and there was none that would cause the misfire/spluttering that you describe.
    The cure I'm running at now is that I by-passed my fuel filter with 2 inline filters.My fuel filter was only 6 weeks old but it looks like the problem is with the T peice on top of the filter.
    I think the T peice puts returned fuel back into the filter and this keeps the filter full.I've ran with the 2 iline filters for nearly 3 weeks and the misfire /splutter has never cameback.
    Its worth the £5 for the 2 filters to try.
    HTH M

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2011
    Location
    Harrogate, North Yorkshire, United Kingdom
    Posts
    11
    Ive fitted a new fuel filter and new (bosch) Maf , its better at 2000 revs but still shuddering at 3500,i know you can fit a new t piece for the top of the filter might try that and look at bypassing it too,if no improvement,its ok when cold it has the problem once warm which to me means harness in the head or cam sensor or crank sensor,i still have engine mount to replace too

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO