EM TuningVolks Autos
Results 1 to 10 of 10
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Bridgend, s-wales
    Posts
    4

    cooling fans constantly on.

    hi all, i'm a newbie so be kind and help me out if i get it wrong.

    I own a 54 reg A3 2.0 tdi, 3 door in red.
    I have a couple of problems with it and i wondered if anyone could help.

    Firstly as soon as the ignition is turned on the radiator fans come on and don't stop until you take the key back out. are my fans broken? as i have heard that they run constantly when broken, or could it be a stuck relay etc....

    Secondly when you turn on the ignition the horn blasts for 5 seconds and then goes off, any ideas?
    Last edited by chud-godfrey; 20th August 2009 at 23:54.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,166
    There are a few threads in this list that are about the same problem:

    http://www.audi-sport.net/vb/search....archid=1282186

    Never heard of the horn problem! What year is it?
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Bridgend, s-wales
    Posts
    4
    it's a 54 plate, 2005 year. cheers for the links

  5. #4
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    some kind of relay on the horn...

    and is the ac on when as that would mean the fans would be coming on.

    try it with the econ light off
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  6. #5
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,166
    Not with just the ignition on though.
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  7. #6
    slick-A3's Avatar
    A3/TDI/S-LINE/BBS LM SPLITTYS

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    67
    It sound's like, the same problem that i had with the cooling system management system.

    If it is, the fan unit, it will mean replacing the whole black radiator cowl with the fans, as i had to, not cheap but there is not much you can do.lol. it will cost you about 300-400 i would think.

    let me know how you get on?

    Tom

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Bridgend, s-wales
    Posts
    4
    cheers tom, will do, it's going in to the dealer on wednesday, so keep you posted

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Bridgend, s-wales
    Posts
    4
    ok, so got the news today, that the horn has an earth to ground problem. when the ignition is turned on the horn sounds. Then the brain registers a fault and cuts the horn after 5 seconds.
    It turns out that the contacts in the steering wheel are touching, probably because of my over enthusiastic honking.......so with some new parts it should be as good as new..
    The problem with the fans is still a mystery.... more checks tomorrow

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    cheshire
    Posts
    22
    i've come across this fan issue before: you'll need to replace the fans and cowling etc as someone has already mentioned, then they need to be re-programmed in apparently. quite a common issue on the A3 so it seems.

  11. #10
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,028
    Horn is a self fix tbh if you have a torx set to remove airbag & the fans, well have you checked the coolant sensor, does the dash show 90 all the time for temp, any scans of the car with diagnostic like vagcom with any errors for us to see?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO