AH FabricationsMonster Motorsport
Results 1 to 19 of 19
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9

    Audi A3 8p emission control light, Surrey - VAG-com help?

    Hi all,

    Its my first time on the site and hope you can help.

    Had my 2004 2.0Tdi 140 (engine BKD) for two weeks now and the emission control light has come on. I have read the manual and had a check through a number of informative posts on the subject.

    I understand I need to get a fault code read and the local stealer will charge standard labour rate if I take it to them. So I was wondering if there's anyone who would be kind enough to put their software to the test and help me out.

    Could it be something to do with a remap the car has had? Read a few threads which seem to indicate a link between the two..

    I also wanted to know whether it is safe to drive the vehicle, as my partner needs it to get to work. I was 45miles from home when the light came on earlier today, but eased down the motorway. It hasn't started to flash yet.

    Really need to get it sorted ASAP, but would be great to avoid having to be ripped off by the dealer.

    Many thanks!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Hi there.

    Does the car drive any differently with the light on - if no then:

    The Intake Manifold Flap is common prob on your model of A3.

    If you check the F8 Fuse (find it in the manual) and if its blown - it could be the IMF (may ease your mind for now)

    But, best bet is to VAGCOM it - Then you will find out the exact prob and be able to sort it.

    It shouldnt do any harm driving it. The engine manangement light is orange which means get to to a garage as soon as. If it were red - then stop driving and get it checked immediately!
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  4. #3
    S3-N's Avatar
    ?

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    263
    Phantom Black B7 S4 + Milltek

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Quote Originally Posted by kaz219 View Post
    Hi there.

    Does the car drive any differently with the light on - if no then:

    The Intake Manifold Flap is common prob on your model of A3.

    If you check the F8 Fuse (find it in the manual) and if its blown - it could be the IMF (may ease your mind for now)

    But, best bet is to VAGCOM it - Then you will find out the exact prob and be able to sort it.

    It shouldnt do any harm driving it. The engine manangement light is orange which means get to to a garage as soon as. If it were red - then stop driving and get it checked immediately!
    Checked the fuse box and fuse F8 is blown.

    Still going to try and find someone in the Epsom area who could help me VAGCOM it, to identify what exactly has decided to stop working properly.

    If it is the IMF - could anyone give me a rough idea of costs involved?

    Thanks

  6. #5
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Guessed right :-)

    that fuse is for the fans and imf

    as the emission light came on, it is more than likely to be the IMF.

    They are 206 from euro car parts, 10-20 for seals and stuff, my as well clean the EGR 5 for carb cleaner and its easy enough to fit yourself.

    i wrote a guide on this thread as mine popped too.

    http://audi-sport.net/vb/showthread.php?t=58985

    Replace the fuse for now as the fans wont work so your car can overheat.

    If your lucky, when you clear the codes, it may not come back as it could have randomly jammed and may start working. If it comes back, pop it out and keep pushing the butterfly flap in and out around 50 times and if it jams, then its screwed - the cogs have gone in it. if ot doesnt jam clean it and put it back in and you may be ok.

    but tbh - only one person has got lucky with jsut cleaning the imf. chances are, its screwed....and will need repalcing.

    BTW - second hand are about 100 to 150.

    BBTW - its safe to drive with the IMF broke. Me and Boydie both drove with ours broke for a long period of time - mines was 3 months lol
    Last edited by kaz219; 23rd February 2009 at 14:25.
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Thanks for the advice kaz219. I'll get a new fuse on tonight and have put the VAGCOM directory to use here by getting in contact with MikeA3. He's kindly offered to come and read the fault codes for me.

    Just out of interest, Mike has an 8L 2003, and was unsure whether the connector he has is compatible with mine. Any thoughts?

    Fingers crossed it will, otherwise I'll get in touch with Vagcheck.com (thanks S3-N).

    Update to follow.

  8. #7
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    As long as his vagcom is hex can - it will work.

    Keep an eye on the fuse after you replace it too...

    Shame your not round my way - i would have scanned it for you!
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Right ok - thanks to MikeA3 for coming over with the VAGCOM software.

    The following codes came up on the initial scan (didn't have a printer hooked up)

    17978 - P1570-000 Engine start blocked by immobilizer Engine starting but stalling immediately

    17075 - P0691-000 Fan control circuit 1 controller low

    19558-p3102-000 Motor for intake manifold map (V157): No signal


    Codes were cleared and engine started. ECON light gone out. Then another scan on the system was done and there was only one fault that came back....17075 - P0691-000 Fan control circuit 1 controller low

    Need to check if the fans are working properly.

    Replaced the blow fuse (F8) and having driven for 15 mins, it had blown again. I noticed the fans were not working after I had stopped the car on the drive, without switching off the engine.

    There is also a bit of a shudder when you stop the engine.

    Not really sure whether its the intake manifold and fan - are they connected? Will take the car for a drive and warm it up, and then check if fans are working..

    Any help would be appreciated!

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    69
    Just thought i would tell you my ongoing experience about this!

    A few weeks ago the ECON light came on and stayed on. While doing some research on this, the orange emissions light came on. Found out the 2 were linked so instead of paying for diagnostic i just booked my car in at audi for an air con service. Apparently needed doing so got that done and they told me the problem! (2 birds with 1 stone).

    Fuse F8 had blown so they replaced that, which knocked the emissions light off. It hasnt came back on so hopefully thats sorted. ECON light remained on though!

    Turns out there were leaks in the air con system. There were slits in the air con pipe so had that replaced but still no better. Trying the condensor next so hopefully that will sort it out!

    Anyone else had similar problem?

  11. #10
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Has the emmision light gone off - if so, keep driving for a bit and see if it comes back..

    17075 - P0691-000 Fan control circuit 1 controller low - is the fuse which has blown

    19558-p3102-000 Motor for intake manifold map (V157): No signal - IMF

    As above, drive it and if the emissions light returns, it will be the IMF.

    Here were my fault codes when the IMF broke:

    3 Faults Found:
    19558 - Motor for Intake Manifold Flap (V157): No Signal
    P3102 - 000 - - - Intermittent
    Freeze Frame:
    RPM: 0 /min
    Torque: 0.0 Nm
    Speed: 0.0 km/h
    Load: 0.0 %
    Voltage: 12.46 V
    Bin. Bits: 00101100
    Torque: 0.0 Nm
    Torque: 92.0 Nm
    19557 - Motor for Intake Manifold Flap (V157): Open or Short to Ground
    P3101 - 000 - -
    Freeze Frame:
    RPM: 0 /min
    Torque: 0.0 Nm
    Speed: 0.0 km/h
    Load: 0.0 %
    Voltage: 12.46 V
    Bin. Bits: 00101100
    Torque: 0.0 Nm
    Torque: 92.0 Nm
    17075 - Fan 1 Control Circuit: Short to GND
    P0691 - 000 - -
    Freeze Frame:
    RPM: 0 /min
    Torque: 0.0 Nm
    Speed: 0.0 km/h
    Load: 0.0 %
    Voltage: 12.46 V
    Bin. Bits: 00101100
    Temperature: 90.0C
    Duty Cycle: 9.6 %

    Same as yours....

    Chances are the emmissions light will return and you will need a new IMF as the fuse has blown when you changed it meaning the IMF jammed again...
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    69
    How long does it tend to take before it will come back on or does it just depend? hopefully it will just stay off!

  13. #12
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Mine flicked back on the same day within a few miles..
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Took it for a drive this evening to warm her up and the emission control light came on within two minutes. The fuse has blown once more. I am pretty certain that the IMF is the culprit now.

    I m not confident enough to do the DIY job - even though the guide looks good!

    Epsom Audi are charging 270.60 for the parts and 251 for labour - ha!

    I've spoken to Euro Car parts and they quote 205 inc. VAT for the part in question. I spoke to Weybridge Vehicle Consultants and they quote 340 all inc. That's a damn sight cheaper than the stealer - but when I asked about Euro Car parts - they said it would be a refurbished unit...not new OEM...Is that true, or are they blagging?

  15. #14
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Sorry mate - my internet been broke for a few days!!

    EuroCP - its a new pierburg unit with 12month warranty...

    i wouldnt pay more than 2hrs labour to fit it - took me and hour and i cleaned the egr out too!

    But vagcom it again and make sure it is the IMF fault code and then its the culprit!

    I have a guide/TSB that Boydie sent me on how to change it - pm me your email address and I'll forward you if you want

    Quote Originally Posted by Greenmunkey View Post
    Took it for a drive this evening to warm her up and the emission control light came on within two minutes. The fuse has blown once more. I am pretty certain that the IMF is the culprit now.

    I m not confident enough to do the DIY job - even though the guide looks good!

    Epsom Audi are charging 270.60 for the parts and 251 for labour - ha!

    I've spoken to Euro Car parts and they quote 205 inc. VAT for the part in question. I spoke to Weybridge Vehicle Consultants and they quote 340 all inc. That's a damn sight cheaper than the stealer - but when I asked about Euro Car parts - they said it would be a refurbished unit...not new OEM...Is that true, or are they blagging?
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Cheers mate - pm sent!

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    9
    Guys,

    I couldn't wait any longer and finally got the work done. Bought the part from Audi and got Mark from MTM Technik to do the hard work - paid 320 in total - so I am happy with that.

    Once again, thanks for all your help everyone, really appreciate it!

    P.s. Kaz219 - I don't even know my own email address - sent wrong one via PM the last time, so am sending the correct one this time!! Would be handy to have that guide, so I can try next time (hopefully not on my own motor though!)

    Thanks to everyone for their help!

  18. #17
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    No worries mate

    Sent it to the correct emil address lol

    Glad its sorted!
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  19. #18
    Neutral

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    69
    Finally its fixed!!! Condesor was changed, regassed and all is good! fingers crossed it stays that way!

  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    4
    ... i have spent ages tryin 2 sort this out - theres quite a few useless forum sites/ppl out there n this is the best one by far !!!
    my A3 Tdi Sport DSG has all the faults (fuse F8 blowing,fans inop/overheating,air con intermittant and emmission light on) (plus my internet is all over the place so posting here rather than thru yr link Kaz 219) it seems instead of 4 seperate faults i may b all sorted when i replace the intake flap motor & resetting the ecus?? fingers Xed it works n BIG THANX TO ALL WHO POSTED (here plus other feed) esp Kaz 219, cheers ;0)

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO