JMB RetrofitsEM Tuning
Results 1 to 16 of 16
  1. #1
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117

    Erratic idle + fault code

    Hi, Ive noticed that now and again my 2.0 tdi a3 will idle slightly erratically. Only really noticeable when sat at lights and the car will shake slightly. It only does it now and again.

    When I had it remapped, the bloke looked to see if it had thrown any codes, and it had thrown something to do with glow plug number 4 circuit failure, although this could have been an old code.

    Speaking to a friend, he seems to think the fault has nothing to do with the problem i've got and it's a possible sticking egr valve.

    Anyone got any ideas?

    Cheers, Dom

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    RobinA3's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Cheshire
    Posts
    1,763
    won't be the glow plug error causing the problem as the glow plug only comes into action when the engine is started up cold

  4. #3
    RobinA3's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Cheshire
    Posts
    1,763
    also i'd check for air leaks.

  5. #4
    Khufu's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    West coast of Scotland
    Posts
    5,693
    Quote Originally Posted by RobinA3 View Post
    also i'd check for air leaks.
    I'd go with that too.
    2003-2008 1998 Red A3 8L 1.8 Sport
    2008 -> 2003 Akoya Silver A3 8P1 2.0 FSi Sport

  6. #5
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117
    where would i start with that? cheers

  7. #6
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    check the engine bay for hoses that have split/have holes etc.

    Also, check the seals..

    These can be identified as some holes may leave black marks around where the air has been escaping (the gungy black stuff thats found when the manfiold, imf, egr are stripped off..) This may only apply to the thick main pipe in the middle front of the engine where the egr is located...

    I have a pic of my air leak and how i identified it and a vid of the revs bouncing but this is on my home comp. Im at my flat at uni now..Probs wont be home till nextweekend or even the weekend after but when i get chance, i'll post the pic and vid and you can compare it to yours.

    My leak was inbetween the EGR and the manifold - the seal had perished as i changed the IMF and it must have moved about as they are connected...

    On Vagcom, the revs were idling between 810ish and just under 850ish IIRC. It happened when i drove the car for a few mins, parked it up and started it again... It was very slight but enough to annoy me!
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  8. #7
    sprout99's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    North East - Dodge city
    Posts
    367
    check the ones either side of intercooler.

    They are known for either popping out or splitting.
    2004 AUDI A3 S-LINE DSG TDi
    MAURITIUS BLUE
    2005 BMW 120d M Sport 163+
    BLACK SAPPHIRE

  9. #8
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117
    Thanks for the help. I'll have a look at the weekend in the daylight.

    Would i not notice the leak at higher revs, or wouldnt it make noise under boost?

  10. #9
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Quote Originally Posted by Crunch View Post
    Thanks for the help. I'll have a look at the weekend in the daylight.

    Would i not notice the leak at higher revs, or wouldnt it make noise under boost?
    It depends on the kidn of air leak.

    Mine was fine when driving - just idled a bit rough...
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  11. #10
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Quote Originally Posted by Crunch View Post
    Thanks for the help. I'll have a look at the weekend in the daylight.

    Would i not notice the leak at higher revs, or wouldnt it make noise under boost?
    It depends on the severity of air leak and which pipe its leaking from...

    Mine was fine when driving - just idled a bit rough...
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  12. #11
    A3TDI

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Worcestershire
    Posts
    116
    i sometimes get this problem but it is only very rarely, not enough to really bother me much but i will check for air leaks next time im under the bonnet as this seems the most likely cause..

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2009
    Posts
    4
    Hi,

    Audi TDI 2.0 Sport 53 plate
    My car was just serviced and timing belt change by the main dealer. I now have, what sounds like the same problem. Did you get it resolved?

  14. #13
    sprout99's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    North East - Dodge city
    Posts
    367
    Quote Originally Posted by Crunch View Post
    Hi, Ive noticed that now and again my 2.0 tdi a3 will idle slightly erratically. Only really noticeable when sat at lights and the car will shake slightly. It only does it now and again.

    When I had it remapped, the bloke looked to see if it had thrown any codes, and it had thrown something to do with glow plug number 4 circuit failure, although this could have been an old code.

    Speaking to a friend, he seems to think the fault has nothing to do with the problem i've got and it's a possible sticking egr valve.

    Anyone got any ideas?

    Cheers, Dom
    our was cutting out when stood in traffic - new pipes fitted and idle speed turned up.
    2004 AUDI A3 S-LINE DSG TDi
    MAURITIUS BLUE
    2005 BMW 120d M Sport 163+
    BLACK SAPPHIRE

  15. #14
    APL TDi's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    285
    Mine ildes a bit rough every now and then.

    Its not enough to bother me though.
    2004 140 TDi sport 3dr (new turbo)

  16. #15
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117
    Not sorted it yet as i spent a few hours cleaning it today so cba working on it now. When yours does it does it do it enough to make the car noticable wobble and jiggle the passengers about. If you get out you can hear the engine, it almost sounds as if its misfiring.
    If it makes any difference my cambelt was done about 1k ago (not by audi)

  17. #16
    6th Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    1,562
    Strange, I just read this thread title as 'eric idle'..............

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO