Monster MotorsportBadger5
Results 1 to 11 of 11

Thread: Oil Light

  1. #1
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347

    Oil Light

    Morning chaps, on the way to work this morning my oil light came on (centre display), i pulled over straight away and checked the level and that was OK. I restarted the car and it wasnt on, i drove about 2 miles and it came back on.
    I checked the level again and all seems fine?

    In any case i dumped the car at a friends as I was half way between my house and the office and didnt want to drive it.

    Anyone got any ideas? faulty switch maybe? the oil pick up was cleaned when the engine work was done.
    There wasnt any leaks apparent when I was on my knees in my suit in the rain at 7am this mornning looking under the car FFS

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    JRock247's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Hampshire
    Posts
    335
    This might help or point you in the right direction, I know its for the A4 but may help.

    OIL WARNING LIGHT BUT PLENTY IN????
    Ask admin to advertise here

  4. #3
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347
    Thanks for that. Tonight I will give it an oil change and check the sensor.
    Only thing thats changed since I last drove it is a new outer CV joint, a ball joint and i topped the transer box up with oil.
    So cant think I would have knocked something or pulled a wire.

  5. #4
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Aberdeenshire
    Posts
    590
    Quote Originally Posted by autolatry View Post
    Thanks for that. Tonight I will give it an oil change and check the sensor.
    Only thing thats changed since I last drove it is a new outer CV joint, a ball joint and i topped the transer box up with oil.
    So cant think I would have knocked something or pulled a wire.
    Is it the oil level or pressure light ,hopefully it's not pressure after the blood,sweat and tears you have put into the car.

  6. #5
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347
    Think it was just the level? I note we don't have a oil can symbol on normal dash lights do we?

    I've driven a couple of miles tonite and it hasn't happened again.
    I haven't put the under tray back on since the rebuild and it was raining this morning, I wonder if the sensor on the sump got wet.
    Last edited by autolatry; 29th January 2014 at 20:52. Reason: Manual correction of auto correction

  7. #6
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347
    I have just cheked the oil pressure, at idle it's 20psi (1.5 bar) and at around 2000rpm is around 55psi (3.8 bar)

    I think that's ok, I was told auto data says 50psi at 2000rpm.

    So il swap the oil pressure switch and see what happens.

  8. #7
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347
    guess which bell end then forgot to remove the pressure gauge valve and put the bolt back in the port?

    oil.jpg


    had to run to B&M and buy some cat litter to try soak it up.........think the property manager will have something to say on Monday morning.

  9. #8
    Marshy's Avatar
    3rd Gear

    Status
    Online
    Join Date
    Nov 2013
    Location
    Dumfriesshire
    Posts
    636
    Ooops!
    Good luck in trying to clean it up mate, nobody's perfect.
    IBIS WHITE S3
    Revo stage 2+ and loving it

  10. #9
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    London
    Posts
    469
    After cleaning it up...
    Get some cement paint and give it 2 coats and done (40min in between), then you're done and could hardly tell...
    Remember you need to blend the paint with brush... to the clean areas...

  11. #10
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347
    Finally got round to changing the oil pressure sensor today. It was a ball ache as the entire front end had to come off.

    It has fixed the problem though so all good. The sensor on the car, well the electrical connector was full of oil!

  12. #11
    autolatry's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Yorkshire
    Posts
    347

 

 

Similar Threads

  1. Trouble Resetting Oil light
    By Beerzo in forum General Chat
    Replies: 2
    Last Post: 20th June 2006, 21:02
  2. Audi 100 Oil Light at 3000rpm
    By blued in forum Classic Audi Forum
    Replies: 4
    Last Post: 27th March 2006, 14:08
  3. Oil light
    By imported_billybravo in forum A4/S4 forum(B5 Chassis)
    Replies: 12
    Last Post: 9th June 2005, 13:34
  4. Oil light
    By Ilogik in forum A4/S4 forum(B5 Chassis)
    Replies: 1
    Last Post: 17th March 2005, 15:16
  5. Audi A4 Oil Light - HELP HELP :(
    By slips in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 26th January 2005, 18:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO