Chris NottAH Fabrications
Results 1 to 11 of 11
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    18

    Horn doesn't work after swapping for a FBMFSW

    I recently swapped the standard steering wheel for a FBMFSW from a TT with DSG paddles. Everything seemed fine - the DSG paddles work and light up - but when I try the horn, not a peep. The horn worked before with my old steering wheel. I've checked the fuse, and checked all the plugs were attached correctly.

    I've taken the airbag off again, to look at the wiring. There are three spade connectors on the back of the airbag, but only two are connected up. Is that right? I'll try put a picture here, but if that doesn't work, I'll try describe it.




    Holding the airbag so the green connector is on the left and the orange connector is on the right, there is one spade connector around the 12 o'clock position, and another around the 7 o'clock position. These are both connected up. But there is a third, unused connector around the 1 o'clock position. What is this for? There doesn't seem to be an unused wire to attach to it.

    I can't see any other stray wires sprouting from the steering column or slip ring. Nothing is mentioned in the how-to guides I've found. Those all suggest it's a pretty straight-forward plug n play, straight swap. Mine's an 05 five door Sportback. My old wheel was the shield-shaped airbag, not a multi-function one, but it was also a dual airbag with green and orange connectors. The TT one has a round airbag if that makes any difference?

    Any ideas anyone?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    amar06fbr's Avatar
    Vorsprung Durch Technik

    Status
    Offline
    Join Date
    Apr 2010
    Location
    West Yorkshire
    Posts
    1,033
    did you use your old loom?
    For Sale
    climate control (double din non chrome)
    Black roof lining (sportback)
    pm me for more info..

    BBM: 28E07323

    My Panoramic RetroFit


  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    18
    Quote Originally Posted by amar06fbr View Post
    did you use your old loom?
    Nope, should I have used the old loom? Looking at the loom on my old airbag, that's only got two spade connectors branching out from the green and orange plugs too.

  5. #4
    5th Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Cleveland
    Posts
    979
    The horn wires are just earths. Connect the vacant spade to one of the other earths. If you look at what happens when you press the horn to the base, you'll see that all they do is complete the circuit through the other two wires. Look very closely where the two parts meet and you will see some tiny contacts; four I think.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    18
    Quote Originally Posted by fangio View Post
    The horn wires are just earths. Connect the vacant spade to one of the other earths. If you look at what happens when you press the horn to the base, you'll see that all they do is complete the circuit through the other two wires. Look very closely where the two parts meet and you will see some tiny contacts; four I think.
    Sorry, I wasn't that clear in my description. I don't have a vacant spade connector. But the opposite. There's an unused connection point/terminal type thing. I don't know what the technical term for it is. It looks like there should be a spade connector attached to it. The problem is, I don't have am unused (third) wire with spade connector. There are only two spade connectors coming out of the airbag - each wrapped in the yellow sleeve in the picture. There isn't a third wire to connect to the terminal at the 1 o' clock position.

  7. #6
    5th Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Cleveland
    Posts
    979
    No, you're reading it wrong. Make up a short piece of wire with a female spade crimped to one end and join the other end to a part of the loom that goes to the horn wires, then connect it to the male spade that's vacant near your orange plug. There are three connections for the horn.

    Make sure you insulate the join in the wires or the horn will sound if a bare wire contacts the metal!

    I've done exactly the same swap.
    Last edited by fangio; 8th December 2013 at 15:57.

  8. #7
    JS3
    1st Gear

    Status
    Offline
    Join Date
    Oct 2011
    Posts
    215
    PS any pics of the completed install?
    2010 S3, Sprint Blue, S-Tronic, RNSE, Cruise Control, Interior Light Pack, Upgraded LED Interior Bulbs, Heated Seats, Hill Hold, Boot Buddy, Fog Turn Lights, Revo Stage 1, De-Wipered

  9. #8
    5th Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Cleveland
    Posts
    979
    Sorry, no. It's easy enough.

  10. #9
    LEE69's Avatar
    07 170 DSG

    Status
    Offline
    Join Date
    Jul 2013
    Posts
    896
    Think he wanted a picture of the wheel now fitted.
    I have the correct controller, just need to find the wheel/loom lol
    Growing old is mandatory, growing up is optional


  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    18
    Quote Originally Posted by LEE69 View Post
    Think he wanted a picture of the wheel now fitted.I have the correct controller, just need to find the wheel/loom lol
    Here is mine fitted now. Horn now works. I ended up buying a replacement airbag wiring loom off a well-known auction site with three earth's rather than trying to modify mine with only two. I'm no electrician so didn't fancy messing about with mine especially seeing as the airbag was involved.

  12. #11
    LEE69's Avatar
    07 170 DSG

    Status
    Offline
    Join Date
    Jul 2013
    Posts
    896
    Very nice
    Growing old is mandatory, growing up is optional


 

 

Similar Threads

  1. stereo and factory sat nav not working after battery swap
    By clashcityrocker in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 4th December 2012, 12:34
  2. Instant email notification doesn't work after AS.net upgrade???
    By Dennis Moeller in forum Site Support & Announcements
    Replies: 21
    Last Post: 15th July 2009, 15:33
  3. Anyone with a black leather interior wanting to swap for creme?
    By killa_z in forum A3/S3/Sportback (8P Chassis)
    Replies: 3
    Last Post: 2nd October 2007, 12:58
  4. Anyone with a silver/grey interior want to swap for black?
    By mwstewart in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 8th July 2007, 13:39
  5. Ko3 swap for Ko4
    By J7USS in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 24th November 2006, 11:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO