Monster MotorsportVolks Autos
Results 1 to 8 of 8
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182

    A3 TDI problems getting worse. Help please?

    Hi all, we have a 2004 A3 2.0 tdi, done 115k now. For a long time it has struggled to start when warm and the whole car judders at temperature when stationary. We had he car looked at and said they couldn't find anything wrong (no fault codes or unusual readings). So we have left it and now two years on we have the fan coming on constantly (I know I need a new fan for this just haven't found one yet and don't want to pay out for audi prices!) but also we keep having the coil light on the dash continuously flashing while driving along with reduced power. Now last name night the light stopped but when we set off in the car there was no power when pulling off and it would bog down when changing gear until it seemed to get warm and it stopped and drove fine.
    Has anyone got any suggestions on what it could be? I am going to get it scanned for faults and checked over ought id ask here incase anyone could tell me what to do/check.

    As you can imagine it's dangerous loosing lower while changing gear like the idiot last night following too closely behind me nearly found out!

    Any help much appreciated!
    Thanks

    Dan

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Anyone?

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    8
    Hi Dan,

    i would try try to get the car booked in with a local independent vw audi specialist, the hard starting problem could be caused by a number of things, like coolant temp sensor, starter motor not cranking fast enough.

    The juddering can be caused by incorrect timing, this is adjustable and a specialist should be able to check this for you.

    when you say the fan runs constantly, does the car have climate control, if it's set to auto and the aircon compressor is running the fans will run, if you put it into Econ mode you should see the fan stop.

    i hope you get it sorted.

    cheers

  5. #4
    J8TT X's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Leicester
    Posts
    327
    have a search for warm start issues on the forum. There's loads of info on it.
    2005 Audi A3 2.0 TDI DSG S-line (8p1)
    Mods: 18" Gloss Black RS4's - 8p2 S-line Front Bumper - Black Grill - A5 LED Number Plate lights - LED Sidelights - Euro Style Plates - EGR Delete - RTech Custom Remap - Hot Start Issue Fix
    Pipeline: Lowering, Wheel Refurb, Coming Home Lights

    2007 VW Golf 2.0 GT TDI 140 (Wife's)
    Mods: 18" Charlestons

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Yeah we have searched loads on the start issue, it's had new coolant sensor, starter motor, loads and all the common issues inspected and ruled out. The timing has been checked and found to be fine. The fans stay on No matter what it is set to even with the climate control off. I think it's the resistor in the fan itself gone.

  7. #6
    3rd Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    south yorkshire
    Posts
    563
    there is a map modification for hot start problems on the bosch ecu in these cars .

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    PORTUGAL-Mirandela
    Posts
    21
    Quote Originally Posted by gizm0 View Post
    Hi all, we have a 2004 A3 2.0 tdi, done 115k now. For a long time it has struggled to start when warm and the whole car judders at temperature when stationary. We had he car looked at and said they couldn't find anything wrong (no fault codes or unusual readings). So we have left it and now two years on we have the fan coming on constantly (I know I need a new fan for this just haven't found one yet and don't want to pay out for audi prices!) but also we keep having the coil light on the dash continuously flashing while driving along with reduced power. Now last name night the light stopped but when we set off in the car there was no power when pulling off and it would bog down when changing gear until it seemed to get warm and it stopped and drove fine.
    Has anyone got any suggestions on what it could be? I am going to get it scanned for faults and checked over ought id ask here incase anyone could tell me what to do/check.

    As you can imagine it's dangerous loosing lower while changing gear like the idiot last night following too closely behind me nearly found out!

    Any help much appreciated!
    Thanks

    Dan
    the fan problem is quite common mostly in the bkd engine...its the fan engine that collapses and stays allways on on untill it burns down...i´ve already had that problem, there is no reparing for that just new engines, and i recomend for both fans....luckelly i found 2 engines in a dismantle house here in Portugal!, for a very low price...!the warm start its also common, on mine the guy that remaped my ECU corrected that problem by rewriting the hot start map, basicaly he says to the ECU that the car in the start instant is allways cold, so the injecion increases the quantity of diesel, and it starts imediatly...however with some black smoke by the exhaust..
    about the judering issue, how are the injectors??how is the injection wiring on the top of the engine head, that is comon for all the injectors???the possibility of air/water in the fuel line/fuel filter is excluded right...??
    hope that helps...
    cheers

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Injectors are fine I think, surethe ggarage will have checked thatwhen it went in , it's had a new injector loom as you say that's a common fault fuel filter was changed recently and seemed fine and not contaminated when I checked it.... It's weird because the last few days it's been fine apart from the juddering, hot start and fans but the coil light problem will no doubt come back again

 

 

Similar Threads

  1. 2.5 TDI V6 cambelt change - help please!
    By Joni_s in forum Diesel forum
    Replies: 63
    Last Post: 16th January 2010, 22:09
  2. Battery problem getting worse and worse
    By drewbee in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 6
    Last Post: 19th December 2009, 21:48
  3. Boost Problem I think. Help please?
    By dougy72 in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 23rd November 2009, 22:14
  4. a3 1.9 tdi 110bhp ? power loss help please
    By madmark in forum General Technical / How To
    Replies: 5
    Last Post: 24th August 2009, 07:09
  5. hot engine problem , can anyone help please ????
    By Jonny_doe in forum A4/S4 forum(B5 Chassis)
    Replies: 4
    Last Post: 28th January 2005, 20:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO