Sky InsuranceMonster Motorsport
Results 1 to 7 of 7
  1. #1
    scott_johnson's Avatar
    Audiless

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Bingley
    Posts
    875

    PRNDS Flashing: Audi A3 3.2 V6 DSG HELP!!!

    Chaps,

    I need someones expertise to help rectify an ongoing problem.

    My car is currently with Andrew from Autograph Cars (site sponsor).

    As stated in the title, the car has a gearbox fault and flashes 'PRNDS' and has no drive / selects neutral intermittently. It will drive for 2 minutes then do the same thing.. Turn the ignition off and on and will solve the problem for another 2 minutes!

    The Mechatronic ECU was sent off for testing and came back with NO FAULTS!

    Does anyone know what else it could be? I've been told there's a switch under the gear lever that can go faulty?

    Andrew was going to explore the oil pressure to the clutches next...

    Im tearing my hair out with this and has already cost me £££'s to be back at square one!

    Any help is hugely appreciated!!

    Thanks in advance

    Scott
    Last edited by scott_johnson; 23rd October 2013 at 09:11.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Jason-3.2's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Bracknell
    Posts
    191
    Try cleaning the switch, bits of fluff and dust get under the gear selector causing it not to know which position its in. If cleaning the area doesn't help look at changing the switch just to rule that out.

  4. #3
    scott_johnson's Avatar
    Audiless

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Bingley
    Posts
    875
    Thanks Jason, ill pass this onto my mechanic Andrew to rule out..

  5. #4
    scott_johnson's Avatar
    Audiless

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Bingley
    Posts
    875
    Anyone else have the same issue?

    Ive searched high and low for answers and everyone seems to have different issues / symptoms.

    How likely is it that the gearbox itself is faulty?

    It was due a gearbox oil change at 40k. This wasn't done until I bought the car at 68k. Should this cause any problems?

  6. #5
    Paullie's Avatar
    Banana Menace!

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    2,088
    Hi there, I've heard of this problem with the mechatronics unit being stuck in N and flashing PRNDS and looking at some stuff online it looks like it could either be in need of a re-flash of the DSG ECU or it could be caused by a faulty temperature sensor. I believe Audi America did a recall and also extended the warranty of the DSG units. Unfortunately there was no such action by VW/Audi in the UK. Have a look at this page, it's very informative with regard to the DSG.

    VW Audi DSG S-tronic FAQ with common DSG problems, the sensor recall, and video reviews


    I found this just about half way down.

    Temp sensor recall

    "On Aug 2009, VW started a recall on 2009 and 2010 DSG on the temperature sensor. Models affected are built between August and September 2009. A faulty temperature sensor can result in illuminated warning lamps in the dashboard and the transmission may shift into neutral. It appears that both sensors below are in the same assembly. This is probably responsible for some of the flashing "PRNDS shift light" incidents."

    Hope this helps. Paula xx
    MY10 S3 8P3 S-TRONIC, IMOLA YELLOW
    SHARK PERFORMANCE STAGE 2
    - GONE BUT NOT FORGOTTEN!

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,129
    The microswitch under the lever when in park can cause issues as above, it will present a fault log usually, so scan & check for error, if so then its a new gear unit needed, about £400 for the part, pita to remove/fit.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    MrLapou's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Lincoln
    Posts
    1,209
    I read you said the mechatronics tested ok.
    These sorts of thing can happen if the temp sensor in the box is faulty.

    02E927770M 02E927770M

 

 

Similar Threads

  1. '55 2.0 tdi DSG 75k PRNDS Flashing. Tempremental won't start
    By caraudiaye3 in forum A3/S3/Sportback (8P Chassis)
    Replies: 11
    Last Post: 19th May 2013, 20:23
  2. Flywheel and turbo on Audi A3 2.0 tdi DSG
    By brettsh555 in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 23rd February 2013, 17:06
  3. Audi A3 3.2 V6 DSG Running Issues***ADVICE PLEASE***
    By phil08 in forum A3/S3/Sportback (8P Chassis)
    Replies: 13
    Last Post: 16th July 2012, 02:38
  4. PRNDS flashing
    By les hook in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 26
    Last Post: 17th August 2011, 21:39
  5. First Audi, 2.0 TDI Sport Dsg, and pos gearbox problem
    By jin2 in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 31st August 2010, 18:53

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO