Monster MotorsportBadger5
Results 1 to 9 of 9
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182

    2004 A3 2.0 tdi problems and fault codes

    Hi all, having a few issues with my girlfriends 2004 A3 2.0 tdi. Firstly the radiator fan keeps coming on really soon after starting, I have replaced the coolant stat as that's what it was before when it happened. But still have the same problem. Also last night after 20 minutes of motorway driving the coil light started flashing on the dash and it went into limp mode with no power at all. When I got home I turned the engine off and back on again and it stopped. Today to be safe I got the car scanned for faults and it came back with the following codes: 18359 coolant fan, 18358 coolant fan, 16610 throttle position sensor. Iv had a quick look on here but can't make sense of what it could be as there seems to be so many different opinions. Any help would be greatly appreciated.

    Thanks

    Dan

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    SAiLO's Avatar
    Enthusiast

    Status
    Offline
    Join Date
    May 2009
    Location
    UK
    Posts
    939
    Throttle position sensor code would indicate a problem with your accelerator pedal sensors.
    Have a look on Ross-Tech wiki for more info.
    VCDS USER

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Ok that's great thanks, will have a look!

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Ross-tech only lists one of the fan fault codes and says it could be jammed but it spins freely and nothing in there. Iv seen something about replacing a fan but unsure which it is that needs replacing, but also seen that some have had to replace a control unit or something on them? Would any of these codes mean that one of them needs doing?

    The throttle code apparently could mean a number of things like O2 sensors but I will get the car scanned again tomorrow to see if anything else has re appeared. The car also has warm starting trouble and lumpy idle but not sure if that could be linked to these issues?

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    ok so just checked the car for sault codes again, only the fan one is coming up (18359) with the ignition on there is a constant whining type sound coming from the fan area. is this normal?

    thanks!

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Overwhelming response on here lol

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,748
    whiring fans and o2 sensors. id be loooking at the o2 sensor and wiring, logging with vcds and hoping the ecu isnt fried.

    Where abouts are you?
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  9. #8
    Lewis583's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    870
    Diesels don't have 02 sensors. At least the BKD doesn't.

    You need to log the throttle position sensor with ignition on engine off. Watch the measuring blocks as you SLOWLY depress the accelerator pedal. Look for any abnormal/erratic readings.

    You may find that you have one reading that the % increases as you press the pedal and you have one that decreases % as you press the pedal. This is a fail safe that the ECU uses to asses plausibility of the pedal position sensors and is normal.
    2008 E92 BMW 335i M-sport
    1990 Golf GTi w/ a 20v heart BUILD THREAD
    Full VCDS

    2006 A3 2.0T quattro S-line R.I.P. You will be missed.

    ** Breaking - 8L 1997 Audi A3 1.8T. **

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    182
    Sorry guys missed these replies. I'm still having issues however it went away but came back yesterday it has got worse and I'm loosing power immediately after changing gear. I live near Birmingham

 

 

Similar Threads

  1. a3 2.0 tdi BKD 8P fault codes after remap!!! worried!!!
    By chrisy t in forum A3/S3/Sportback (8P Chassis)
    Replies: 7
    Last Post: 2nd April 2012, 18:24
  2. MAF and Fault Code 16486
    By tompearson in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 6th August 2011, 16:10
  3. Logs And Fault Codes
    By cecilthesausage in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 22nd May 2011, 16:16
  4. 2004 A3 2.0 TDI juddering and struggling to start?
    By gizm0 in forum A3/S3/Sportback (8P Chassis)
    Replies: 19
    Last Post: 22nd December 2010, 17:54
  5. 2005 A3 TDI - pile of fault codes
    By timcoupe in forum VCDS (formerly VAG-COM) forum
    Replies: 28
    Last Post: 18th September 2009, 12:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO