Volks AutosEM Tuning
Results 1 to 24 of 24
Like Tree1Likes
  • 1 Post By RobbieWebs

Thread: Bluetooth retrofit - no sound from speakers?!

  1. #1
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167

    Bluetooth retrofit - no sound from speakers?!

    Hi,

    I've (mostly) successfully retrofitted blue-tooth. I can connect the phone, I can dial and receive calls...

    BUT - there are no sounds coming from car speakers :-/ When I'm connecting the phone there's no "beep", also when I'm dialing or when someone dials me, he can hear me (microphone works ok), but I can't hear anything...

    When listening to radio, spekers work fine, so it's bluetooth+speakers issue. I have a MY09 car and '04' RNS-E unit (8P0 035 192).


    Any ideas what could be wrong? Is it possible that RNS-E is not working propery or that bluetooth is partially fried? Or is it just the wiring issue?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    voorhees's Avatar
    Moderator

    Status
    Online
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,626
    Have you tried putting the volume up when connected ?
    The radio volume and the call volume are two different settings on my system

  4. #3
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Yes I've tried.... There's a crossed speaker icon at the bottom of the RNS-E when in-call, just like mute is on. I've tried pressing the power toggle (to unmute it) but that didn't help either.

  5. #4
    voorhees's Avatar
    Moderator

    Status
    Online
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,626
    I have to press volume up

  6. #5
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    Check your NF -/+ wires.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  7. #6
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Quote Originally Posted by NHN View Post
    Check your NF -/+ wires.
    Are those the wires that go from pin 6 (nf -) and pin12 (nf+) C connector RNS-e to Bluetooth? To which pins in bluetooth connector are those 2 supposed to connect?

    Pin6 to PinX?
    Pin12 to PinY?

  8. #7
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    OK I have one more question regarding Bluetooth...


    I switched to RADIO (or CD - same results), and set up my balance to full left with fader to full front, and after that I can't hear any sound from my drivers door (left-hand drive, I'm not from UK/Ireland), only from the dash speaker.... When I start to turn the balance to right, I can hear clearly sound from the drivers (right) door...

    So, it seems that my problem is probably regarded to my drivers door speakers? Is it possible that bluetooth send sound only to drivers side speakers or should it send it all across the board?

    I don't have bose...

  9. #8
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    Fix your speaker problems & then deal with the issue.

    Check the door hinge rubber for breakages.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  10. #9
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Quote Originally Posted by NHN View Post
    Fix your speaker problems & then deal with the issue.

    Check the door hinge rubber for breakages.
    This is the VCDS error that I have for a very long time... can this be somehow related?


    Address 19: CAN Gateway Labels: 1K0-907-530.lbl
    Part No SW: 1K0 907 530 Q HW: 1K0 907 951
    Component: J533__Gateway H16 0202
    Revision: H16 Serial number: 2700K08A060279
    Coding: E9811F061002020100
    Shop #: WSC 07790 995 07790
    VCID: 356525E72781

    1 Fault Found:
    00470 - Combination comfort Databus in Single Wire
    011 - Open Circuit
    Freeze Frame:
    Fault Status: 01101011
    Fault Priority: 3
    Fault Frequency: 254
    Reset counter: 24
    Mileage: 60124 km
    Time Indication: 0
    Date: 2012.11.14
    Time: 15:03:53

  11. #10
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    That is more than likely related to a broken wire, but check the door rubber as advised 1st.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  12. #11
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Rubber is fine, I found the issue - RNS-E wasn't connected properly... After reconnecting the big square connector, speakers in the drivers door work OK but still no in-call sound from bluetooth Other person can hear me loud and clear but I just cannot hear anything he/she says...

    Also, when in-call, RNS-E shows crossed speaker and mutes radio/cd volume and that is fine. When I finish the call icon is gone and radio resumes....

  13. #12
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    One more thing, when I increase/decrease the volume via small knob on the RNS-E, I can see the changes on the phone (little knob shows and goes up or down just like I'm changing volume level on the phone)....

    So everything works except that I cannot hear a thing from bluetooth.... Can this be a faulty bluetooth unit? :-/ Or maybe even RNS-E ...

  14. #13
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    As I said check your NF wiring, the info is readily available online.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  15. #14
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Just to make sure...

    NF - : Pin6 RNS-E goes to Pin 8 BT
    NF + : Pin12 RNS-E goes to Pin 9 BT

    is this correct?

  16. #15
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    Swap them round.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  17. #16
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    OK I've tried swapping them round and now when phone connects to BT, I can hear white noise, not very loud. Also, when someone calls me or when I call someone, I can hear that same noise.... :-/

  18. #17
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    Quote Originally Posted by jsosic View Post
    OK I've tried swapping them round and now when phone connects to BT, I can hear white noise, not very loud. Also, when someone calls me or when I call someone, I can hear that same noise.... :-/
    I've tried everything... I've even tried the BT with another RNS-E, and my RNS-E in another car with BT installed... RNS-E is ok, so definitely my BT module is broken

    I'll call it a quits and try to get my hands on another BT module....there's really nothing much I can do from this point. Strange that it's broken this way but that's the way it goes

  19. #18
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    Have you put your friends bt module in your car to test?

    I sell the new latest version BT kits if interested.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  20. #19
    jsosic's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Zagreb, Croatia, Croatia
    Posts
    167
    We didn't cause his is placed under the passenger seat while I put mine behind RNS-E, so it's very hard to take his out....

  21. #20
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    It wouldn't take that long to get too & test tbh, that way it would totally discount everything else & 100% prove its the module.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  22. #21
    Phil-1's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2013
    Location
    Harrogate
    Posts
    895
    Sorry to crash this post. Didn't want to start another one.

    Just got my car last night and I want to know if it has BT.
    I tried switching the ignition on and searching but found nothing :-(

    However I have seen the BT modules on EBay for £40. Is it as simple as getting a loom kit and plugging it all in?

    I thought £40 was to good to be true

    Thanks
    Phil
    Audi A3 8P Sport Back 170BHP (And I Love it)

    web page: philseagus.co.uk
    E-Mail:info@philseagust.co.uk

  23. #22
    RobbieWebs's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Scotland
    Posts
    685
    Hi Phil,
    Yes u need the module, wiring, microphone and vcds to code it for ur car.
    Have a read of this for installation and part numbers -
    Guide to retrofit OEM Bluetooth with RNS-E
    Phil-1 likes this.
    Audi A3 2010 2.0 TDI 140 Black Edition


  24. #23
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    Older modules may not support certain features & have compatibility issues with newer handsets, so beware of cheaper versions.

    We supply/fit the newest versions that work with all the latest handsets perfectly fine.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  25. #24
    Phil-1's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2013
    Location
    Harrogate
    Posts
    895
    What sort of price fitted are we looking at?
    Audi A3 8P Sport Back 170BHP (And I Love it)

    web page: philseagus.co.uk
    E-Mail:info@philseagust.co.uk

 

 

Similar Threads

  1. No sound from speakers
    By briankemp78 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 2
    Last Post: 21st March 2013, 20:18
  2. engine sound from speakers
    By harvey01 in forum In-Car Entertainment
    Replies: 3
    Last Post: 1st July 2012, 09:38
  3. no sound from speakers A5 B/O
    By stuart scott in forum General Automotive Chat
    Replies: 0
    Last Post: 3rd January 2011, 21:21
  4. zap sound from speakers when removing key
    By MixedUp in forum In-Car Entertainment
    Replies: 0
    Last Post: 26th February 2010, 08:28
  5. Losing sound from rear speakers
    By imported_micko2602 in forum In-Car Entertainment
    Replies: 4
    Last Post: 13th September 2004, 22:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO