AH FabricationsJMB Retrofits
Results 1 to 3 of 3
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Bridlington
    Posts
    144

    Something doesn't seem right...

    Audi A3 2004/2005 2.0 FSI Sport.

    Had a fuel leak a while ago so i took it back to the garage that i bought it from and they said that they sorted it and seemed ok but now the smell of petrol has come back so i want to replace the fuel rails and fittings.

    I have attached a photo of the rails, something doesn't seem right, there's paste all over the rails and there's a nut on both the these rails that go into the housing, i want to know are these nuts needed as i just thought the bolts should go straight through the pipe into the housing? (seems to me that they've done a bodge job)

    I'm buying the pipes and bolts from audi but when they sent me the order it came with no nuts? do i need them or not?

    Thanks
    Attached Images Attached Images

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,083
    Well for me the fix is a very cowboy one unless you asked for as cheap as possible, looks like banjo fitment & they've basically sealed it with some crap.

    You should replace all the fixings, so including lines, bolts etc, but it may just be the fixings that need replacing as I can only surmise that's what is wrapped up from that pic.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Bridlington
    Posts
    144
    Yeah i've ordered all the parts but Audi didn't add the nuts on the order and said i don't need them which is strange because why are they on there now? do i need the nuts? or i'm guessing this is a cowboy fix and don't need the nuts

 

 

Similar Threads

  1. NEW HEADLIGHT DOESN'T LOOK RIGHT !
    By ADC74 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 18
    Last Post: 21st July 2011, 07:29
  2. New windscreen fitted, doesnt seem right!!
    By wibble111 in forum A3/S3 Forum (8L Chassis)
    Replies: 19
    Last Post: 26th November 2010, 22:22
  3. Milltek Doesn't look right
    By solaris in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 25
    Last Post: 17th June 2010, 22:07
  4. Heating doesn't seem to be working correctly - advice?
    By gadgesxi in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 8
    Last Post: 13th January 2010, 18:46
  5. EBC pad fitting - doesn't look right to me...
    By Marc1 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 10
    Last Post: 24th October 2009, 14:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO