Monster MotorsportEM Tuning
Results 1 to 8 of 8
  1. #1
    mramage's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Scotland
    Posts
    514

    Engine coding failing

    This has been driving me mad for the last 2 months!! I retrofitted cruise control (2009 s3 stronic facelift) no probs. the steering wheel coded fine and diag shows all buttons working ok.

    The problem is the engine coding. Setting the cruise control bit just doesn't seem to take. I've tried doing them in different orders, ignition off and on, ignition left off and the apparently sometimes needed TBA. It says coding accepted, but then it just doesn't work. When I reopen the coding the bit is unset again, even after all the things above. It's really weird. Just wondered if anyone had seen anything similar.

    I should say this is not a genuine cable in use. If people have seen issues like this I guess it would be a good reason for buying the proper one!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Aberdeenshire
    Posts
    580
    I have a genuine lead I live near Aberdeen if your near i could help ,I would advise buying one from nhn on here am sure he will give you a good deal and assistance.
    Last edited by Chillout; 15th September 2013 at 21:07.

  4. #3
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,707
    Have you actually activated it?

    [Select]
    [01 - Engine]
    [Login - 11]
    Enter 11463 to activate cruise control
    [Do It!]
    After doing this procedure, there should be a letter "G" in the Component field.

    Try doing that first then changing the coding in 16/steering wheel.
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  5. #4
    mramage's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Scotland
    Posts
    514
    It's a different coding style for the diesels, the s3 uses the long coding cruise control bit setting.

    Chillout, thanks, bit far away though!!!!

  6. #5
    Dannykn9's Avatar
    "Cruise My Ride"

    Status
    Offline
    Join Date
    May 2011
    Location
    North London
    Posts
    1,074
    Log in to engine module, long coding activate cruise, do it, when it says coding accepted, log out of engine mode completely, turn ignition off, and take out key, wait at least "30 secs" then put key in ignition on, then take for a spin. I have retrofitted well over a hundred on various Audi's and has worked 100% of the time for me. If this still does not work, then the problem may lie deeper, and perhaps need further investigation, as for some reason, your engine module does not want to keep the coding stored.

    ATB
    VCDS Owner-North London/Enfield
    " To Cruise Is What I Do"


  7. #6
    mramage's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Scotland
    Posts
    514
    Seems it is the cable. Don't trust the copies!!!!!! Stirling audi kindly activated it for free when car was in :-)

  8. #7
    voorhees's Avatar
    Moderator

    Status
    Online
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,617
    Quote Originally Posted by mramage View Post
    Seems it is the cable. Don't trust the copies!!!!!! Stirling audi kindly activated it for free when car was in :-)
    Sorry for off topic but your avatar is awesome mramage

  9. #8
    mramage's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Scotland
    Posts
    514
    Quote Originally Posted by voorhees View Post
    Sorry for off topic but your avatar is awesome mramage
    Cheers. It's McLaren F1 engine. I defected to BMW for a while and had an e46 M3. Apparently the F1 is 2x those engines as basis.

 

 

Similar Threads

  1. Definitive list of engine codes
    By jediknight in forum A3/S3 Forum (8L Chassis)
    Replies: 21
    Last Post: 2nd November 2009, 20:52
  2. quick engine code question
    By paulwakinshaw in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 22nd November 2005, 12:05
  3. A4 Intercooler Differences with engine code
    By Markey in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 4th August 2005, 16:58
  4. Engine code AMU
    By ANDYTQ in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 1st November 2004, 09:02
  5. Engine Code for Polo GTi
    By chuffer in forum Volkswagen and other VAG
    Replies: 0
    Last Post: 12th October 2004, 12:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO