Badger5Sky Insurance
Results 1 to 24 of 24
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101

    Stereo doesn't turn off when the key is removed.

    According to the manual the headunit should turn itself off when the key is removed from the ignition. Mine stays on and I'm going to forget sooner or later. Anyone heard of this problem before, seen a few instances of the issue browsing the web but no resolution. Any help much appreciated!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    shariain's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2004
    Location
    Glasgow
    Posts
    1,173
    I have the same problem with mine in my 8L S3 what I also noticed is when I turn my head lights on my radio doesn't light up.
    S3 1.8t Ming blue with ivory leather & 18"tt alloys

  4. #3
    LEE69's Avatar
    07 170 DSG

    Status
    Offline
    Join Date
    Jul 2013
    Posts
    904
    As you say should be instant the moment the key is removed from the ignition, that points to ignition barrel worn to me.
    Mine is instant F.Y.I
    Growing old is mandatory, growing up is optional


  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,114
    Do the interior night illumination led's light up ok on the speedo, headlight switch, dash buttons, could be barrel & if not then its a canbus issue.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    shariain's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2004
    Location
    Glasgow
    Posts
    1,173

    Stereo doesn't turn off when the key is removed.

    All the lights on my car light up apart from the radio and my other issue is my mfsw buttons don't work the radio either.
    S3 1.8t Ming blue with ivory leather & 18"tt alloys

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,114
    You have an 8L mfsw or 8P?

    Sounds like radio issues are related to bus wiring.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    shariain's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2004
    Location
    Glasgow
    Posts
    1,173
    Mine is an 8L and it was in the car when I bought it so hope it would be the right one. Main thing is the car still turns with it. Lol
    S3 1.8t Ming blue with ivory leather & 18"tt alloys

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Mines a 57 plate. Everything else seems to light up, can't find anything that doesn't. Did have a fuse out on the cig lighter but changed it and the stereo still stays on.
    Last edited by Smeds; 4th September 2013 at 18:24.

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    There is an aftermarket Phone holder on the dash, so not sure if something has been modified to accommodate that.

  11. #10
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    369
    We had a poster on here recently with a similar issue - the mini-ISO plug wasn't plugged in the back - you could have a look at that (although on a 57 I think it may be part of the quadlock)

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    I'll see if I can get the unit out to have a look, may have keys somewhere.

    Have just got home and it's the first journey I've done in the dark. When I turn the engine off, the headlights turn off and the sidelights stay on and the dash stays lit, when I remove the key it all goes off and the interior lights come on. So looks positive in that regard, it's recognizing the key being removed.

  13. #12
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    369
    I just did a bit of web research (saddo) and it looks like if it's a quadlock unit the canbus signal is on one of the ISO connectors.

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Thanks John, that's much appreciated. Will have a look at it when i find the stereo keys.

  15. #14
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Managed to get the stereo out, the unit for the hands free has been spliced into the cables. Had hoped it was just going to be plugged in. Unless its got a 2nd aftermarket cable plugged in and the cables from the car go into that. I've taken a photo so when I get to my PC ill upload them, finger crossed someone can confirm I can just take out the aftermarket cables and plug the normal ones in again. I've never seen this set up so I'm in the dark.

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    There's a single blue cable going into it, I'm wondering if its the permanent live.

  17. #16
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    They're not the best photos and I doubt you can tell anything from them, but I'm just hoping someone familiar with this will be able to give me some pointers. If that blue wire is aftermarket, where is it likely to be going? Is it easy to find the other end if it's permanent live?


    IMG_0586.jpgIMG_0584.jpgIMG_0588.jpg

  18. #17
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,114
    Do you use the phone kit, if not then remove it all.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  19. #18
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Nope, want it gone. I'm just not sure which cables have to stay.

  20. #19
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    My gut feeling says the cables with a bit of black gaffer tape are after market. I've got a feeling the cable directly into the stereo with the bury kit spliced into it is an aftermarket ISO cable. And the standard ISO cable is plugged into that. Never seen these cables before so wary of taking them out.

    On holiday tomorrow, long drive to Cornwall and there's no way I can talk to my girlfriend for three hours without music.

  21. #20
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    I went for it, unplugged the cables, put the cable from the car back in and bish bash bosh it still works. Cut the cable that goes to the mic but still left with the blue one. Is it ok to cut that?

  22. #21
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Also, the stereo now turns off when the key is removed. Win!

  23. #22
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,114
    Yeap pins not mapped properly & thus lost canbus connections.

    If you ever want to upgrade to the oem BT systems & the rns unit, give me a shout & I can assure you it will all turn on/off with the key

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  24. #23
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    101
    Cheers for all the help!

    As it happens I'm thinking about parking sensors, paint correction and Bose speakers, Where are you based?

  25. #24
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,114
    Work all over, usually come out to locations.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

 

 

Similar Threads

  1. How do you turn your Radio/CD off when the nav is on (RNS-510)
    By sat1983 in forum Satellite Navigation
    Replies: 6
    Last Post: 27th June 2013, 19:18
  2. ECON light doesn't turn off when engine starts
    By HOZY19812 in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 3rd March 2013, 18:28
  3. S3 xenon headlight turning off when hot?
    By guinness in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 21st May 2010, 16:46
  4. Why does the car turns off when...
    By abdus in forum A3/S3 Forum (8L Chassis)
    Replies: 10
    Last Post: 8th August 2008, 17:32
  5. Wanting neons to turn on when the door opens ...
    By kazino21 in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 1st February 2005, 16:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO