Monster MotorsportChris Nott
Results 1 to 7 of 7
  1. #1
    5th Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Grimsby
    Posts
    1,085

    Problem with brake lights on over night and now flat battery.

    So the 2nd night of owning my car and i come out the house tis morning to see my brake lights all on and guess what, my car wont start.

    checked all the buttons i cant get them to turn off, they flicker when i close the door but thats all.

    Anyone had this problem? or know ideas what i can check?

    Thankyou,
    JJ.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    5th Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Grimsby
    Posts
    1,085
    ok so i slammed my brake pedal and they have gone off, is it a cheap fix to replace the switch?

    JJ.

  4. #3
    leeds2592's Avatar
    When I grow up, I want a 964!

    Status
    Offline
    Join Date
    Apr 2012
    Location
    Leeds
    Posts
    1,169

    My Social Networking

    Visit leeds2592's Instagram Channel
    Yep, think they're only about a tenner for the part, then there's just fitting.

    Id still scan it with VCDS before replacing it just to make sure it is the brake light switch which is faulty though.
    Black 2007 2.0 FSI Sport
    2011 Glossy Black RNS-E |AP Coilovers | 18" 7 Spoke OEM BE Alloy Wheels | H&R Trak+ Spacers 8mm (Front) 12mm (Rear) | MY11 Rear Lights | S Line Spoiler | Retrofitted MFSW | Retrofitted Cruise Control | Interior LED Light Pack | OEM LED Numberplate Bulbs

  5. #4
    OVRA3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Norwich
    Posts
    1,079
    Had this myself brake switch defo cheap fix
    A3 Sportback 2.0 TFSI S-Line Quattro Stage 1 Tune it up - Lowestoft Custom Remap- 6187 RPM developing 260 bhp 279lbs ft Akoya Silver, Roof rails, Black heated Vienna Leather, Bose upgrade, Bluetooth

  6. #5
    5th Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Grimsby
    Posts
    1,085
    Anyone can link me to the part, as i came back tonight with them on again. i checked when i left the car and they were off and have turned themselves on later on. might this be a diffrent probem?

    Jj.

  7. #6
    5th Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Grimsby
    Posts
    1,085

  8. #7
    5th Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Grimsby
    Posts
    1,085
    btw thought id let you know, after a week now, the problem has been fixed.

    Solution - i sprayed switch cleaner ALL OVER THE DAM THING where the mechanical part was.

    thanks for help!

    JJ.

 

 

Similar Threads

  1. Hot Start problem with brake light flashing.
    By delc83 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 4
    Last Post: 13th April 2012, 00:35
  2. Problem with esp light on dash...
    By Jonesy in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 2nd May 2011, 15:34
  3. Help - Problem with brakes
    By imported_AndyB40 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 25th November 2005, 09:31
  4. problem with front lights
    By share1t in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 15th November 2005, 08:32
  5. Problem with brakes?
    By imported_spuddie007 in forum A3/S3 Forum (8L Chassis)
    Replies: 13
    Last Post: 19th October 2005, 16:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO