Monster MotorsportAH Fabrications
Results 1 to 9 of 9
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172

    Wiring disasters! HELP!

    Hi guys,

    This is my first post so be gentle!

    I have a 2005 a3 DSG 2.0 tdi, and my brother has a 2004 a3 manual 2.0 tdi, weve both bought them to find the stereo wiring harness has been hacked and bodged! I cannot stand it when people do this! I am a fully qualified mechanic so have technicial background, Ive recentley bought a propper version of VAGCOM however i have recieved it yet and never used it. Both cars have multi funcional steering wheels however they're not wired up, they illuminate so not sure what i need to do to get them working. They both have rnse sat nav units, one is a 2009 and one is a 2012 led version, they both have Parrot MKI9200 blue tooth kits. I can solder fine but what id like to do is find out what connectors i need to put back on to the original wiring harness thats been chopped of. So can you telle for example if this is what i need: Where to purchase a quadlock for the rnse, where to purchase the receptacle terminals so i can crimp the original wires and put them back into the connector. The only connector that hasnt been chopped on the 2005 has 6 thin wires going into it and its not for the power wires or speakers any idea what it is? Also where to get one of those connectors for the 2004 that has been chopped.

    The 2005 doesnt turn on and off with the key but does have its own ignition live so im guessing the red and yellow wires need swapping? Also the illumination doesnt light up on the rnse. Also the rear speakers dont work but there are speakers there. The other thing is the radio reception is rubbish and i have no idea why?

    Once the original wiring is sorted i can then look at getting the correct adapters. However ive no idea how to find out if they have bose or if theyre half amplified or fully? I think the 2004 may be half amplied and non bose, as the speaker grills dont say bose and with the ignition off and music playing its only the front two speakers but with ignition on its all four and what sounds like a sub.

    So eventually what i need is an adapter to make my parrot kit work in conjuntion with my rnse and the multifional steering wheel and depending on wether they are fully amplified or half.

    Also pretty sure the rnse havent been programmed with vagcom.

    Please help.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    jb0o's Avatar
    North East Forum Moderator

    Status
    Offline
    Join Date
    Feb 2009
    Location
    North East, UK
    Posts
    2,607
    How did you manage to come across two A3's with bodged wiring? lol.

    First off, the 2005 and 2006 A3's come with ISO connectors and the RNS-E require a quadlock connector, so there should have been a plug&play harness between the car wiring and the RNS-E... was this there, or was this where they hacked it? And what did they do to hack it... photo's?

    Also, the A3's dont have an ignition source, the ignition is controlled via the canbus. All ignition feeds (ie, the Parrot kit) will have to be from the fusebox (drivers side dash).

    And again, the MFSW controls work through the canbus, there are no wires going from the MFSW into the stereo. Chances are you don't have the correct Steering ECU (most likely) or it hasn't been coded for a MFSW.

    Heres the manual for part numbers on all the pins/housings for the stereos http://www.vaglinks.com/Docs/Catalog...m_Audipins.pdf

    Good luck.

    Website | Facebook | Audi TT 2.0TDI 170 Quattro


  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    Attachment 14537Attachment 14538

    First picture is the 2005 (mine) When i first got it the parrot kit didnt work so i tested everything and i had a spare Vauxhall iso adaptor to use for now hence the tape on the spare quadlock, all the wires were just cut,twisted and gafa taped! so i soldered them for now. I have no idea whats right and wrong? When i bought the car it had a concert in it which didnt turn on and off with the key, but im sure it originally had a symphony as in the cars history theres info on a syphony. I then ran a switched live from the fusebox to get it to turn on and off properly. I then got the rnse plugged it in and now this doesnt turn on and off. What is the only connector that hasnt been chopped for thats not plugged in? On my brothers this has been chopped but is connected to other wires? I understand that if the wiring was facotry and i was retrofitting the rnse i would need an adapter for a simple solution but as my connectors have been chopped can you tell me what id need to make the factory wiring correct for the rnse?

    As for my brothers (2004) second picture. I have the reciept for it being supplied and installed in 2009 for £999! and it turns on and off with key, it only sounds front speakers with no ignition and then all four and what sounds like a sub when the ignition is on which im guessing is correct, i think again it just need all the correct connectors putting back on.

    As i said both have poor reception, i dont know if the pictures can tell you if they have the correct adapters? I can hardly get any radio channels on either when i search?

  5. #4
    4th Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    SW London
    Posts
    794
    Bloody hell! Where du live? In/around london?
    2006 Audi A3 2.0 TDI S-Line 8P2 PD170 - Dolphin Grey Metallic - The problem child
    1994 VW Golf VR6 - Mystic Blue - The money thief
    VCDS User

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    Quote Originally Posted by Sidhu88 View Post
    Bloody hell! Where du live? In/around london?
    Im Northamptonshire area mate

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    Since ive coded my rnse correctly my sub now works but it sounds **** my brothers doesn't sounds as bad as mine and ive turned the bass down, also figured out why my rear speakers don't work, It looks like the previous owner/s have installed speakers themselves as I pulled the rear quarter panel and it has the original twisted coloured wires but they've been cut and joined to some aftermarket speaker cable, I didn't realise this when I was sorting out all the hacked wiring so I left them to the side. What do I connect them to as on the rnse wiring diagram it only show the fronts being used and from the rnse adapter theres only 4 wires two for each front. Any ideas? Also need a new fakra adapter as it has broken I know there only cheap but from looking on ebay theres a blue plug on one end which im guessing should connect to another blue plug from the vehicles wiring it looks like my has been chopped and they've tried putting it straight into the back of the white connector that goes into the rnse. What should I do? Can you buy the blue connector that should be there? Please help I want my wiring back to how it should be! factory and safe!

  8. #7
    Artimus's Avatar
    Short Back

    Status
    Offline
    Join Date
    May 2012
    Location
    Hertfordshire
    Posts
    1,826
    A Grand? Wow! that receipt isn't from Bodgit & Flee Car Audio is it?

    Seriously though, you should look up member AndyMac in the I.C.E section of the forum - he seems to know everything there is to know about Audi ICE.

    Good Luck.
    ................................................
    2009 A3 SB 2.0T DSG S line
    ''''''''''''''''''''''''''''''''''''''''''''''''''

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    How can I repair this? Is there supposed to be a connector on the end that someone's cut off? What adapter do I need?

    image.jpg

  10. #9
    c_w
    5th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,061
    There is a switched 12v source that can be taken from the heater controls for a parrot kit so it's accessible with the heater panel pulled forward. I can't remember which wire it is though but that's what I used on my A3.

 

 

Similar Threads

  1. FBMFSW airbag wiring harness help.
    By Lewbo in forum A3/S3/Sportback (8P Chassis)
    Replies: 11
    Last Post: 21st March 2014, 10:05
  2. Replies: 7
    Last Post: 27th March 2011, 07:40
  3. Audio wiring butcherd (HELP)
    By Audijarvis in forum A4/S4 forum(B5 Chassis)
    Replies: 24
    Last Post: 22nd February 2010, 13:05
  4. URS6 or even A6 AirCon wiring diagrams/help ?
    By smogthemog in forum Classic Audi Forum
    Replies: 2
    Last Post: 8th April 2007, 10:49
  5. CD Changer wiring installation - help
    By imported_bearboy in forum In-Car Entertainment
    Replies: 2
    Last Post: 7th September 2004, 17:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO