Volks AutosSky Insurance
Results 1 to 10 of 10
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    York
    Posts
    203

    Possible Turbo Problem - Limp Mode - Advice Needed

    Hey,

    This has happened to me on 2 occasions over the space of 3 days.

    Driving along in 4th gear and plant my foot to the floor to overtake and when it gets probably around 3500rpm it feels like it has hit the limiter and then goes into limp mode. There is no warning lights on the dash etc, just no power.

    If I turn the car off and leave for 10 mins then it will go back to normal.

    What can this be? is my turbo going?

    My car is a 2.0 TDI 140 BKD
    Help will be much appreciated


    Many Thanks

    Alex

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    mjr901's Avatar
    S3 Pollution Plus+ Edition

    Status
    Offline
    Join Date
    Nov 2011
    Location
    In The Sticks....
    Posts
    2,611
    In a word. Yes.

    But to explain a little more, it'll be sticky turbo veins, which cause an overboost fault code.

    Get it plugged in and scanned, if it reads overboost. pretty much 100% it's 1 x turbo pooped.

    As you may know it's stupidly popular for these Turbos to do this, massive let down on Audi's side.

    Whats your current mileage?

    It is possible to remove and clean, mr muscle and all that.

    I wouldn't though, use yours as an exchange and get a re-con one, the last thing youd want to do is to take the thing off twice.

    OR use it as an excuse to go BIG turbo...Then comes clutch issues though....and mapping costs...
    Last edited by mjr901; 4th April 2013 at 08:24.
    2012 Ibis Black Edition S-tronic S3, 3 Door, Shark Stage 2, MTC Intake Kit, Powerflex Fast Road Dogbone Mount, Full Non Res Milltek Exhaust, Forge Development Intercooler + DV system,
    340bhp Mikes Ibis BE 2012 S3...

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    York
    Posts
    203
    Hmm I thought it'd be something like that, can an air leak or something like that cause it???

  5. #4
    mjr901's Avatar
    S3 Pollution Plus+ Edition

    Status
    Offline
    Join Date
    Nov 2011
    Location
    In The Sticks....
    Posts
    2,611
    Quote Originally Posted by Bramley View Post
    Hmm I thought it'd be something like that, can an air leak or something like that cause it???
    I doubt it, the symptoms you describe seem bang on turbo issues, but rather than speculate, simply get it plugged in, previous fault codes will be stored.

    Bobs your uncle.
    2012 Ibis Black Edition S-tronic S3, 3 Door, Shark Stage 2, MTC Intake Kit, Powerflex Fast Road Dogbone Mount, Full Non Res Milltek Exhaust, Forge Development Intercooler + DV system,
    340bhp Mikes Ibis BE 2012 S3...

  6. #5
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    486
    i had exactly the same mate two weeks after buying the car and more anoying one week after serviceing it so had to throw away my new oil and filter after the turbo was reconditioned and put another £40 worth of oil and another new filter , i got mine reconditioned at turbo clinic leeds they were very good and fast , you either go for there collect and return service or go to there workshop i live in cumbria so went for the collect and return which was great there courior collected from the guy that was doing my car and i spoke with them next day about the condition of the internals and they reconditioned with quallity parts and the courior returned it all within 3 or 4 days, some people clean the vaines but depending on the mileage on your car this may be a waste of time mine was 110,000 and on original turbo which is very good going from what i here so didnt even consider cleaning , all has been great sinse, hope this helps mate cheers




    Quote Originally Posted by Bramley View Post
    Hey,

    This has happened to me on 2 occasions over the space of 3 days.

    Driving along in 4th gear and plant my foot to the floor to overtake and when it gets probably around 3500rpm it feels like it has hit the limiter and then goes into limp mode. There is no warning lights on the dash etc, just no power.

    If I turn the car off and leave for 10 mins then it will go back to normal.

    What can this be? is my turbo going?

    My car is a 2.0 TDI 140 BKD
    Help will be much appreciated


    Many Thanks

    Alex

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    78
    Quote Originally Posted by southylad View Post
    i had exactly the same mate two weeks after buying the car and more anoying one week after serviceing it so had to throw away my new oil and filter after the turbo was reconditioned and put another £40 worth of oil and another new filter , i got mine reconditioned at turbo clinic leeds they were very good and fast , you either go for there collect and return service or go to there workshop i live in cumbria so went for the collect and return which was great there courior collected from the guy that was doing my car and i spoke with them next day about the condition of the internals and they reconditioned with quallity parts and the courior returned it all within 3 or 4 days, some people clean the vaines but depending on the mileage on your car this may be a waste of time mine was 110,000 and on original turbo which is very good going from what i here so didnt even consider cleaning , all has been great sinse, hope this helps mate cheers
    How much did the process cost you for your turbo to be sorted out?

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leeds
    Posts
    58
    Sticky turbo vanes mate caused by carbon and soot build up over the years unfortunately! Gonna need a recon one as the guys say, forget cleaning it fella. The vanes stick open when under full load and the engine thinks it has a major issue so goes into limp mode to save itself, I lived with it for a year on my old car, it will only do it under load uphill or booting it on motorways. Dangerous though, try get it sorted asap.
    It is because people don't use the turbo enough as there is so much low down torque you can nearly always change up before 2000 rpm.
    Cheers

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    78
    Quote Originally Posted by Simon16 View Post
    Sticky turbo vanes mate caused by carbon and soot build up over the years unfortunately! Gonna need a recon one as the guys say, forget cleaning it fella. The vanes stick open when under full load and the engine thinks it has a major issue so goes into limp mode to save itself, I lived with it for a year on my old car, it will only do it under load uphill or booting it on motorways. Dangerous though, try get it sorted asap.
    It is because people don't use the turbo enough as there is so much low down torque you can nearly always change up before 2000 rpm.
    Cheers
    How much would i be looking to pay for a Re conditioned turbo?

    Anyone got a place they would reccomend or is it just Find one on Ebay?

  10. #9
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    486
    dont use ebay not for a turbo mate theres been a lot of problems with them in the past turbo clinic was £325 + vat for rebuild but i went for an uprated billet alloy compressor wheel instead of the standard cast item so was an extra £100 , there service and knoledge was very good




    Quote Originally Posted by chale989 View Post
    How much would i be looking to pay for a Re conditioned turbo?

    Anyone got a place they would reccomend or is it just Find one on Ebay?

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    York
    Posts
    203
    Oh dear, well in that case I might just chop it in for a Hybrid!

 

 

Similar Threads

  1. Turbo overboost & limp mode
    By Lo x in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 13th June 2011, 12:05
  2. MAF Problem possibly, advice needed
    By sportquattro in forum A3/S3 Forum (8L Chassis)
    Replies: 16
    Last Post: 8th March 2010, 19:48
  3. possible EBAY fraud? advice needed.
    By MikeS4 in forum General Chat
    Replies: 1
    Last Post: 29th January 2007, 11:19
  4. Limp Mode/MAF Problem????
    By GarryX in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 30th August 2005, 11:10
  5. N75J and limp mode (overboost problems)
    By pure in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 21st June 2004, 18:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO