Monster MotorsportJMB Retrofits
Results 1 to 10 of 10
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    4

    ECON light doesn't turn off when engine starts

    Hi There, I have an audi a3 sportback tdi 1.9 2007 model.

    Econ light stays on after engine starts and does not turn off after pressing the button. I did a scan on VAG and no faults came up. I did some output tests and I got the following results with the car stationary and engine running and the econ button would not turn off after pressing it:

    0.000 A A/C Regulating Valve (N280)
    0.0 % A/C Regulating Valve (N280)
    4.5 % High Pressure Sensor (G65)
    1.0 bar Refrigerant Pressure
    35.0 Feedback Value (Actual)
    36.0 Feedback Value (Specified)
    38.0 Minimum Position (Lower Stop/Cool)
    211.0 Maximum Position (Upper Stop/Hot)
    60.0°C Coolant Temperature
    0 A/C Compressor Regul.Valve (N280)

    The reading were obtained while temparature setting was set to 'LO', I opened the bonnet and both radiator fans are not spinning, which I believe is because the air con compressor is not activated due to econ light being on. Hope I don't need to spend £££ to have what ever is wrong fixed. Before I did the scan I was told I have a dodgy econ button, but this works while engine is not running. I was also told I maybe low on gas, which I believe isn't a costly fix.

    Feeback on this will be most appreciated. Cheers

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,097
    Check the pressre switch G65 iirc, on a 2.0 bkd its on the drivers side silver pipe with connector plugged in just behind the bottom corner of rad.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Dannykn9's Avatar
    "Cruise My Ride"

    Status
    Offline
    Join Date
    May 2011
    Location
    North London
    Posts
    1,108
    Silly question maybe, but does your aircon need re-gassing? If empty, then econ mode would permantly stay on I assume.
    VCDS Owner-North London/Enfield
    " To Cruise Is What I Do"


  5. #4
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Use KWIKFIT!!!
    They offer a no fill no charge policy, If your sytem just needs gassing they can fix it for around £40-50.

    If it leaks or fails to operate when filled they wont charge you! Used them twice when i was messing about with my aircon pipes!

    They will be able to tell you what if anything is removed and how much they put into it or if its leaking. If they charge and it still doesnt work you have other issues, and back to fault finding!
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  6. #5
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,097
    Thats good advice tbh.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    4

    RE: ECON light doesn't turn off when engine starts

    Quote Originally Posted by NHN View Post
    Thats good advice tbh.
    Thanks for the pointers guys. I tested the output of the a/c compressor on VAG and there is a clicking sound suggesting the compressor is all good. i also tried to do an output test on the cooling fans for the raditors using VAG but they did not spin when I activated the test while engine running. Maybe the radiator fans have gone and or low gas? How will I be able to tell if the G65 high pressure sensor is ok or not as no fault code was found on a scan for G65, no fault code for radiator fans or anything else related to auto HAVC.

    May also need to check for leaks in system before re-gassing as suggested.

    Cheers

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    4

    RE: ECON light doesn't turn off when engine starts

    Quote Originally Posted by HOZY19812 View Post
    Thanks for the pointers guys. I tested the output of the a/c compressor on VAG and there is a clicking sound suggesting the compressor is all good. i also tried to do an output test on the cooling fans for the raditors using VAG but they did not spin when I activated the test while engine running. Maybe the radiator fans have gone and or low gas? How will I be able to tell if the G65 high pressure sensor is ok or not as no fault code was found on a scan for G65, no fault code for radiator fans or anything else related to auto HAVC.

    May also need to check for leaks in system before re-gassing as suggested.

    Cheers
    Econ light was still on while I drove to Kwik fit but when they tested the econ button, it worked and the A/C was blowing cold air. Everything was working, i.e. compressor and cooling fans including econ button! Strange? They went ahead to re-gas it since the air could be even more colder with the re-gas. It did a test for leaks and none was found otherwise the re-gas would not have gone ahead. After the re-gas air con was working brilliantly. Can't really complain for a £29 re-gas at Kwik fit as thats cheap.

    However next morning, I tested A/C and the econ button would not go off to activate the A/C. I then read up my manual and it implies that if the temparature is less than 5 degrees celcius, the econ button will not go off and if the econ button still does not go off when the temparature is 5 degrees or more than theres a fault with one of the A/C components. It was 2.5 degrees in the morning, so ok, I can't expect it to work. I checked later in the morning when the temparature was above 5 degrees and the econ light would not go off and no A/C working. I then took the car on a spin to warm engine and after re-starting the engine, presto A/C and fans working??

    In summary, compressor not faulty, fans are working, car re-gassed and no leaks found. Can a G65 pressure switch which I have found located at the bottom corner of the radiator still be faulty with no fault found on VAG or could it be a dodgy econ button??

    Cheers

  9. #8
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,097
    Well yes it could be faulting, but with reference to the manual, I've never seen the econ button stay on in that scenario, got me thinking now lol.

    Pressure switch is £50 odd at audi, some on ebay for half, maybe try it as its cheapish to test.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  10. #9
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    hmm. my aircons working even at 2degrees out last night. Ive just got into a habit of leaving it on auto and econ off. I guess the compressor wont kick in when its not needed.
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    4
    Took the car out for a spin at 3pm and aircon works fine with outside temparature at 12 degrees. Three hours later, I took it for a spin with outside temp at 7.5 degrees and air con works. According to my vehicle air compressor doesn't like to operate when tempature is below 5 degrees or when car has been in freezing cold over night. Should be useful for anyone else to refer to their manual to see what it says if compressor doesn't kick in at temparatures below 5 degrees.

    I looked at the G65 sensor and does look old though VAG showed no fault code on it. Will see how it goes and replace G65 switch by buying one from Audi as they are only £10 more than GSF Car Parts, better to stick with OE parts. Thanks for your advice guys. Kwik fits £29 no re-charge no fee price is dead cheap compared to the stealers since Audi use the same type of gas machine as Kwik Fit. Thanks for the useful tips, much appreciated.

 

 

Similar Threads

  1. Service Light will not turn off
    By Boydie in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 29th October 2010, 14:46
  2. Interior light won't go off when I close the drivers door!?!
    By paneristi232 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 17th July 2010, 18:10
  3. S3 xenon headlight turning off when hot?
    By guinness in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 21st May 2010, 16:46
  4. Airbag light on, alarm goes off when locking car,
    By neuron in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 12th November 2009, 18:58
  5. Why does the car turns off when...
    By abdus in forum A3/S3 Forum (8L Chassis)
    Replies: 10
    Last Post: 8th August 2008, 17:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO