Chris NottBadger5
Results 1 to 3 of 3
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Fife
    Posts
    59

    No DIS, clock lights flickering, no speedo/rev

    Well....last night I locked my at up went to bed, woke up, went outside and I left my blooming window open a little :-(
    It was super cold last night. So, I jumped in and shut the window. I have a van and drive that to work. So came home tonight to find that I have no DIS, Speedo, revs, Dash lights are flickering occasionally. ESP light up, steering light and airbag.

    I know I will have to get it scanned :-( just wondering if anyone has any insight.
    I have the car running just now to see if its just condensation or something silly :-/
    panicking a little!

    Thanks guys

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,094
    Remove the cluster, put it in the airing cupboard or on a rad over night, then test.

    There will be lights on when you plug back in which should go out when you drive the car.

    The trim directly below the cluster does pull back with some minor forcewith finger/thumb on both sides, 2 size 8 bolts need removing, magnetic tool better, so they dont fall down into steering column, then lift cluster out & pull the bottom up & over round the steering wheel to see the connector, then you need to pull the latching clip over to make the connector open & lift out.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Fife
    Posts
    59
    @NHN i put the car in a garage with windows all down space heater on and it seemed to work. I disconnected the battery for 20 mins or so also. Now, the TC light is on and Steering wheel light. Im guessing its because the signal has been lost from steering wheel angle to the Traction Control. Hoping it goes off after a drive.
    The air bag light is also on now :s
    Thanks fgor your reply and sorry for my late reply!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO