Volks AutosSky Insurance
Results 1 to 12 of 12
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9

    Diagnostic results of steering issue...Can anyone makes sense of it for me??

    Alright, so I got a red steering light and a yellow ESP light when I replaced my battery and it wouldn't go away.
    No I've followed the ross tech guide and tried a steering limit stop and such. I've also tried turning my wheels to the left and right and going straight forward and nothing, lights are still there.

    Got the faults codes below, it'd be awesome if anyone could help me on what I should do?

    Stuck!


    02546 - Steering Limit Stop
    005 - No or Incorrect Basic Setting / Adaptation - MIL ON
    Freeze Frame:
    Mileage: 6160 km
    Temperature: 18.0°
    Voltage: 13.90 V
    Voltage: 13.70 V


    00778 - Steering Angle Sensor (G85)
    000 - - - MIL ON
    Freeze Frame:
    Mileage: 6160 km
    Count: 1
    Steering Angle: 0.00°

    Thanks!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,547
    Is your steering wheel on straight? have you had a wheel alignment recently? has the steering wheel been off for any reason?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9
    Yeah it was aligned a couple months ago. And the steering was centered until I rest the battery and when the wheels are straight it's a few degrees to the right

  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,547
    The steering needs to straight as there is a sensor in the column assembly that is used for the ESP system... whoever aligned the wheels should have sorted this so it wasn't an issue... you need to take it back to them and explain the situation or it means you may have to try and remove the steering wheel, realign the sensor and refit the steering wheel a couple of splines over...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9
    I also had an ABS sensor on my rear left show up as faulty which I didn't think to include.

    Now would it be correct to think that it might not be adapting because the battery was disconnected whilst their was an ABS sensor fault?

  7. #6
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,547
    Its all interlinked... fix one fault at a time... the other faults could be symptomatic of the steering issues...

    I would get the steering sensor issue sorted first then take it from there... I believe if the sensor faults like this there is an adaption period.. this might actually be what you are experiencing tbh... (had a similar issue on another car once before but didn't make the connection)...

    What car is this exactly? mileage looks low...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9
    We'll I had the ABS issue on the back left (no other faults at this time). Then I gave it a clean and while I was at it, swapped a battery which I had been putting off. Everything turns on and the red steering light is there along with the sensor issue. And it looks like it hasn't adapted and refuses to as there is an ABS sensor fault. That's just my logic, don't know how right it is.

    I'll start with the sensor and the realignment, see where that gets me.

    And that's another thing that confused me...it's a 2004 A3 TDI 140 with 97,000 on the clock and it's showing a reading on the fault at 6700 and the ECU is actually showing the right mileage with everything else.

    These cars are a burden and a joy.

  9. #8
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,547
    8L or 8P?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9
    8P

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    9
    Address 44: Steering Assist Labels: 1Kx-909-14x.lbl
    Control Module Part Number: 1K2 909 144 E
    Component and/or Version: EPS_ZFLS Kl.10 1202
    Software Coding: 0000000
    Work Shop Code: WSC 00000 000 00000


    Is there meant to be that many zeros?

  12. #11
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,547
    Not sure mate... 8P is not my specialism...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  13. #12
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

 

 

Similar Threads

  1. 1.8t with serious issues.. can anyone work this one out?
    By WillJP in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 25th May 2013, 17:48
  2. a3 steering issue can any rack be coded if differetn part number
    By ali1211 in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 3rd February 2013, 18:14
  3. Can anybody make sense of this for me?!
    By chud in forum A4/S4 forum(B5 Chassis)
    Replies: 7
    Last Post: 24th August 2011, 12:56
  4. 2004 A8 with 'issues' can anyone help?
    By RRH685 in forum A8/S8 forum
    Replies: 1
    Last Post: 16th March 2010, 06:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO