Chris NottSky Insurance
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Gods County
    Posts
    9

    Does anyone know????

    Hi all, yeah am new on here guys, just recently aquired my first audi, its a 3 door 3.2 with dsg on a 54 plate, 2 owners with full audi history and 49k on the clock. So far am really happy with the car, its very clean and straight and drives nice and tight, however the the EML light came on today so i have had it plugged in and its showing codes p2415 02 sensor exhaust sample error bank 2 sensor 1 and code p2197 02 sensor signal biased/stuck lean bank 2 sensor 1. Can anyone tell me which is sensor 1 please as you are stood over the engine bay, sorry if this question has been asked a thousand times guys but i just want to get to the bottom of it as i really enjoy the car. Would like to get it sorted asap as it is going into wakefield audi soon for coil pack recall check and dsg service plus haldex service. Many thanks . Rich

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    well bank 2 is whichever cyl 2,4 and 6 are. sensor 1 is up stream of the cat.

    to pin it down 100%, clear the codes you have so you are fault free. unplug the suspected lambda, switch the ignition back on and re-read the fault memory. if you now have "lambda sensor bank 2 sensor 1 - open circuit" then youve found it!

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Gods County
    Posts
    9
    Thanks alot for your reply murran, i,ve cleared it twice now and it comes back after a few miles, it never says 'open circuit' it always comes up as '02 sensor exhaust sample error' or sometimes '02 sensor signal biased/stuck lean' Am i right in saying the 3.2 has 3 lambda sensors? 2 upstream and 1 downstream? Thanks .Rich.

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    no, i mean you know it says two faults relating to b2s1 sensor.
    you asked which sensor it was? a way to tell is to unplug a sensor. the sensor will be open circuit with it unplugged. on reading the fault memory again it'll say "b2s1 sensor open circuit"! then you know thats the correct sensor. if it says b1s1 you know its the other one.

    im not sure if it has 2 pre and 2 post cat lambdas. does it have 2 separate cats? if theres two cats it should have 4 lambdas.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Gods County
    Posts
    9
    Thanks again murran, i have a new sensor so i will try what you have said and let you know soon, hope it workscos i love the car

 

 

Similar Threads

  1. does anyone know how to replace the Lambda sensor?
    By MingBluS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 16th May 2005, 23:26
  2. Does anyone know a good BMW oem parts supplier?
    By imported_Yaseen in forum General Chat
    Replies: 3
    Last Post: 18th October 2004, 13:05
  3. Does anyone know when....
    By jasew in forum A3/S3/Sportback (8P Chassis)
    Replies: 16
    Last Post: 22nd September 2004, 16:34
  4. Does anyone know if R88PER is on holiday
    By abmunro in forum General Chat
    Replies: 1
    Last Post: 15th August 2004, 17:56
  5. Does anyone know....
    By RichA3Turbo in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 2nd August 2004, 09:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO