JMB RetrofitsAH Fabrications
Results 1 to 3 of 3
  1. #1
    Djwoody's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2011
    Location
    Middlesbrough
    Posts
    345

    Aftermarket Filter and EML

    Hi.
    I fitted a K&N panel filter to my 2.0 TDI a couple of months ago, Then, I read that the K&N can damage your MAF sensor.
    With this is mind, I decided to change the K&N for a Pipercross. After a few days my EML started flashing, which I presume is something to do with the new filter.
    I am now going to buy a new OEM filter and put it back to standard. Should my EML go off when this is fitted or does it sound like i've knacked my MAF sensor?
    Just after your thoughts before I get it vagcom'd.

    Chris

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    478
    All aftermarket filters can cause the EML light to come on - it depends on how much oil is on the filter as this gets blown onto the MAF element. I've had a K&N on for 10k miles with no problems.

    Your EML light won't go away without cleaning your sensor (with Isopropyl Alcohol) and then resetting the error with VCDS.

  4. #3
    Djwoody's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2011
    Location
    Middlesbrough
    Posts
    345
    Quote Originally Posted by nluk100 View Post
    All aftermarket filters can cause the EML light to come on - it depends on how much oil is on the filter as this gets blown onto the MAF element. I've had a K&N on for 10k miles with no problems.

    Your EML light won't go away without cleaning your sensor (with Isopropyl Alcohol) and then resetting the error with VCDS.
    Thought that might be the case, I'll get it all cleaned when I put my OEM filter in.
    How do you remove the MAF?
    I took out the two screws connecting it to the hose and it makes it visible but I couldn't remove the grey fastener which looks like a jubilee clip at the top, it wouldn't budge.

 

 

Similar Threads

  1. replacement filter and spark plugs for s3 2000 x
    By sleeksx in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 20th March 2008, 13:45
  2. V6 owners with filters and exhausts please help me
    By Audi_TT 83 in forum TT/TT-S/TT-RS Forum
    Replies: 2
    Last Post: 4th March 2008, 12:59
  3. V6 owners with filters and/or exhausts please help me
    By Audi_TT 83 in forum A3/S3/Sportback (8P Chassis)
    Replies: 3
    Last Post: 2nd March 2008, 03:15
  4. Fitted a cone filter and......
    By M44 DUB in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 19th February 2007, 14:17
  5. Is there a valve in the oil filter and cooler?
    By S3Si in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 6th December 2005, 12:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO