Sky InsuranceMonster Motorsport
Results 1 to 11 of 11
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82

    Thumbs down RNS-E Blank Screen

    My RNS-E (2007 model) has developed a fault where the screen does not display anything.
    The radio switches on but no logo appears or station listings.

    There doesn't seem to be any power going to the screen at all.

    It happened once this week but it started working again but now it is just stays blank.

    Are these units serviceable or do I have to buy a new one?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    TimJK's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2011
    Location
    Norwich, Norfolk, United Kingdom
    Posts
    407
    Wanna buy mine? Shameless plug!

    I'm sure somewhere can fix these? Does screen come on when flip it down? Maybe a loose video cable issue?

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82
    Thanks for the offer.

    Yes the screen comes down. I think it looks like a loose connection or a circuit has failed.
    But I don't feel confidant taking it apart.

  5. #4
    TimJK's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2011
    Location
    Norwich, Norfolk, United Kingdom
    Posts
    407
    Does the screen come on though as it comes down? would indicate its a loose connection, Otherwise if the circuit boards failed would need replacing. Not sure where would repair, prob worth a google though for places that repair them?

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82
    It says blank when it comes down as well.
    Ok will have search.
    I will let you know how I get on.

    Thanks for your help.

  7. #6
    TimJK's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2011
    Location
    Norwich, Norfolk, United Kingdom
    Posts
    407

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82
    They are a bit.
    Will drop them an email over the weekend to see if they can give me a better quote than the prices they have there.

  9. #8
    Dannykn9's Avatar
    "Cruise My Ride"

    Status
    Offline
    Join Date
    May 2011
    Location
    North London
    Posts
    1,111
    Give Nigel NHN a PM, sure he can sort this out.
    VCDS Owner-North London/Enfield
    " To Cruise Is What I Do"


  10. #9
    Johnny Bravo's Avatar
    6+1 Gears

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Romania
    Posts
    797
    Most likely you need one of these: AUDI RNS-E NAVIGATION --PARTS---LCD TAPE | eBay
    DSG | Vienna Leather | Bose Sound | MFSW | Interior Lights Pack | Light & Rain Sensors | Auto Dimming Mirror Mods: LED RNS-e | FL LED Tail Lights | Bi-Xenons | Illuminated Speaker Grilles | Tinted windows | Chrome Switches | Chrome Paddles&Commands | RS4 Start Button | Cruise Control | S3 Pedals | S3 Roof Spoiler | 18" BBS CH | H&R Spacers 10/15 mm | Bilstein B16 PSS10 | H&R 26/24 ARBs | TT Arms | S3 Front Brakes+DS2500+Tarox F2000 | HEL Brake Lines | VNT20 | EGR&Cooler Delete | Custom Remap

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82
    It's been blank all the way to work today but it was ok for most of the drive back apart from a few time going blank and being ok again randomly. So I think your right Jonny It seems to be some kind of connection problem.

    I phoned the local dealerand they said a software upgrade would solve this issue. Seeing I've had the car for 5 years and there has been no issues I don't think it is.

    I asked how much it would cost for a sofware upgrade and it was £54!! I guess it's only putting a cd in the player and waiting for it to run. But if it doesn't work I don't need to pay or more likely it would be £54 off the price of actually them fixing it.
    I'm glad Microsoft doesn't charge £54 per update.

    Is it running the latest software?

    Last edited by XPOWER; 14th July 2012 at 08:27.

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Swansea
    Posts
    82
    It's been a while since my screen packed-in but I finally got around to sending it off to be fixed.
    I sent it to SatNav Systems of Surry.
    Within two days of sending it they diagnosed the fault and telephoned me with a quote for a replacement Screen Electronics Board.

    The total cost was £258 including the shipping it back to me.
    I had the unit returned in a week of sending it to them.

    So I was very happy with their level of service and the no obligation quote that they offered.

 

 

Similar Threads

  1. RNS-E Radio screen shows greyed stations
    By iwantone in forum In-Car Entertainment
    Replies: 4
    Last Post: 23rd May 2011, 16:29
  2. RNS-e scratched screen repair
    By M88JCP in forum A3/S3/Sportback (8P Chassis)
    Replies: 8
    Last Post: 14th March 2011, 11:37
  3. RNS-e scratched screen
    By M88JCP in forum Satellite Navigation
    Replies: 0
    Last Post: 22nd March 2010, 19:02
  4. RNS-E Glossy screen .
    By crypric23 in forum A3/S3/Sportback (8P Chassis)
    Replies: 25
    Last Post: 5th October 2009, 22:18
  5. RNS-E Screen "Noise"
    By JamS3 in forum In-Car Entertainment
    Replies: 8
    Last Post: 22nd February 2007, 14:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO