Monster MotorsportVolks Autos
Results 1 to 18 of 18
  1. #1
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354

    Loosing the plot! HELP WANTED PLEASE - ESP, ABS, Red Steering Wheel, Handbrake light

    Right I am crying out for a HUGE help now, I am loosing the plot and don’t know what I can do next!!

    Sorry for the long story………but it’s either a coincidence or partly something to do with it.Problem started off with my car having the ESP light on and ABS, once I got round to plugging it in the computer I found out it was a rear drivers side ABS sensor. Got that changed (Not genuine Audi) lights went off and wala! 2-3 days after driving about they came back on, did a repeat of the computer and it came up with the rear passengers ABS sensor. So changed that sensor (Not genuine Audi). At this point I thought it was a bit random that both had gone in a close space of time. BUT the lights didn’t go off this time! So computer on again!! And said it was the drivers ABS sensor AGAIN, so checked if there was any dirt and checked the bearing. Bearing was a bit rough and the ring on the back was a bit cracked soooooo I changed that (Not genuine Audi).

    Once I changed the bearing and went for a drive my dash turned into a Christmas tree……………..
    ESP
    ABS
    Red steering wheel
    Hand brake
    Engine management (now and again)

    Slight loss of power and steering slightly heavier.

    I’ve been doing a lot of googling / reading and I can’t put my finger on it. My mate is an Auto Electrician he has checked all the wiring to the ABS pump, checked all grounding and various tests. But with each test drive it gave him different fault codes each time i.e. front ABS sensors or rear, some valve in the ABS pump. A funny thing was that he couldn’t get rid of the ESP light after clearing all the codes. So from there he was stumped and an ECU test was next or a gamble with Audi if they could find something different.

    The ECU has been sent away to be checked and said it working fine and on it way back.

    Audi had a look for 2hrs and couldn’t find anything! Really scratching their heads, next step with them it to start stripping ££££££££

    Don’t know if this relates to what’s going, my battery was going flat after a couple of days standing. Now and again struggles to start like the battery is dead and then when you try again starts up fine! The alternator does a funny ticking noise when its starts up, is that ok?I don’t know what to do next now! Could it be the alternator? Could it be something to do with the bearing I changed or is it just a coincidence that all this triggered off after changing the bearing?

    Massssssssive thanks in advance to any help!
    Last edited by Blueie; 14th March 2012 at 22:58.
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Paullie's Avatar
    Banana Menace!

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    2,083
    I think it could possibly be your battery, Dude. I've heard that ABS/ESP lights come on if the battery is out of juice. I know it's not an Audi but my other half's Freelander 2 had this happen a few months ago, ABS/ESP/Hill Descent Control lights all on and car wouldn't start. We were worried it was the steering rack that was shot as that costs BIG $$$, but it was just the battery. Don't throw anymore cash at it until you get the battery/alternator checked out. xx
    MY10 S3 8P3 S-TRONIC, IMOLA YELLOW
    SHARK PERFORMANCE STAGE 2
    - GONE BUT NOT FORGOTTEN!

  4. #3
    4th Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    SW London
    Posts
    751
    The brake fault may be down to something else. But the steering wheel and ESP light came on after i changed my battery but went off after a hundred yards or so of driving. As previously said, if the batteries low its probably causing that. Get it tested out to see for sure

  5. #4
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    Quote Originally Posted by Paullie View Post
    I think it could possibly be your battery, Dude. I've heard that ABS/ESP lights come on if the battery is out of juice. I know it's not an Audi but my other half's Freelander 2 had this happen a few months ago, ABS/ESP/Hill Descent Control lights all on and car wouldn't start. We were worried it was the steering rack that was shot as that costs BIG $$$, but it was just the battery. Don't throw anymore cash at it until you get the battery/alternator checked out. xx
    Thanks Paullie, thats what my next check will be! I just hope to god its just something so simple cause im running out of steam with this car!

    Quote Originally Posted by Sidhu88 View Post
    The brake fault may be down to something else. But the steering wheel and ESP light came on after i changed my battery but went off after a hundred yards or so of driving. As previously said, if the batteries low its probably causing that. Get it tested out to see for sure
    Thanks! Cross fingers its a battery problem!
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  6. #5
    Ash187's Avatar
    Audi Retrofitter

    Status
    Offline
    Join Date
    Mar 2009
    Location
    North, East, South, West London & Dartford in Kent
    Posts
    6,289

    My Social Networking

    Visit Ash187's Instagram Channel
    Hope its not what Farhan had where a RAT ate through the wiring!
    A3 Sportback 2.0TDI
    Dark Headlining, Bose, Alcantara Leather, Lights Pack

    MODS:
    S3 facelift, 19" RS6, RS3 Grill, TTRS FBMFSW, A5 S-Line Heated Seats, Bi-Xenons, Auto Lights & Wipers, Eibach Sportlines, S3 brakes, Cruise, Pioneer HU, Reverse Camera, OEM Parking Sensors, Auto Folding & Dimming Dumbo Mirrors, LED Tail Lights, S3 Pedals, Tints, Carbon Trims.

    Items for Sale
    Read My Blog & Build Thread


  7. #6
    Smithymartyn's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    34
    My alternator failed recently (fortuntately only frayed belt and some sort of bracket). This resulted in limp mode, loss of power sterring, dashboard like Blackpool illuminations. May be worth a check? Good luck fella.....

    170tdi, Quattro Sportback

  8. #7
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    More i think about it it could be the alternator! But it sounds to simple lol Just hope it isnt rats, where do you start looking!!!
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  9. #8
    4th Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    SW London
    Posts
    751
    Halfords can do a battery and alternator test for u
    2006 Audi A3 2.0 TDI S-Line 8P2 PD170 - Dolphin Grey Metallic - The problem child
    1994 VW Golf VR6 - Mystic Blue - The money thief
    VCDS User

  10. #9
    Farhan's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    West London
    Posts
    1,228
    Yer dude test the voltage on alternator and battery. Mind you from previous experiences a faulty alternator not charging would bring up the battery light.

    Also the battery would quite simply be causing problems with start up. Regardless test those quick to try and narrow down the problem.

    The next thing i would suggest is, inspect the main power looms going to both the alternator and battery. Poor connections from the description you have given could suggest interference.My car had rat damage to the looms and power steering, i had allsorts of errors flagging up.

    From what i gather the wiring was done nearer to the firewall area and also the power steering.

    From what i have now learnt from the rat experience that if its not the ECU then its a bulk of wiring which would effect all those lights coming up.

    Just out of curiosity how old is the car? Nigel mentioned for me to check my grounding near the battery area and around the intake side...Worth a try and to help cancel out what you can.
    2008 A3 1.8TFSI 3 Door S Line - Lava Grey - Bose - Bluetooth - S Line Full Black Leather - Aux - Comfort Pack - Coming Home Lights - Storage Pack - Cruise Control - Ambient Interior Light - Footwell Lights - Audi IPhone 4 Cradle - Leather Armrest - BE Rear - MY09 Rear Lights - S3 Pedals - S3 Vents - BBS RS866 - Bi Xenons - Bluefin Stage 1 - K&N 57S Intake - Rev D Valve - Powerflex Dogbone Insert & Gear Box Mount


  11. #10
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    The car is a 2003/53, The groundings near the battery are all checked. D-day will be tomorrow! Getting my hands on it. Crossing everything that it is the alternator.

    Oh and i have been having starting problems so kinda makes sense.
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  12. #11
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    Frahan - Question, you know the problem with your car did all the lights come up straight away once you started it??

    As mine only come up after i drive about 2 miles. I've tested the alternator and battery load and all ok. Im getting to point i dont care how big or small the problem is, i just want to know what it is so i can do something about it lol.

    Whats random thing is that the ESP light stays on constantly, with no fault coming up on it!
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  13. #12
    Farhan's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    West London
    Posts
    1,228
    Quote Originally Posted by Blueie View Post
    Frahan - Question, you know the problem with your car did all the lights come up straight away once you started it??

    As mine only come up after i drive about 2 miles. I've tested the alternator and battery load and all ok. Im getting to point i dont care how big or small the problem is, i just want to know what it is so i can do something about it lol.

    Whats random thing is that the ESP light stays on constantly, with no fault coming up on it!
    Same as you fella!! when they were cleared....They would take maybe 2 hours to come up again!!!!

    Me and Itwasntme(ash) sat down one whole afternoon running vcds scans driving around in the car resetting the power steering, Doing a road test.

    We drove for around an hour nothing!....We thought its all cleared low and behold sitting on the driveway engine running talking of mods....Ping....Ping...Ping....all faults came back.

    The powersteering fault would continuously reappear after 1-2 miles and the engine lights would appear in a sequence straight after.
    2008 A3 1.8TFSI 3 Door S Line - Lava Grey - Bose - Bluetooth - S Line Full Black Leather - Aux - Comfort Pack - Coming Home Lights - Storage Pack - Cruise Control - Ambient Interior Light - Footwell Lights - Audi IPhone 4 Cradle - Leather Armrest - BE Rear - MY09 Rear Lights - S3 Pedals - S3 Vents - BBS RS866 - Bi Xenons - Bluefin Stage 1 - K&N 57S Intake - Rev D Valve - Powerflex Dogbone Insert & Gear Box Mount


  14. #13
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    Quote Originally Posted by Farhan View Post
    Same as you fella!! when they were cleared....They would take maybe 2 hours to come up again!!!!

    Me and Itwasntme(ash) sat down one whole afternoon running vcds scans driving around in the car resetting the power steering, Doing a road test.

    We drove for around an hour nothing!....We thought its all cleared low and behold sitting on the driveway engine running talking of mods....Ping....Ping...Ping....all faults came back.

    The powersteering fault would continuously reappear after 1-2 miles and the engine lights would appear in a sequence straight after.
    Because ive recently changed some parts i.e. the sensors and bearing im tempted to change them to genuine Audi. Couple of guys told me know they have had similar problems and once the change them to genuine problem solved! So worth a gamble!
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  15. #14
    Farhan's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    West London
    Posts
    1,228
    Certainly mate, try genuine depending on cost and see how you go from there. Obviously its hard to describe the rat damage because rats wont bite in the same place....But i would say maybe just before you do anything ask the garage to look closely at the looms going into the firewall area form underneath the car.

    Apparently cellulose is used quite a bit to seal the cables in or on the loom tapes (This attracts rats to chew on the looms) I mean if you find nothing visually then its safe to say your in the all clear on that front and can replace the said parts.
    2008 A3 1.8TFSI 3 Door S Line - Lava Grey - Bose - Bluetooth - S Line Full Black Leather - Aux - Comfort Pack - Coming Home Lights - Storage Pack - Cruise Control - Ambient Interior Light - Footwell Lights - Audi IPhone 4 Cradle - Leather Armrest - BE Rear - MY09 Rear Lights - S3 Pedals - S3 Vents - BBS RS866 - Bi Xenons - Bluefin Stage 1 - K&N 57S Intake - Rev D Valve - Powerflex Dogbone Insert & Gear Box Mount


  16. #15
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    Ideal thanks for that! I will give it a good look over before i order the parts.

    With the genuine parts i think ive just got to bite the bullet if i want to get the car sorted.
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  17. #16
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    *UPDATE*

    The Bluester is one happy chappy!!!!!! All fixed and spot on now! It was down to the rear ABS again, it was faulty.

    We ran live diagnostics one the wheel sensors and it showed that one wheel was turning faster than the others, hence why i was going crazy. It wasnt a clear fault hence why it wasnt showing on the computer clearly. So from a £25 sensor all lights have gone now! £400 later

    Thanks for all your input, hope this helps someone one day!


    P.S. I can finaly put my car up for sale, time for a change
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

  18. #17
    Farhan's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    West London
    Posts
    1,228
    glad for you mate what a relief!
    2008 A3 1.8TFSI 3 Door S Line - Lava Grey - Bose - Bluetooth - S Line Full Black Leather - Aux - Comfort Pack - Coming Home Lights - Storage Pack - Cruise Control - Ambient Interior Light - Footwell Lights - Audi IPhone 4 Cradle - Leather Armrest - BE Rear - MY09 Rear Lights - S3 Pedals - S3 Vents - BBS RS866 - Bi Xenons - Bluefin Stage 1 - K&N 57S Intake - Rev D Valve - Powerflex Dogbone Insert & Gear Box Mount


  19. #18
    Blueie's Avatar
    He who dears' wins!!

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Anglesey
    Posts
    354
    Quote Originally Posted by Farhan View Post
    glad for you mate what a relief!
    Tell me about it!!! Few beers this weekend now!
    I cant read, an i cant write. But thats ok! Cause im from the west country and i can drive a tractor!

    Click here to make clicking sound

 

 

Similar Threads

  1. ESP, ABS and now Power steering warning
    By r10jdl in forum A3/S3/Sportback (8P Chassis)
    Replies: 15
    Last Post: 29th August 2011, 17:20
  2. Red Steering Wheel Warning Light
    By A3-ALF in forum A3/S3/Sportback (8P Chassis)
    Replies: 24
    Last Post: 18th January 2011, 17:19
  3. ESP and ABS light on
    By jimmp in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 17th January 2011, 10:21
  4. abs and esp light on with engine management light
    By madsad1 in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 18th May 2010, 18:22
  5. ESP light and handbrake light
    By marcyp in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 19th November 2009, 00:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO