AH FabricationsVolks Autos
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2011
    Posts
    9

    ESP & Emissions Light Staying on an car stalling when coming to stop.

    Hi,

    Just a bit of background on the car, it's a 53 A3 3.2 V6 with DSG,

    I was driving home today in traffic, when all of a sudden the car stalled when I came to a complete stop. It came as a bit of a surprise as I thought the DSG was incapable of stalling.

    I put it back into park, started then engine and continued driving, however the ESP light stayed on, the car felt perfectly fine, pulled well but as soon as i came to a stop it stalled again.

    This happened a few more times, after about the 4th restart, the check emissions light also came on.

    The car is now sat outside my house, as soon as i start it I get both the ESP light and Emissions light staying on, but the car will idle. It only seems to be when it comes to stop from moving that it stalls.

    I don't have access to a VAGCOM at the present time, does anything have any ideas of experienced anything similar?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Apr 2011
    Location
    Essex
    Posts
    30
    Hi, I have the same car except mines a 54 plate. I had this problem about 8 months ago I checked this thread out Engine cut out, ECS & ESP lights on I discounted the chains as mine had been done by previous owner who had also had the cutting out. invoice from Audi main dealer said they had checked earth points so discounted them.

    I checked with VCDS and had lots of faults showing! including the faulty air mass meter which the previous owner had just replaced.
    again dismissed that.

    mine had a K&N air filter in, have read that the oil can cause problems with the MAF so changed to a proper Audi one, got an extra 3 MPG! (not to be sneezed at in a 3.2) but still cutting out.


    I then read it could be something to do with the throttle body, so read about resetting the throttle body with VCDS so tried that and it worked! has not cut out in about 8 months until a flat battery caused by the car being in a workshop for a week for a inner CV joint to be replaced, the garage tried to get a aftermarket one to save me money couldn't had to get genuine one in the end.

    anyway 2 days after getting the car back it cut out at a roundabout, very embarrassing as it will not idle so you have to keep the revs up the same time as your braking, with it being DSG not easy!


    apparently on modern cars with electronic throttle body's when battery is disconnected and reconnected you should put the ignition on for 1-2 Min's without touching the accelerator pedal for it to reset, you will hear it making whirring and clicking noises.

    now my thinking is if a garage has disconnected the battery for whatever reason to work on the car it will properly be the last thing to be connected back at the last minute, I bet they don't sit there with the ignition on for a couple of Min's!

    now that was over a month ago, and no cutting out.


    as you haven't got VCDS to do the throttle body adaption which I think does the same as disconnecting and reconnecting the battery you could try it nothing to lose!

    only problem on the 3.2 is the battery is in the boot under a metal cover with 20,000 bolts securing it!
    I would disconnect the battery for about 5 Min's negative lead and when reconnected just turn key so the ignition lights are on.


    do not touch the pedals while it is doing its thing, I lost my time settings and the one touch windows settings.
    I have heard that it is a good idea to reset the throttle a couple of times a year, for throttle response and MPG.

    sorry such a long post but you could spend a fortune at Audi and not cure it so I always try the cheapest solutions first!

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2011
    Posts
    9
    Brilliant colin, thank you for the reply,

    I started it up this morning and it was idling rough, but didn't stall. This doesn't make sense to me :S

    It's going back into Audi Bristol on Monday for the coil pack recall, and in for a full service just after at my local indie garage. If i don't have any success with the TB alignment hopefully these will sort it out.

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Apr 2011
    Location
    Essex
    Posts
    30
    yes when mine did it the ESP and check engine light would come on and it would not idle at all, but after it was switched off for a few hours or more it would then idle OK and not stall for a few days or so with just the ESP light lit.


    The reason I thought it was connected to the throttle body was my last car was a Jaguar XJR V8 that would do a similar thing, it was so wide spread that Jaguar did a recall and changed it for free, apparently if you had to pay yourself you would not get much change from £1500! not bad considering car was 13 years old and had done 135,000 miles with no Jag service history for about 6 years, from what I have read on this forum Audi won't be so accommodating!

    Well worth the investment in VCDS switch the warning lights of yourself without having to give Audi £50+ every time, plus all the extras you can enable if not already done eg audible bleep on setting alarm etc.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2011
    Posts
    9
    Ok status update,

    I've taken apart the whole air intake system, cleaned the MAF with electrical cleaner spray, cleaned the throttle body using this technique on the TT forum for the same V6 engine, The Audi TT Forum :: View topic - 3.2 V6 Throttle Body Clean - How To,

    the throttle body really was gunked up, and there was no space for air around the side of the butterfly,

    i had the ECU fuse disconnected throughout this process, when i reconnected it and turned the ignition the throttle body made a noise for about 30 seconds.

    I then had the local indie clear the codes and turn warning lights of, and its been fine since

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Apr 2011
    Location
    Essex
    Posts
    30
    fingers crossed!

    Mine when warmed up idles in D at 640rpm, checked with VCDS but sits on the 600rpm marker on the rev counter, I did notice that prior to it cutting out ie a day before, the revs would drop slightly below the 600 increment when at idle.
    If you notice that in future could be a early warning.

    if you are taking it to Audi for coil packs recall you might as well ask about getting the software update Advice re 3.2 QS DSG mentioned near the end of the post.

 

 

Similar Threads

  1. ABS & ESP Lights Staying On
    By Jiny_P in forum A3/S3 Forum (8L Chassis)
    Replies: 36
    Last Post: 31st August 2013, 20:28
  2. ESP Light staying on
    By dirtydamdog in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 3rd April 2011, 20:01
  3. Found out why my ESP light was staying on
    By V6Pete in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 22nd March 2010, 17:35
  4. ESP and EPC Light Staying On And Engine Revs Up & Down??
    By pazaz in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 15th March 2010, 20:34
  5. esp light staying on cutting engine out
    By kendo01 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 28th October 2007, 19:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO