JMB RetrofitsMonster Motorsport
Results 1 to 26 of 26
  1. #1
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628

    What are the signs of a faulty coolant temperature sensor?

    My car for a while has been ticking over rough on idle but only when the temperature reads 90', it starts first time every time in an instant, but once it warms up to temperature the engine starts to shake and miss fire.

    It also takes around 15 miles or 30 mins or so to properly warm up (on the cluster i mean, the heating is warm long before the cluster reads 90')

    This morning whilst queuing down the M606 for about 5 mins stood still the engine temperature began to drop, bear in mind the car had been running a good 35 mins and covered around 14 miles to this point, surely being stood still for less than 5 minutes would not cause the cluster temperature read out to drop 1/4 of the way back down?

    The car drives perfect and gives back good MPG and miles to the tank however on idle it's a pig when warm NOT when cold.

    Can anyone shed any light?
    Last edited by AidenUK; 30th January 2012 at 15:12.
    Audi A3 2.0L TDI S-Line Sportback

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    marknjayne's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    worksop
    Posts
    423
    whats it showing on the gauge and if you have the oil temp on the DIS whats that at,coudl possibly be a stuck thermostat


  4. #3
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Don't know what the oil temperature is, i could check that on the DIS on the way home tonight.

    When the car eventually warms up, it shows 90' but once sat in traffic the gauge then drops as it did this morning.

    The lumpy idle is doing my head in!
    Audi A3 2.0L TDI S-Line Sportback

  5. #4
    marknjayne's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    worksop
    Posts
    423
    is there not someone up your way with vag-com or similar


  6. #5
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Been scanned and there are no faults, would a nackered DMF cause the car to miss fire? Or would it just give a lumpy idle, the engine misses, well the engine sounds like it's missing, lift the bonnet and it's shaking its tits off, feather the gas pedel slightly and the rough idle goes away, the car drives perfect and when it's cold it idles perfect.
    Audi A3 2.0L TDI S-Line Sportback

  7. #6
    marknjayne's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    worksop
    Posts
    423
    could be air flow meter,coil/s or plug/s,injector/s etc but i cant see how that will relate to engine coolant temp


  8. #7
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    I thought if the coolant temperature sensor was nacked it would over fuel the car on idle thus causing it to idle like a crock of sticky stuff? Is this completely wrong then?
    Audi A3 2.0L TDI S-Line Sportback

  9. #8
    marknjayne's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    worksop
    Posts
    423
    could possibly,i have no experience with the coolant sensor though so cant help there,im sure it would show up on vag com though


  10. #9
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Aiden - I will re-scan it for you if you want. However, you could always take it to my man in Leeds who will diagnose immediately !

  11. #10
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Quote Originally Posted by mike foster View Post
    Aiden - I will re-scan it for you if you want. However, you could always take it to my man in Leeds who will diagnose immediately !
    Thanks Mike, I might need you to do that for me. Who's your guy in Leeds you know? Is he a Audi specialist?
    Audi A3 2.0L TDI S-Line Sportback

  12. #11
    marknjayne's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    worksop
    Posts
    423
    dont think scanning will show it if the sensor is within its perimeters,had this issue with an air flow meter,its was knackered but still sending a signal, unfortunately the wrong signal so the fuelling was all over the place but the ecu saw a signal and adjusted the fuelling and timing to suit without throwing a code or light


  13. #12
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Quote Originally Posted by marknjayne View Post
    dont think scanning will show it if the sensor is within its perimeters,had this issue with an air flow meter,its was knackered but still sending a signal, unfortunately the wrong signal so the fuelling was all over the place but the ecu saw a signal and adjusted the fuelling and timing to suit without throwing a code or light
    What was your car doing to make you think it was the air mass meter mark?

    Thanks for your help.
    Audi A3 2.0L TDI S-Line Sportback

  14. #13
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Volksworks.com - the owner has 30 years experience with VW and is hands on. Does all the work for taxi drivers in Leeds and BKD engines are bread and butter ! VAT registered and sorted my turbo with Warranty Direct ! PM me for a scan if you want one.

  15. #14
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Thanks for that Mike!
    Audi A3 2.0L TDI S-Line Sportback

  16. #15
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Driving the car for 27 minutes and covered almost 12 mile, the car still hadn't warmed up on the gauge, the heaters themselves in the cabin were blasting out 27' worth of hot air.







    Does this look right?
    Audi A3 2.0L TDI S-Line Sportback

  17. #16
    jb0o's Avatar
    North East Forum Moderator

    Status
    Offline
    Join Date
    Feb 2009
    Location
    North East, UK
    Posts
    2,609
    Seen this thread this morning and tracked mine on the way to work this morning.

    Mine was pretty much fully warmed up by 8 minutes & 4.5 miles.

    Website | Facebook | Audi TT 2.0TDI 170 Quattro


  18. #17
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Hi matey, do petrol engines warm up quicker than diesels? I don't know, i don't even know if this is abnormal or not. All i know is, the missing on idle is royally pissing me off.
    Audi A3 2.0L TDI S-Line Sportback

  19. #18
    jb0o's Avatar
    North East Forum Moderator

    Status
    Offline
    Join Date
    Feb 2009
    Location
    North East, UK
    Posts
    2,609
    I've no idea unfortunately mate

    Hope you get it sorted soon!

    Website | Facebook | Audi TT 2.0TDI 170 Quattro


  20. #19
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    York
    Posts
    1,657
    Quote Originally Posted by AidenUK View Post
    Hi matey, do petrol engines warm up quicker than diesels? I don't know, i don't even know if this is abnormal or not. All i know is, the missing on idle is royally pissing me off.
    Yes petrol engines warm up a damn sight quicker than diesels.
    MY15 8V S3 Sportback with options

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Bristol
    Posts
    6
    I have a 53 plate 2.0TDI and it is doing the exact same thing, no movement on the temp gauge for what seems like ages and then goes straight to 90 degrees... also have the lumpy idle when warm.

    Seems to be quite a common thing but I'm unable to find a definitive answer anywhere on how to solve it!?

  22. #21
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    Is yours missing on idle from time to time, i can feel the vibration through the gear stick, i watch the gear stick and see it shake and move when the car is at it's worst!!
    Audi A3 2.0L TDI S-Line Sportback

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Bristol
    Posts
    6
    Quote Originally Posted by AidenUK View Post
    Is yours missing on idle from time to time, i can feel the vibration through the gear stick, i watch the gear stick and see it shake and move when the car is at it's worst!!
    I wouldn't say it was actually missing but it does get very lumpy, it also hunts at times and the revs will pick up to just over 1k, sit there for a few seconds and return to be being lumpy... I've only noticed it the last couple of days so not had chance to investigate it properly as yet. The confusing thing is how is this and the temp gauge's weird behaviour linked or are the two seperate problems??

  24. #23
    jonnysimm's Avatar
    jonnysimm

    Status
    Online
    Join Date
    Nov 2008
    Location
    warrington
    Posts
    161
    Mine also has lumpy idle and also would like to know, ive been told it could be my EGR valve and may need replacing?

  25. #24
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    I'm fecked if i know.

    If i pop the bonnet the engine is rocking away, you can feel the shakes and judder in the car, you can watch the gear stick shake whilst in gear with my foot pressed on the clutch, the rev counter doesn't fluctuate up or down at all.Properly pisssing me off if I'm honest, the car has been scanned countless times and no faults are thrown up, i've whacked countless amounts of injector cleaner through it and it had 84 quids worth v-power diesel the other day and still not a turds worth of difference.
    Audi A3 2.0L TDI S-Line Sportback

  26. #25
    audicruiser's Avatar
    Audi Heaven

    Status
    Offline
    Join Date
    Feb 2010
    Location
    Somerset
    Posts
    1,861
    Thermostat for sure, and it won't show on any scans. Does the temp gauge drop of colder if your coasting down a hill? I had a similar fault on my old 1.8T Golf, it ran like a new car once the thermostat was fixed and the ecu gets all confused from the false readings from related sensors...
    Scott

    Audi A3 Sportback 2.0T Quattro S-Line 2007 8P2
    Lava Grey, Exclusive Line Black/Silver Leather, Heated Seats, Bose, RNS-e, iPod, Auto Lights & Wipers, Interior Light Pack

  27. #26
    6th Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    1,628
    No the thermostat doesn't do that matey.
    Audi A3 2.0L TDI S-Line Sportback

 

 

Similar Threads

  1. what coolant temperature sensor?
    By knoxie in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 17th December 2011, 18:33
  2. Where is Coolant Temperature Sensor? Help please!
    By Pom in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 3rd September 2011, 15:28
  3. Price please on a Coolant Temperature Sensor
    By impster in forum Parts Requests
    Replies: 1
    Last Post: 17th August 2009, 21:11
  4. coolant temperature sensor problem.
    By nu boy in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 30th April 2008, 15:10
  5. Faulty coolant temp sensor?
    By AndyMac in forum A4/S4 forum(B5 Chassis)
    Replies: 8
    Last Post: 19th August 2006, 19:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO