AH FabricationsBadger5
Results 1 to 8 of 8
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    11

    newbie, help- 2004 2.0 TDi Sport - Emission Control System warning light & power loss

    Hi,

    I'm the proud new owner of a silver tdi sport which I bought from an used car garage in Manchester last Thursday.

    I had to drive on the motorway for the first time yesterday and I noticed the emission control system warning light was on and when the car hit 70mph there was a serious lack of power which didn't reset until stopped car and restarted the engine.

    I phoned the garage who said it could be a faulty sensor and Audi's have a limp mode to protect engines when a warning light comes on. The warning light is still on but its driving fine but when it hits 70mph limp mode still kicks in.

    The garage have told me to take it in so they can check the fault code and sensors.

    Anyone experienced this problem?

    Thanks in advance.
    Last edited by a3tazza; 29th January 2012 at 19:10.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Manchester
    Posts
    130
    Haven't had limp mode kick in at 70mph, it's either been on or off. I'm guessing yours won't have a DPF being a 2004 so it's most likely to be a sensor but I can only comment on those with DPFs really. Ultimately take it back, get it scanned and ask to see the results too.

  4. #3
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Make sure you get a print out of the fault codes so you have proof.

    If the garage is not Audi you need to make sure that they have the proper scanning equipment to pinpoint the problem.

    If the engine code is BKD and is 140 bhp then you will not have a dpf.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    11
    Hi, thanks for replies. The engine code is bkd. I'll make sure I get a print out as It's not an Audi garage.

  6. #5
    2nd Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    London
    Posts
    334
    Could be the turbo vains sticking since your getting very similar symptoms, common problem on these cars.

  7. #6
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    If the print out shows 'overboost/underboost' then you may have a pressure pipe problem or a turbo problem. As Roman says, this is a common problem on this model but you need it sorting before the warranty runs out.

    Please keep us informed as the 'non-Audi' garage may not know all the possibilities and you may get additional help on here !

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    11
    Just a little update...

    The dealer had me take it to a another garage for them to run a diagnosis which showed an unknown error code. I then had to leave the car overnight for them to check in more detail at another garage who specialised in Audi's. They have diagnosed the problem as sticky turbo veins and will be cleaning the turbo veins tomorrow morning. Is there anything else I should be checking to make sure this problem doesnt come back as I only have 3 months warranty?

    Thanks again.

  9. #8
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    That is the 'overboost' error code I was talking about. You can clean the vanes but it is not a cure, however it will last the 3 months out which is no doubt their plan !

    I should suggest to them that they should guarantee this remedial work for 12 months and if the same problem returns then they will fix it for free.

    The only real cure is a new turbo.

 

 

Similar Threads

  1. emission control system warning light flashing............
    By tisinthepark in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 28
    Last Post: 20th February 2011, 17:02
  2. Replies: 2
    Last Post: 25th November 2010, 16:00
  3. Emission Control System Light
    By nwells in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 6
    Last Post: 5th April 2010, 21:17
  4. Emission Control System Light
    By jumpers in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 5th August 2008, 21:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO