Sky InsuranceAH Fabrications
Results 1 to 6 of 6

Thread: Turbo problems

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2011
    Posts
    5

    Turbo problems

    Ok another slight problem i have and want to solve.
    Recently my turbo, or rather the car has been going into limp mode. This happens when on the motorway and accelerating in 6th gear, the car pulls but then suddenly shuts down and wont rev over 2000 rpm. Yet if i accelerate in any other gear it will rev fine and wont cut off. If i pull over after the turbo has cut out, switch off the engine and then restart it is fine and works perfectly again. I have read that the turbo can get clogged up and overboost, but i thought it wouldnt work again after that? Mine works fine unless its under load, but after switching on off its fine?
    Any help would be great.

    Thanks

    Nathan

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    113
    Hmm, sounds like a strange one! Have you recently run the fuel tank very low? Of so I'd stick an injector additive into a full tank of high octane fuel and see if that sorts it out. If not I'd get it checked out by your local (trusted) garage.
    2004 A3 3.2 Quattro Sport DSG S-line
    2008 KTM 950 Supermoto
    1988 Honda CBR400RR Tri-Arm

  4. #3
    Paradox1's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    SoUf EaSt,Uk
    Posts
    1,829
    sound like shat mine is doing.if I get mine resolve before you ill update this thread.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2011
    Posts
    5
    No never ran it low, always prety much fill up when the light comes on. Iv read about using a turbo cleaner to unstick the turbo, so going to look into this and see if its good. Dont want to be bying endless amount of parts and sensors to find out all it needed was cleaning.

    Ah cool thanks Parodox1

  6. #5
    devonmikeyboy's Avatar
    As far from JBS as possible !

    Status
    Offline
    Join Date
    Feb 2007
    Posts
    1,257
    Engine type/model ?
    06 Audi 2.0 PD140 Sport TDI Quattro S-LINE.
    Old engine 330 bhp @ flywheel 263 bhp @ wheel 490 lb torque. Audidriver write up HERE
    Now stripped and playing with an uprated Cryo treated engine fitted with bigger turbo,water/methanol,uprated injectors etc etc.Wanting 400 bhp and 500 lb torque.

    Other car 500+ bhp MK4 Golf R32 turbo.

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2011
    Posts
    5
    Its the dreaded bkd engine, iv read all about the supposed problems but none sem to have a definitive answer other than just get a new turbo. Unfortunately i cant afford that, so i may as well give the turbo cleaner a try.

 

 

Similar Threads

  1. Turbo Problems
    By danman1986 in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 2nd September 2011, 18:35
  2. Turbo Problems?
    By tompearson in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 4th February 2010, 21:04
  3. Turbo problems
    By grannyjane1970 in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 23rd November 2009, 18:07
  4. turbo problems
    By colinr in forum Diesel forum
    Replies: 1
    Last Post: 2nd June 2008, 12:23
  5. Turbo Problems
    By A3TDI_SPORT in forum Diesel forum
    Replies: 0
    Last Post: 16th November 2006, 08:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO