Volks AutosChris Nott
Results 1 to 23 of 23
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43

    Auto lights and Wipers - Central electrics question

    Hi all,
    as i am in need of having my windscreen replaced, I thought I would retro fit the auto lights and wippers.

    My car is a 54 plate 2.0 tdi Sport, with Dsg.
    The central electrics Vag number is: 8P0 907 279 A 17byte coding (I think the A revision means Highend)

    After much searching around on the web I have found answers to most of my questions, the one that I realy need answerd is:
    Will my central electrics modual support this function ?
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Ash187's Avatar
    Audi Retrofitter

    Status
    Offline
    Join Date
    Mar 2009
    Location
    North, East, South, West London & Dartford in Kent
    Posts
    6,321

    My Social Networking

    Visit Ash187's Instagram Channel
    Do you have access to VCDS? If so have a look on your CE module and look on byte 0 for rain sensor installed check box.
    I believe that the F module and onwards support this but I I'm happy to be corrected
    A3 Sportback 2.0TDI
    Dark Headlining, Bose, Alcantara Leather, Lights Pack

    MODS:
    S3 facelift, 19" RS6, RS3 Grill, TTRS FBMFSW, A5 S-Line Heated Seats, Bi-Xenons, Auto Lights & Wipers, Eibach Sportlines, S3 brakes, Cruise, Pioneer HU, Reverse Camera, OEM Parking Sensors, Auto Folding & Dimming Dumbo Mirrors, LED Tail Lights, S3 Pedals, Tints, Carbon Trims.

    Items for Sale
    Read My Blog & Build Thread


  4. #3
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    Ok I had a look today, I can see the long coding helper screen, there are some check box's (some are ticked some are not) but there are no labels to tell me what the check box's do.

    I assume my label file for this modual needs amending?

    Oh my vcds ver is 10.6
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    Ok, so after using my mates newer version of vcds the options for the central electrics modual now have labels

    For my byte 0 I have:
    A) Rain-/Light sensor installed (bit 6)
    B) coming-home active (bit 7)

    I assume that because I have these options I can infact install the auto lights and wippers ?
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  6. #5
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    A is not high end, thats not to say it does/doesnt support the feature, C module supported this feature, as does its superseding parts F, K & P, also possibly a B given that was the initial released high end.

    Now the issue here is, vcds may show it as a codable option, but it may not support it, you could try coding it & see if it rejects, which inturn usually means either it isnt detecting the connected device or it doesnt support.

    Rather conflicting info from RT tbh as in the label files it shows A as high end & points it to the high end coding tables, but also says its a medium board & audi state it isnt high end just by working out via part numbers & superceding etc & I know 100% the A goes to a D & that wasnt high end.

    Also A was very early on release so it may not have coding for the option anyway, it was a 17byte module iirc.

    Only true way to now is to connect temp the sensor etc & see if it codes up & works as such.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    Ok, so just tried to set the rain-/light sensor installed bit, it set and accepted the coding.
    after it accepted the coding i check around and found no problems, after starting the car and testing the wipers, mirros windows ect, i scaned the cra again, the central electrics unit tells reports the following error.

    02071 - Local Databus
    004 - No Signal/Communication

    and the coding screen is blank, so i can not undo the change.
    Would this error just be reported because i do not have the mirror and rain sensor conected ?
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  8. #7
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    CE errors dont neccessarily come up immediately after coding or clearing an existing code, so best to come out of module, turn of ignition, turn back on go back in, then check.

    Your now reported errors are 1 of the things I advised could happen & the reason.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    Ok, did that, it is still reporting the error.
    Just a stupid question, but how would i correct the error if it does not go away by its self ?
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  10. #9
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    You just have to disable the bits & it will clear, after you've manually cleared the faults shown already that is.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    Ok, so I cannot talk to the module to recode it and the coding caused it to stop talking to the rest of the car.
    Manually removing the error code does not allow me to talk to the modual, every time I come out of the modual and back in it's back.
    Hmm, is it pos that I have killed the modual? If not what else could it be ? As it should not just stop talking to the rest of the car of no reason.
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  12. #11
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    As I'm not there I cant really know what you've done, assuming you can communicate with other modules ok, have you unplugged battery or the module for a period to try & fix comms, also what version of vcds are you using?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Clacton-On-Sea
    Posts
    43
    I am using vcds 10.6, I will try disconnecting the battery tomorow, thanks for the help though, think I will leave this mod though.
    Yes I can talk to all the other moduals in the car.
    Audi A3 2.0 Tdi Sport | DSG | Black | Half Leather Seats | Heated Seats | Electric Lumbar |Bose

  14. #13
    Ash187's Avatar
    Audi Retrofitter

    Status
    Offline
    Join Date
    Mar 2009
    Location
    North, East, South, West London & Dartford in Kent
    Posts
    6,321

    My Social Networking

    Visit Ash187's Instagram Channel
    Are you using a proper VCDS cable? It's weird how you cannot see labels and now cannot communicate with the module?
    A3 Sportback 2.0TDI
    Dark Headlining, Bose, Alcantara Leather, Lights Pack

    MODS:
    S3 facelift, 19" RS6, RS3 Grill, TTRS FBMFSW, A5 S-Line Heated Seats, Bi-Xenons, Auto Lights & Wipers, Eibach Sportlines, S3 brakes, Cruise, Pioneer HU, Reverse Camera, OEM Parking Sensors, Auto Folding & Dimming Dumbo Mirrors, LED Tail Lights, S3 Pedals, Tints, Carbon Trims.

    Items for Sale
    Read My Blog & Build Thread


  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    Is anyone else in this situation? Or did someone, by now, find out if the 8P0 907 279 A module is compatible with Auto Lights/Wipers and CH/LH functions?
    I am changing the windscreen soon and have just bought an autodimming mirror, so i am going to try this in the next few days..

  16. #15
    Ash187's Avatar
    Audi Retrofitter

    Status
    Offline
    Join Date
    Mar 2009
    Location
    North, East, South, West London & Dartford in Kent
    Posts
    6,321

    My Social Networking

    Visit Ash187's Instagram Channel
    As far as i know the A rev module doesnt have support for the rain sensor.
    A3 Sportback 2.0TDI
    Dark Headlining, Bose, Alcantara Leather, Lights Pack

    MODS:
    S3 facelift, 19" RS6, RS3 Grill, TTRS FBMFSW, A5 S-Line Heated Seats, Bi-Xenons, Auto Lights & Wipers, Eibach Sportlines, S3 brakes, Cruise, Pioneer HU, Reverse Camera, OEM Parking Sensors, Auto Folding & Dimming Dumbo Mirrors, LED Tail Lights, S3 Pedals, Tints, Carbon Trims.

    Items for Sale
    Read My Blog & Build Thread


  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    I checked today and the option appears on VCDS. It lets me check the box and apply the modifications, but afterwards it gives an error about not finding the rain sensor. So it might work, the only questions and problems i've read are about CH/LH.
    Anyway, i'll post the updates as soon as i've made some progress.

  18. #17
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    If it codes & gives you dis warnings of system not functional then yes it will be possible to fit.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  19. #18
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    Ok, mounted it today, it gives a defective sensor error on the DIS and in VCDS two errors, one about the sensor and the other one about a canbus connection error with no signal.
    It seems to be the same problem like here, in post #44:
    How easy is it to retrofit auto lights&wipers?

    Will check the wiring in a couple of days, i hope that it's just an earth problem.

  20. #19
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,014
    Sounds like wiring to me.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    I checked everything today.

    The CE is a 8P0 907 279 A.
    So, the light and rain sensor - 4E0 955 559 A - is good. I checked it on another car with rain and light sensor from factory and it works. It even sees it in VCDS, with the brighteness levels. (0..7)
    On my car, in VCDS, the brightness only appears "ON", even if i cover the sensor or put it in the sun. And it doesn't seem like it sees it.

    The wiring - must be good - the auto dimming mirror is working, it had the same earth point. I even moved the earth to OEM grounding point just near the bonnet release lever, as others stated that the earth was the cause for the errors.

    Still nothing, the problem is still there.

    And it seems that it's common on 8P0 907 279 A. I have the same problem as the OP, after the car gives the actual errors on VCDS, sometimes the car stops talking to the computer. The coding screen is blank and i can't do anything.

    The only solutions is disconnecting the car's battery.

    So i'm left with it as it is, whenever i put the light switch in the Auto Position, the error appears on the DIS and disappers when i manually use the Lights..

    Any possible solution? Can the CE be the problem?
    Thanks..

  22. #21
    Ash187's Avatar
    Audi Retrofitter

    Status
    Offline
    Join Date
    Mar 2009
    Location
    North, East, South, West London & Dartford in Kent
    Posts
    6,321

    My Social Networking

    Visit Ash187's Instagram Channel
    It may just be that the module you have does not support the feature... It's not uncommon and I Have seen another car with the A module that uses a different type of light sensor and dimming mirror.
    I should have someone that is selling up their C rev module next week or so which I know supports the auto lights as he already has that in his car.
    PM me if you are interested in it and I can get you the details you need
    A3 Sportback 2.0TDI
    Dark Headlining, Bose, Alcantara Leather, Lights Pack

    MODS:
    S3 facelift, 19" RS6, RS3 Grill, TTRS FBMFSW, A5 S-Line Heated Seats, Bi-Xenons, Auto Lights & Wipers, Eibach Sportlines, S3 brakes, Cruise, Pioneer HU, Reverse Camera, OEM Parking Sensors, Auto Folding & Dimming Dumbo Mirrors, LED Tail Lights, S3 Pedals, Tints, Carbon Trims.

    Items for Sale
    Read My Blog & Build Thread


  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    Ok, it's official, the A rev module doesn't support the rain and light sensor. It was meant to only support the light sensor, back in 2004.

    I hope to test a N module soon to see if it works..will be back with updates.

  24. #23
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    25
    Just installed a C module, 21 bytes, everything works ok, no more errors.

 

 

Similar Threads

  1. How to fit Auto Lights/Wipers & Auto Dim Mirror to 2006 RS4
    By JR Tuning Ltd in forum General Technical / How To
    Replies: 5
    Last Post: 20th November 2010, 19:02
  2. Auto Lights/Wipers v Manual Lights/Wipers
    By A3_SSS in forum A3/S3/Sportback (8P Chassis)
    Replies: 5
    Last Post: 11th July 2009, 13:32
  3. auto wipers, lights etc
    By tdisportuk in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 25th April 2009, 18:30
  4. Is it possibe to retro fit Auto Wipers and Auto Lights
    By StuOwen86 in forum A3/S3/Sportback (8P Chassis)
    Replies: 5
    Last Post: 21st February 2009, 20:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO