JMB RetrofitsChris Nott
Results 1 to 6 of 6
  1. #1
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117

    Engine management light on with fans running and 2 fault codes. HELP?!

    Hi, the other day i noticed when i started my car (2004 2.0 tdi) the engine jumped to 1600 revs before settling at normal tickover 8-900. Like i had started it with part throttle.

    Next both the fans on the radiator were running at full speed even tho the temp guage was still at 50 degrees C.

    I got a friends code reader on it and the 2 main codes thrown were:
    19463 camshaft position sensor (G40): No signal
    P3007 - 000 - - - Intermittant

    and

    16502 - Engine coolant temp sensor (G62): Signal too high
    P0118 - 000 - -


    Having done a search of this forum i had a read and decided to change the coolant temp sensor. I replaced the temp sensor twice (just incase i picked up a faulty one) and still as soon as the i put the ignition on the fans run at full speed.

    Anyone got any advice or tips before i take it to audi as ive just moved house and really cant afford audi prices at the moment, thanks.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    I think the two problems are not connected. You need to clear the faults and re-scan the car first.

    The engine management light is on due to the camshaft position sensor (G40) being faulty ( see 19463/P3007/012295 - Ross-Tech Wiki )

    As far as the fans are concerned I think I am right in saying there are two temperature sensors, one of which is actually in the fan. The only way this can be fixed afaik is to replace the fan units. The sensor you have replaced is probably ok (and the fault code will disappear after clearing and not return ) but the fans will still run if the other one is faulty.

    Edit: by the way there are many VAG independent garages that charge much less than Audi but have all the expertise and facilities required. Just Google for your area.
    Last edited by mike foster; 29th September 2011 at 08:54.

  4. #3
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117
    Thnks for reply mate ,another question which sensor provides info to temp guage ?and which sensor provides info to ecu as the engine seems to be overfuelling and a bit smokey ,is g62 specific to one temp sensor or both ? car feels quite a bit quicker ?faults have been cleared 3 times but same codes appear again , sorry for all questions but trying to sort asap , regards crunch

  5. #4
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Sorry Crunch - I'm not an expert - just passing on info that I have gleaned from the forum. I don't know the answers to your questions but hopefully someone else will come along to help.

    Good luck and please let us all know the final answer for the benefit of all !

  6. #5
    Crunch's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    117
    ok mate thanks for getting back to me regards crunch

  7. #6
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    You're welcome - any experts out there ( A8, NHN, etc. etc. ) who can help with the problem.

    Cheers guys !

 

 

Similar Threads

  1. Could running higher octane fuel put engine management light on?
    By dellboy in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 5th May 2011, 19:54
  2. Iphone App - Diagnostics codes - for engine management
    By mitch2575 in forum General Chat
    Replies: 3
    Last Post: 15th November 2010, 14:06
  3. A6 1.9 TDI engine management ? - diagnostic codes
    By oxford_hippo in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 3
    Last Post: 18th May 2010, 23:15
  4. A3 Sportback 2.0T engine management fault
    By JimmyJames in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 14th November 2007, 19:14
  5. Fault code 17544 by engine management..
    By prel2000 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 18th May 2007, 22:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO